Can't change Camera Upload settings after Server changed name

android-mobile

#1

It kicks me out and I can't change settings. The same for iOS.


#2

I can’t reproduce this. Can you explain the steps you did? Also try turning the camera upload off/in a few times to make sure the server name changes to the new one. The app caches the info for a little bit but toggling the button should get it to update. It then works fine for me.


#3

This literally just happened to me. I fixed it by going in the app on the phone, there is a section in the settings under advanced to reset the camera upload feature. Just do this and you should be able to start uploading again.


#4

I just had the same problem but it appears the reset option in advanced settings has been removed. I had to re-install Plex to select a new server for camera uploads.

Steps to reproduce:

  1. Setup Camera Upload in Android for a specific server
  2. Remove that server from the network
  3. Try to change settings for Camera Upload

#5

Same problem here, removed the app from my Samsung S7 and reinstalled, now I’m waiting while my phone uploads 2,500 duplicate photos :’(


#6

I have the same problem as the original poster. As a note to MovieFan.Plex - When selecting ‘Camera Upload’ in the settings, it gives an error saying the selected server is not reachable. The only option is pressing ‘ok’. This takes you back to the general ‘settings’ menu. There is never any point where you can select to turn off the camera upload feature in order to select a different server.

Re Darewood: I don’t see any option under ‘Advanced’ to reset the camera upload feature.

As a side note, there doesn’t appear to be any way to remove an old server from the list of ‘locations’ in the android app.

My settings menu lists version as 6.7.1.2498


#7

I just migrated to newly built Rockstor NAS.
I had both servers running for a few days while I sorted things out.
Today I renamed my Rockstor plex server to the same name as the original server, then removed the original (now unavailable) server from the list.

I was able to migrate all the metatdata and databases over from Windows to centos successfully.

Every is humming along nicely, except for the camera uploads. I get the same error as everyone is posting.
I’m not sure what resetting camera upload actually does in the app. Am I going to get a bucket of duplicates when I do this and re-enable on the new server?


#8

I also have this issue with the Android App. Just rebuilt my server and I’m unable to change the android app camera upload settings. Help.


#9

Chiming in. I also have run into this and uninstalling and re-installing is the only way I’ve found to sidestep this issue.
Interesting that someone said that there was a setting for this but was removed.


#10

Same issue for months. Too bad Plex cannot fix this issue after a year+


#11

I had this same issue when I switched to a new Diskstation and shut down the Plex server on the old Diskstation. The only way I found to clear this was to go to the Android apps, select Plex, and clear the app data. Then I had to go through the whole setup rigamarole again and things were peachy.