Can't enable remote access

server-windows

#1

Hey, this really baffles me.
My server is unavailable from outside my network. Something is actively blocking the port, and I have no idea what it is.

Port 32400 has been opened just about anywhere. I'm not using Windows Firewall, and instead I whitelisted it in my Kaspersky.
My TP-Link Archer VR600 router has the port forwarded, and every step of the troubleshooting document was double-checked.

What am I missing here?


#2

Until canyouseeme.org shows success there is something wrong along the path.


#3

when I enabled port forwarding in my router, for some reason it wasn’t ported externally to 32400 and was another random port, once I put both internal and external ports and set my computer to static IP it worked


#4

after the server update i got today for plex now my server is unavailable from outside my network also. even my cell phone on the same network cant see my plex server now, ports havnt changed, help?


#5

@nokdim said:
Until canyouseeme.org shows success there is something wrong along the path.
That’s exactly the problem. It can’t, and I can’t figure out what exactly is wrong along the path.

@Mini_Server said:
when I enabled port forwarding in my router, for some reason it wasn’t ported externally to 32400 and was another random port, once I put both internal and external ports and set my computer to static IP it worked
Did that. Internal and external ports are set and static IP is defined (in both router and PC). Still have a problem.

Also tried pausing any kind of antivirus/firewall protection, disabling windows defender and closing every piece of unneeded software. No luck.

@bubbaedc said:
after the server update i got today for plex now my server is unavailable from outside my network also. even my cell phone on the same network cant see my plex server now, ports havnt changed, help?
Been happening since day 1, regardless of updates.


#6

Can you post a shot of your port forwarding setup?


#7



What am I missing?


#8

Protocol in the router should be TCP only, if I’m not mistaken?


#9

@AmazingRando24 said:
Protocol in the router should be TCP only, if I’m not mistaken?

Changed it. Connection is still being refused, when checking from canyouseeme.org. What the hell could be refusing it?


#10

Why do you have port forwarding setup on your PC? That Plex properties screen.

And your PC is .102 right?


#11

Tried configuring the windows firewall as well.

Yeah, locally I’m 192.168.1.102


#12

For me, I use a Netgear 6700 router, and I actually had to disable manually setting up port forwarding (which I’ve used for years, without issue until about a month ago) and just let uPnP on the router handle things automatically on its own.


#13

@“Smiling Maybe” said:
For me, I use a Netgear 6700 router, and I actually had to disable manually setting up port forwarding (which I’ve used for years, without issue until about a month ago) and just let uPnP on the router handle things automatically on its own.

UPnP works, and Plex is even handling it pretty well by opening up a port in my router - but I still can’t establish remote connection.
That’s why I went through other steps to begin with.


#14

What do your settings look like in Plex?
Settings > Server > Remote


#15

@AmazingRando24 said:
What do your settings look like in Plex?
Settings > Server > Remote

That’s exactly what it looks like in my configuration.


#16

So if I was you this is what I would try.

  1. Download a copy of this MiniWeb and run it on the same PC.
    (If you have something else on port 80 already use a different port like 8080 or 8888)

  2. Once that is up you should be able to browse to http://192.168.1.24 and see the default miniweb blue page

  3. Setup a new port forward on your TP-Link Archer VR600 for port 80 or whatever port you specified
    Note: Port 80 is reserved on the TP-Link https://www.tp-link.com/us/faq-72.html
    So might be best to use like 8080 or something else

  4. go to canyouseeme.org and verify this new port shows Success

This will eliminate Plex as being the issue if it also does not show Success.

Only other thing in line would be your local OS FIrewall…


#17

@nokdim said:
So if I was you this is what I would try.

  1. Download a copy of this MiniWeb and run it on the same PC.
    (If you have something else on port 80 already use a different port like 8080 or 8888)

  2. Once that is up you should be able to browse to http://192.168.1.24 and see the default miniweb blue page

  3. Setup a new port forward on your TP-Link Archer VR600 for port 80 or whatever port you specified
    Note: Port 80 is reserved on the TP-Link https://www.tp-link.com/us/faq-72.html
    So might be best to use like 8080 or something else

  4. go to canyouseeme.org and verify this new port shows Success

This will eliminate Plex as being the issue if it also does not show Success.

Only other thing in line would be your local OS FIrewall…

Hey,
The port it opened is 8000.
When browsing to http://192.168.1.102:8000/, I got the blue page you’ve mentioned.

Then, I mapped is as follows:

Following which, I paused Kaspersky, and added rules to the Win10 firewall to allow both 8080 and 8000 (just in case, both inbound and outbound).

In http://canyouseeme.org/ - connection is still being refused.

So, what am I missing? When Kaspersky is paused, Windows firewall both disabled AND configured to allow these ports, something is still refusing the connection. What could this possibly be?


#18

What are the first 3 octets of your TP-Link Archer VR600 WAN interface IP?
Does that IP match what canyouseeme.org shows?

show look something similar to this


#19

Actually, no!
The address the router “knows” does not match the one I see when checking myself externally.

What gives? How does this happen?


#20

You are in a double Nat situation.

You need to call your ISP and ask for a static public IP.