Can't get Plex to work on my 55" Samsung (UN55KS800DF)

smart-tv

#1

Samsung TV Model: UN55KS800DF Type: UN55KS800D

The Plex app on the TV says: "delstar is offline or unreachable"
"delstar" is the name of my Plex server on my PC (running Windows 7).

On my PC I run IPConfig at a DOS Prompt (cmd) and get the IP address of my PC. I then enter that into the Samsung TV Plex app under Manual Servers. This didn't work. I do not get the "ipaddress is offline or unreachable" message, so I know that the address and port I have entered are correct. Also, I know that it can see my server because it tells me the name of it.

The Plex app works when I run it from a Roku box or stick, my Android tablets, my Android phone, and the Apple phones in the house. So, I know my Plex server itself is fine. My stupid Samsung TV just doesn't want me to use it for some reason.

I have tried going into the Plex server settings (the local web based page at http://127.0.0.1:32400/web/index.html) and changing the "Secure Connections" option to "Disabled" (under Server / Network), but that didn't help either.

I don't know what else to try. I have read several topics about people having issues with Plex on Samsung TVs, but nothing I have read helps me. I have the latest version of Plex software on my PC and on my TV. Plex works everywhere except on my Samsung.

Any ideas or help will be appreciated.