Can't locate server



I built a new home server (Windows 10 Pro) and, yesterday, I installed the latest Media Server - 3.9.1 - but cannot connect to it thru my Roku 2.

I have followed all the troubleshooting tips, e.g. Verified my Internet and network connectivity; removed and reinstalled the Plex channel on Roku; signed out of Plex on the app and my computer, restarted, logged into Plex on my computer then the app - none have been successful.

Media Server worked fine on my old computer. I'm really mystified why it refuses to cooperate.



First turn off required secure connections on both the server and in the Roku app. If that works add back security until it does not.

Also be sure that your server and your Roku are both logged into your same account at Plex.


Thanks. The only thing I have been able to figure out is that both my old and new servers were listed under Devices.

I removed my old server and was able to establish a "Direct Connection" which works but has a few issues with playback. But it's at least working on both Rokus. Sort of. I can access all my files but they take longer to load and they hang at least a couple of times during playback.

My computer hardware changed but the OS is still the same - Windows 10 Pro 64-bit. Everything else is unchanged. Even the server IP is the same. I take that back. The only hardware change is a 5-port unmanaged switch between the server and my Surfboard modem/router. In theory, though, that should not matter. There are no other communications issues with devices on the switch.

I've removed the app from both Rokus and the server then reinstalled. I've followed the instructions given to reset the connection explicitly. My VPN isn't even running on the server, much less connected.

It's problems like this that turned me away from Plex a few years ago. Really frustrating.


When you have connection issues and turning off the require secure connection setting on your Roku does not fix it, you can try to isolate the issue by accessing Plex from another type of Plex player app. If you only have Rokus, you can always use a browser to access the Plex Web player app. See Opening Plex Web App.

Try accessing Plex Web using the browser on a computer, tablet, or phone other than your Plex Media Server computer. Connect using the same method as your Roku (Ethernet cable to your router or logged into your home wireless network) and from the same distance from your router (do not stand next to your router if your Roku is on the other side of your home).

If Plex has the same issue with the Plex Web app when using the same type of home network connection as your Roku, then most likely it is an issue with either your home networking , the permissions/software on your Plex Media Server (PMS) computer, or a setting/hardware limitation of your PMS computer. See Why can't the Plex app find or connect to my Plex Media Server? and refer to the Plex Media Server for Windows section of the forum.

Understand that just because you have no issues using the Plex Web app from a browser on your PMS computer, does not mean the issue is with the Plex app for Roku. Using Plex Web on your PMS computer bypasses any folder permission or firewall/antivirus software that may be blocking access. And it cannot show you any issues with your home network that may limiting access, since they are both on the same machine. Unless the issue your are having on your Roku does not occur on the Plex Web app from a device other than your PMS machine when using the same type of home network connection from the same distance as your Roku, then it is not an issue specific to the Plex app for Roku.


Thanks for the reply. I am unable to connect to the server via the Android app or the web browser. I've uninstalled Media Server, restarted, and reinstalled it. I removed the server and Rokus from Devices and reclaimed the server. I also removed Plex from both Rokus, rebooted them, then added Plex back.

The Rokus are connected by Ethernet, a means by which I cannot test other currently available devices.

My latest efforts yielded the same thing only more predictable. I'm getting a proxy connection because a "direct connection is not possible". This go 'round is much faster and stable than my previous connection, though.

For the time being, the server is the only computer on the network. We have 2 Android phones and an Android tablet. I'm going to repurpose the old server but have not had time to do it.

The only other thing is if I switch from DHCP to static IP addresses. Everything is "seeing" everything else and the new server is configured the same way as the old one.

Another odd issue is remote access. I've forwarded a range of ports but when I try to get Plex to connect for just a second I get a green icon beside Remote Access then it turns red again. Manually specifying a port brings about the same result.

For now anyway it's working reliably allowing unsecure connections only on the same network. When I have more time I'll fiddle with it some more.


Since you have determined that is affecting all Plex player apps and it not just a Plex app for Roku specific issue, when you do have the time to look into the issue more, you should post to the section of the forum for Plex Media Server on your operating system.

Users in that section of the forum are those that all use and are most familiar with PMS on that operating system, so they are more familiar with the most common issues related to PMS on that operating system and can interpret the Plex Media Server logs that may shed more light on your issue.


Thanks. Since I last posted the problem has vanished. I changed nothing network-wise. As mysteriously as it appeared, it went away.

I'll try to document everything as you suggested and post it under the Windows 10 forum.

Thanks for your help!