Cant play my plex collection over sonos

sonos

#1

Hi
I have a plex server installed on my NAS drive ( QNAP). My Sonos can see it, browse all files, load a playlist but then says File cannot be found.
All firmware is up to date. I am unable to enable remote access consistently- it will work for a few days and then just stops connecting for no apparent reason. It is manually configured to Port 42300 as auto connect always failed. In the 18 mths or so I have been trying to get this system to work it probably has only connected all up for a month or so and when it does it is great. I have tried all the fixes from the forums and set my router up correctly (I think), tried with all firewalls disabled. I have tried a windows desktop, a windows laptop, android Samsung and an ipad - none will connect. I have rebooted, reinstalled etc etc. I am at my wits end and about to chuck plex out except it is the only server that "works" with Sonos and a large music collection.
Is there anyone that can help me get this working. I am not tech savvy and will need a VERY simple and clear step thru process to understand answers.

( And pleeease can the plex /sonos system have a classification by folder and a much better system to find tracks than it currently has- ie type in or alphabetical touch rather than having to scroll through hundreds of tracks)

Hoping .....


#2

Hey Plex World!

I have the same issue as @Oversaxed and out of ideas on how to move forward. Everything worked well in the past and I could access and listen to my whole Plex content through Sonos on any device / OS. And suddenly Sonos claims not to find the file any more - though it correctly lists the Plex content. Any idea or advice or update?


#3

I too am having this problem.

I can play from other people’s Plex servers though.

I am guessing it is related to a router problem that I have with port forwarding.

Device in internal network -> internal server ip address. Works fine.
Device external to network -> external ip address. Works fine.
Device in internal network -> external ip address. Doesn’t work

This causes some weird hiccups on my phone when I go from WiFi to cell service. On Sonos, even though it is always on WiFi, it appears to be breaking it.