Casting to Samsung TV from iOS app no longer works



I've noticed the problem of controlling / casting to a my Samsung TV from iOS devices (app v4.7, iPhone 5 and 6s) no longer works as of a few weeks ago. My TV no longer shows as a Player to select from.

I can select the player and cast to/from my PMS to the Samsung TV and my iOS devices, but iOS app no longer identifies my Samsung TV.

Is anyone else experiencing this issue and are there any ideas on how to fix it? The functionality used to work great (before iOS app v4.7).


I'm having the identical issue. All the players on my network show up as available to the web app (including the web app running in a browser on iOS) but all my iOS devices cant see ANY players in the app. I didn't notice if this was related to a new version (of either server or client)...


I've can't cast also from my iPhone 7plus but I my 2012 Samsung smart tv. Any ideas anyone?


I'm having the same problem. My 2012 Samsung smart TV doesn't show up in the choose a player list on my iPhone 7 plex app. Is there something I need this turn on on the tv?


No mods/amins here to evaluate the issue?


What does that mean @haasgo


@TheLids said:
What does that mean @haasgo

I meant that, is there no member of staff who could give response if the team has any sort of idea how this happens? I am suffering the same, with no clue why, because I haven't touched anything from my setup configuration and I cannot cast to my TV, from the app, anymore.


Sorry to hear that @haasgo any idea where we can get help from the plex dev team at all. Or is there no contact with them?


I managed to solve this by added my iPhone IP address (on my wifi network) to the list of players "allowed without auth" in the server setting. It works fine now.


@mdredfearn How did you do that?
How did you get your phone ip address?
And where did you input this info?...The plex server?....where in the software?

Sorry I just can't find where you you would do that, would it be possible to give a more detailed tutorial on what you did?




It's in the Server settings in the web app. Settings > Server > Network > List of IP addresses and networks that are allowed without auth
Hope that sorts it for you. I could not see how to set a range, so I listed all my devices separated by commas. I also set those devices to \static IP on my wifi network so that I don't keep getting a new address and it stops working.


That didn't work, nothing comes up on the iPhone plex app saying cast to samsung tv


Also having this problem, Samsung TV casts fine from PMS (both wired to router), but doesn't show up in IOS 4.9 player list - all other devices show fine...

Any ideas welcome!


Update, reapplied the IP address fix above (There was a space typed before the IP address I hadn't noticed before) and it works fine now, thank you mdredfearn!


Thanks for the workaround suggestion on fixing the issue. I added the IP address and confirm that this solves my original problem.

Would be nice for this to become a 'fixed' issue in the main releases instead of having to apply workarounds when updated releases come out :)


I have the same problem but the workaround doesn't work for me. I have a 2016 samsung tizen tv with latest plex app v3. I have 2 android phones and they see the tv plex app as player and can control it. But i can't from an Ipad. I've added the ips of the tv and the ipad to the List of IP addresses and networks that are allowed without auth and still cant see the tv plex player on iOS.

Any ideas?