Closed Captions always displayed on Vizio plex app



Despite turning off Closed Captions in the TV menus, the subtitles are always on in the Plex app for my Vizio TV. It is very distracting so a fix would be greatly appreciated!


same problem on Apple TV (4th gen). this behaviour only started recently - maybe right around the time of the previous post?

this only happens on the Apple TV Plex App.

ALL of the following Apps / versions permit enabling and disabling captioning:
Web Player
Fire TV
IOS on iPad
IOS on iPhone

it's not the TV doing it - i deliberately have a "dumb" TV (sorry, CIA!) that does not even know about captioning.

in the Apple TV App, you can edit (under Settings) the "subtitles" option to "off" or (in my case) "english (tx3g)" ... either way, they are on.

also - one possibly useful clue is when i try to tell the Apple (Siri) interface to turn subtitles on or off, it presents the error (warning? info?) message: "I can't turn off subtitles at the moment." (or on; whichever command i speak).

i do actually WANT closed captioning enabled at certain times on certain shows; like when i really can't understand the Manchester accent of some BBC show, or when the Very Serious Conversation in a movie is Importantly Whispered Quietly between the principals. Most of the time i leave them off.

but i would really, REALLY, REALLY like to be able to turn them on or off at MY choice.

i suspect the App, not the TV.


@leaded1 said:
Despite turning off Closed Captions in the TV menus, the subtitles are always on in the Plex app for my Vizio TV. It is very distracting so a fix would be greatly appreciated!

Same problem here. Happens on both my Vizio smart TVs. Sometimes it's constant, but sometimes the CC just flickers on and off before anyone could even have a chance to have read them. (Which I don't need to do, and would be happier if they didn't appear at all)

Any response would be appreciated as this thread is 3mos. old, and there's no indication it's been seen by anyone knowledgeable in such things.


Me as well on my Vizio TV. Some shows the captioning stays on all the time but the show plays properly. Other times the captioning starts but playback gets really stuttery.

I only find about 10% of my shows have the captioning at all, but it's still pretty irritating.


Been awaiting a fix for this myself.


This is happening to me also. If I look at the files on my Windows PC or iPad, no closed captions. On the visio, some shows have consistent closed captions, some have awful jittery blinking on-and-off captions.


(on the above I have a VIZIO E390i-A1 )


Same thing for me. I have a Vizio D43-D1 ?


Same here -- Vizio D65-D2

very annoying -- anyway to upvote this?


Same issue here. E4804-b2. Not sure but I'm thinking a chromecast might fix the issue?


Issues started a few days ago for us. Not ever tv show but many have the cc and won't go away. Cc button does not work on the tv remote. Only happens on plex.

Netflix is fine.. Android box has no issues either.


I have the exact same problem on my Vizio D40-D1 when watching a channel on Plex.

I also have a roku, no issues with subtitles.


I'm also having this same problem on a Vizio. Can't for the life of me remove the closed captioning. Has anyone had any luck in getting Plex to not pass CC information to the TV?


I also have this issue with a Vizio D650i-B2. I tried finding CC options in the TV menus but no luck. I changed over to the Antenna input (the only input that responds to the CC button on the remote) and turned off CC there. Still no dice. It seems Vizio TV’s are picking up CC encoded into the video, this only happens to broadcast TV recordings. I have tried using HD Homerun and SiliconDust recorders to record OTA TV and both produce videos that allow the TV to show the Closed Captioning. I do not have model numbers because I borrowed them from friends and was not able to find options to disable CC in those recorded videos. This does not happen to Netflix app or movies and TV shows ripped from DVD. Only OTA broadcast files played with Plex. There is no subtitle track, no subtitle file next to the video and no subtitle plugin installed. The subtitles are shown in the TV’s CC font, not the Plex subtitle font.


I found the following on Vizio’s website:
f you are using a cable box, satellite box, or third-party device (like a streaming media player) attached to the HDMI, component, or AV connector, closed captioning (CC) is controlled by THAT device. The option to turn on CC will be based on the external source device and may require contacting the manufacturer.

If you are using the coaxial (RF) connector, you can control the closed captioning with the CC button on the remote or through the on-screen menu.


I can confirm this IS the TV doing the closed captioning as I have files that lock up when this happens but the closed captioning still continues and the audio works. If this was in the video stream the caption would also freeze.

this has been going on for a while now and it affects all my vizios P,D,E and M series. my whole house is Vizio and this is driving me crazy. I have one sony TV used as a computer monitor and it does not have these problems



Anyone have any luck solving this? I’d like to buy a TV that works with my Plex system. I have a small Visio that is exhibiting this problem, and without a fix, there is no point in buying another Visio.

Thanks in advance,


I only have this problem on my 22"
I have a 42E, 50E, and 55M" in which I go to the player
settings and turn off “Allow Direct Play”
They will go away, but not on my 22".