Collections show up between my movies

android-tv
fire-tv

#1

I have a Philips android TV with Plex on it. When I view my movies on this, movies and collections are both shown. Since Plex creates collections as well, a lot of collections just have one movie in it.
Because movies and collections are both shown, it just makes a very annoyingly long list.
Is there a way to show just movies? I know that on the top of the screen I can apply a filter, by default this is set to 'movies', the other option I have is 'collections'.

When it's set to 'collections', it just shows collections only. When I set it back to movies, movies and collections are shown.
How can I get a movies-only view?


#2

sure… use Plex Web, edit the settings of your movie library and change the collections option in the advanced settings to “deactivate” – this way no collection will show up inline with your movies.

as for your point on Plex automatically creating collections… this only happens if you configured it that way! double-check the following 2 configurations:

  1. agent settings (in general or for this library): do you have The Movie Database agent configured to download collection information? (checked Use collection info from The Movie Database)
  2. in Settings > Server > Agents > Movies check if you have the applicable agents configured to include embedded metadata… with this setting, Plex will include the “Album” tag from MP4/M4V files as “Collection”

#3

I just went to the web version of the app and added a '0 ’ prefix to the “Sort Name” of each collection and that moved the collections to the top of my page without changing the names.

I actually am finding I like the collections feature.

(oh, and deleted any collection that was pointless because it only had 3 or fewer movies in them)


#4

The idea of collections is nice, they just have a flawed implementation – one which I hope they realize & fix! Like the OP hinted, the collections should not be showing up in the movies view – leave them in the collections view! The current implementation treats the movies view as an ALL view.


#5

@NicFord1 said:
The idea of collections is nice, they just have a flawed implementation – one which I hope they realize & fix! Like the OP hinted, the collections should not be showing up in the movies view – leave them in the collections view! The current implementation treats the movies view as an ALL view.

You can turn off that feature. Just edit your library and go to “advanced” section and choose the collection display option you want.

I keep the inline collection display off due to the bug where collections screw up the go to letter. At least until that BUG is fixed I will keep the inline display off but, in this case, it is good that Plex had the, unusual for them, foresight to allow the display option to be turned off.