Connection refused to my.plexapp.com after trying the addon

plex-for-kodi

#1

I installed the addon to Kodi, but when I clicked the sign in button, I kept getting thrown back out to the Kodi interface.

So I checked the Kodi log and noticed this:
ConnectionError: HTTPSConnectionPool(host='my.plexapp.com', port=443): Max retries exceeded with url: /pins.xml (Caused by NewConnectionError('<requests.packages.urllib3.connection.VerifiedHTTPSConnection object at 0x7fbf1e15a110>: Failed to establish a new connection: [Errno 111] Connection refused',))

And when I browse to https://my.plexapp.com in Chrome, I get ERR_CONNECTION_REFUSED errors. Browsing to the same address from my mobile network works fine.

So my questions are:
Could the addon contain a bug that flooded your site with requests, activating some sort of anti-DoS measure?
Or could this be caused by some other device running plex on my network?
Is anyone able to take a closer look? I'm a bit hesitant to post my IP here but I'd gladly provide it in a private message.


#2

It shouldn't work any different for auth than PMP, Roku, etc clients do. It must be something else, but since chrome doesn't work anymore, its outside of this add-on specifically.

Might want to post in another section to get visibility by Plex support guys.


#3

Fair enough. I just thought I should raise it here since it seemed like more than coincidence and since I haven't signed into Plex from any other devices recently.


#4

Do any devices work? I would think if you're getting connection refused to my.plexapp.com that none of myplex works now.


#5

Well, it appears that my Pi-hole is a bit overzealous with the ad filtering tonight. Changed my DNS to 8.8.8.8 and everything is peachy. Sorry for the bother but thanks for the assistance. :)


#6

Glad you got it working and let us know what you think of the add-on! Also I hadn't seen pi-hole, that looks pretty neat. If I wasn't already running ad-blocking on my asusWRT router I would look into it further. :)


#7

@Edisman said:
Well, it appears that my Pi-hole is a bit overzealous with the ad filtering tonight. Changed my DNS to 8.8.8.8 and everything is peachy. Sorry for the bother but thanks for the assistance. :)

I'm having the same issue but really don't want to give up my pi-hole (it's great at ad blocking). Is there any way around this?


#8

Whitelist my.plexapp.com in the pi-hole?


#9

@keithah Tried that; white-listed both my.plexapp.com and plexapp.com but still no go.


#10

No idea, never used a pi-hole. You need to talk to them to see why they are blocking it.


#11

I whitelisted my.plexapp.com, plexapp.com and plex.tv and it works for me now. Just make sure to update the filters after whitelisting since it's applied when the filters are generated.