# Database Error When Removing Label Containing Emoji

**URL:** <https://forums.plex.tv/t/database-error-when-removing-label-containing-emoji/886440>\
**Category:** Plex Media Server\
**Tags:** server-linux, server-unraid, library-management\
**Created:** [August 27, 2024, 2:24pm UTC](https://forums.plex.tv/t/database-error-when-removing-label-containing-emoji/886440 "2024-08-27T14:24:06Z")\
**Posts on this page:** 12\
**Page:** 1

<div class="post-metadata">

**Author:** ![werkkrew](https://avatars.discourse-cdn.com/v4/letter/w/e274bd/32.png) [@werkkrew](https://forums.plex.tv/u/werkkrew)\
**Post date:** [August 27, 2024, 2:24pm UTC](https://forums.plex.tv/t/database-error-when-removing-label-containing-emoji/886440/1 "2024-08-27T14:24:06Z")

</div>

Server Version#: 1.41.0.8911

I have items in my library with labels which contain emoji’s. Adding these labels worked find but when removing them I get an error.

The error occurs both when using the api directly as well as the Plex web UI to edit the libary items.

```auto
Aug 27, 2024 09:25:12.762 [22489983888184] Info — Request: [172.18.0.22:39822 (WAN)] PUT /library/sections/1/all?id=271971&label.locked=1&label%5B%5D.tag.tag-=%25F0%259F%25A5%25A6%2520420%2520Day%2520Movies&type=1 (8 live) #b16dc6 GZIP Signed-in Token (werkkrew) (Firefox) / Accept => */* / Accept-Encoding => gzip, deflate / Connection => keep-alive / Content-Length => 0 / Host => 192.168.1.230:32400 / User-Agent => python-requests/2.32.3 / X-Plex-Client-Identifier => 26862f15-07c6-45cc-b6d7-c078b4709c98 / X-Plex-Device => Linux / X-Plex-Device-Name => fcaaed031b3d / X-Plex-Features => external-media / X-Plex-Language => en / X-Plex-Platform => Linux / X-Plex-Platform-Version => 6.1.99-Unraid / X-Plex-Product => PlexAPI / X-Plex-Provides => controller / X-Plex-Sync-Version => 2 / X-Plex-Token => xxxxxxxxxxxxxxxxxxxx / X-Plex-Version => 4.15.15
Aug 27, 2024 09:25:16.947 [22490409511736] Info — Completed: [172.18.0.22:39822] 500 PUT /library/sections/1/all?id=271971&label.locked=1&label%5B%5D.tag.tag-=%25F0%259F%25A5%25A6%2520420%2520Day%2520Movies&type=1 (8 live) #b16dc6 GZIP 4185ms 405 bytes (pipelined: 1467)

```

```auto
[Req#b6f58a] SQLITE3:0x80000001, 1, statement aborts at 16: [DELETE FROM taggings WHERE (tag_id IN (SELECT tg.id FROM tags tg WHERE (tg.tag IN (SELECT value FROM json_each(:C1)) AND tg.tag_type=:C2)) AND metadata_item_id IN (SELECT value FROM json_each(:C3)))] malformed JSON

```

There is also someone else having the same issue as me: [Reddit - Dive into anything](https://www.reddit.com/r/PleX/comments/1f1fru6/unable_to_remove_label_from_media/)

---

<div class="post-metadata">

**Author:** ![Mio](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/mio/32/133816_2.png) [@Mio](https://forums.plex.tv/u/Mio)\
**Post date:** [August 28, 2024, 7:15pm UTC](https://forums.plex.tv/t/database-error-when-removing-label-containing-emoji/886440/2 "2024-08-28T19:15:07Z")

</div>

Was just coming to post this!  
I have the same issue with Version 1.40.5.8897.

---

<div class="post-metadata">

**Author:** ![vanburen](https://avatars.discourse-cdn.com/v4/letter/v/d07c76/32.png) [@vanburen](https://forums.plex.tv/u/vanburen)\
**Post date:** [September 18, 2024, 5:49pm UTC](https://forums.plex.tv/t/database-error-when-removing-label-containing-emoji/886440/3 "2024-09-18T17:49:29Z")

</div>

I’m also seeing this issue when trying to remove items from Collections that has an emoji in the title.

`PLEX Version 1.41.0.8992`

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [September 18, 2024, 7:39pm UTC](https://forums.plex.tv/t/database-error-when-removing-label-containing-emoji/886440/4 "2024-09-18T19:39:10Z")

</div>

For those items and collections with emoji’s in them,

Can you please share:

1. The XML (Hover - Get Info - View XML) for the media part where it shows the emoji encoded in the info
2. How it looks in the collection as you go to delete it
3. The server DEBUG logs after deleting it.
4. Where the server is reporting DB error when removing the label

---

<div class="post-metadata">

**Author:** ![vanburen](https://avatars.discourse-cdn.com/v4/letter/v/d07c76/32.png) [@vanburen](https://forums.plex.tv/u/vanburen)\
**Post date:** [September 19, 2024, 7:09pm UTC](https://forums.plex.tv/t/database-error-when-removing-label-containing-emoji/886440/5 "2024-09-19T19:09:29Z")

</div>

Hopefully this is enough info to start.

1. For the XML data I’m not sure how to go about that because this was a Collection of television series so the label was on the series and as far as I can tell you can only get XML data on a specific episode/move file. Let me know if there is a way to get this info that I’m missing.
2. Here’s an image of the series UI label. If I remove the label the label, then save the item, then reopen the Edit dialog the label is still there. Here’s what the label is: `🚀 Fantasy &amp; Sci-Fi Series`  
 ![image_label](https://global.discourse-cdn.com/plex/original/4X/0/7/e/07e56ef255af579ef0ffd3d0b4996204419d0c38.png)
3. Debug logs

```auto
Sep 19, 2024 14:47:00.884 [140053143628600] Debug — Request: [127.0.0.1:38404 (Loopback)] GET /identity (10 live) #f12 Signed-in
Sep 19, 2024 14:47:00.884 [140053233806136] Debug — Completed: [127.0.0.1:38404] 200 GET /identity (10 live) #f12 0ms 417 bytes (pipelined: 1)
Sep 19, 2024 14:47:01.577 [140053110074168] Debug — Request: [####REDACTED_INFO####:55045 (Allowed Network (Subnet))] OPTIONS /library/sections/4/all?type=2&id=628185&includeExternalMedia=1&label%5B%5D.tag.tag-=%25F0%259F%259A%2580%2520Fantasy%2520%2526%2520Sci-Fi%2520Series (9 live) #f1e TLS GZIP Signed-in Token ()
Sep 19, 2024 14:47:01.577 [140053233806136] Debug — Completed: [####REDACTED_INFO####:55045] 200 OPTIONS /library/sections/4/all?type=2&id=628185&includeExternalMedia=1&label%5B%5D.tag.tag-=%25F0%259F%259A%2580%2520Fantasy%2520%2526%2520Sci-Fi%2520Series (9 live) #f1e TLS GZIP 0ms 385 bytes (pipelined: 15)
Sep 19, 2024 14:47:01.588 [140053229611832] Debug — Request came in with unrecognized domain / IP '####REDACTED_INFO####' in header Referer; treating as non-local
Sep 19, 2024 14:47:01.588 [140053143628600] Info — Request: [####REDACTED_INFO####:55045 (Allowed Network (Subnet))] PUT /library/sections/4/all?type=2&id=628185&includeExternalMedia=1&label%5B%5D.tag.tag-=%25F0%259F%259A%2580%2520Fantasy%2520%2526%2520Sci-Fi%2520Series (9 live) #f2a TLS GZIP Signed-in Token ####REDACTED_INFO####
Sep 19, 2024 14:47:01.600 [140053143628600] Debug — [Req#f2a] Collections: Found 0 collections tags in section 4.
Sep 19, 2024 14:47:01.600 [140053143628600] Debug — [Req#f2a] Collections: We had 0 collections in the library already.
Sep 19, 2024 14:47:01.600 [140053143628600] Debug — [Req#f2a] Collections: Synced tags in section 4 in 10ms.
Sep 19, 2024 14:47:01.610 [140053143628600] Debug — [Req#f2a] Collections: Found 0 collections tags in section 4.
Sep 19, 2024 14:47:01.610 [140053143628600] Debug — [Req#f2a] Collections: We had 0 collections in the library already.
Sep 19, 2024 14:47:01.610 [140053143628600] Debug — [Req#f2a] Collections: Synced tags in section 4 in 20ms.
Sep 19, 2024 14:47:01.619 [140053143628600] Debug — [Req#f2a] Collections: Found 0 collections tags in section 4.
Sep 19, 2024 14:47:01.619 [140053143628600] Debug — [Req#f2a] Collections: We had 0 collections in the library already.
Sep 19, 2024 14:47:01.619 [140053143628600] Debug — [Req#f2a] Collections: Synced tags in section 4 in 30ms.
Sep 19, 2024 14:47:01.650 [140053143628600] Debug — [Req#f2a] Collections: Refreshed attributes for 0 collections in section 4 in 30ms.
Sep 19, 2024 14:47:01.665 [140053143628600] Debug — [Req#f2a] Collection: Refreshed visibility in section 4 in 15ms.
Sep 19, 2024 14:47:01.665 [140053229611832] Info — Completed: [####REDACTED_INFO####:55045] 200 PUT /library/sections/4/all?type=2&id=628185&includeExternalMedia=1&label%5B%5D.tag.tag-=%25F0%259F%259A%2580%2520Fantasy%2520%2526%2520Sci-Fi%2520Series (9 live) #f2a TLS GZIP 76ms 329 bytes (pipelined: 16)

```

Thanks

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [September 19, 2024, 7:59pm UTC](https://forums.plex.tv/t/database-error-when-removing-label-containing-emoji/886440/6 "2024-09-19T19:59:17Z")

</div>

@vanburen

Sending you a PM for your Logs ZIP please.  
The snippet isn’t enough for Engineering.

---

<div class="post-metadata">

**Author:** ![KSPL3X](https://avatars.discourse-cdn.com/v4/letter/k/a3d4f5/32.png) [@KSPL3X](https://forums.plex.tv/u/KSPL3X)\
**Post date:** [October 9, 2024, 1:28pm UTC](https://forums.plex.tv/t/database-error-when-removing-label-containing-emoji/886440/7 "2024-10-09T13:28:36Z")

</div>

Can I ask if there has been any movement on this? The issue is still seen on the latest beta release.

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [October 9, 2024, 3:53pm UTC](https://forums.plex.tv/t/database-error-when-removing-label-containing-emoji/886440/8 "2024-10-09T15:53:46Z")

</div>

The issue was been submitted to Engineering.  
I have no feedback/info on when they’ll resolve it.

---

<div class="post-metadata">

**Author:** ![core897](https://avatars.discourse-cdn.com/v4/letter/c/dc4da7/32.png) [@core897](https://forums.plex.tv/u/core897)\
**Post date:** [November 25, 2024, 5:33pm UTC](https://forums.plex.tv/t/database-error-when-removing-label-containing-emoji/886440/9 "2024-11-25T17:33:53Z")

</div>

Hello, It’s been nearly 2 months and this is still very much an issue.

Any chance the engineering team will have a fix out soon?

Thanks so much

---

<div class="post-metadata">

**Author:** ![Mio](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/mio/32/133816_2.png) [@Mio](https://forums.plex.tv/u/Mio)\
**Post date:** [January 4, 2025, 3:58pm UTC](https://forums.plex.tv/t/database-error-when-removing-label-containing-emoji/886440/10 "2025-01-04T15:58:42Z")

</div>

Can we get an update on this? Thank you.

---

<div class="post-metadata">

**Author:** ![AnonFawkes](https://avatars.discourse-cdn.com/v4/letter/a/5e9695/32.png) [@AnonFawkes](https://forums.plex.tv/u/AnonFawkes)\
**Post date:** [February 4, 2025, 8:58pm UTC](https://forums.plex.tv/t/database-error-when-removing-label-containing-emoji/886440/11 "2025-02-04T20:58:22Z")

</div>

Any updates on this? Still an issue on the current beta

---

<div class="post-metadata">

**Author:** ![system](https://global.discourse-cdn.com/plex/original/3X/2/a/2acb9765406f63293d357b4ec509ec39aa28f2ad.png) [@system](https://forums.plex.tv/u/system)\
**Post date:** [May 5, 2025, 8:59pm UTC](https://forums.plex.tv/t/database-error-when-removing-label-containing-emoji/886440/12 "2025-05-05T20:59:01Z")

</div>

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.
