# Debugging setup failures

**URL:** <https://forums.plex.tv/t/debugging-setup-failures/11495>\
**Category:** Plex Media Server\
**Tags:** server-windows\
**Created:** [October 29, 2011, 2:05am UTC](https://forums.plex.tv/t/debugging-setup-failures/11495 "2011-10-29T02:05:57Z")\
**Posts on this page:** 20\
**Page:** 18

<div class="post-metadata">

**Author:** ![sa2000](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/sa2000/32/6922_2.png) [@sa2000](https://forums.plex.tv/u/sa2000)\
**Post date:** [February 22, 2015, 9:56pm UTC](https://forums.plex.tv/t/debugging-setup-failures/11495/341 "2015-02-22T21:56:46Z")

</div>

> Well,I have restore my computer to a previous safe point and now all is ok

Thanks for the feedback. Can you pin it down to anything you installed since then?

---

<div class="post-metadata">

**Author:** ![gregnj](https://avatars.discourse-cdn.com/v4/letter/g/a88e57/32.png) [@gregnj](https://forums.plex.tv/u/gregnj)\
**Post date:** [February 23, 2015, 12:26am UTC](https://forums.plex.tv/t/debugging-setup-failures/11495/342 "2015-02-23T00:26:35Z")

</div>

I am having simila problms. First time using...dowwnload create account sign in then whn starting setup the logo coms up thn gos black.

Th web page is empty. using th try icon clicking on media manager I gt th same thing. any ideas?

---

<div class="post-metadata">

**Author:** ![sa2000](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/sa2000/32/6922_2.png) [@sa2000](https://forums.plex.tv/u/sa2000)\
**Post date:** [February 23, 2015, 12:37am UTC](https://forums.plex.tv/t/debugging-setup-failures/11495/343 "2015-02-23T00:37:32Z")

</div>

> I am having simila problms. First time using...dowwnload create account sign in then whn starting setup the logo coms up thn gos black.
> 
> Th web page is empty. using th try icon clicking on media manager I gt th same thing. any ideas?

Hi

Similar problems to who?

The browser is loaded on initial setup. Issues in the past have been caused by browser add-ons and security / privacy settings&nbsp;

You can try changing default browser (control panel / default programs) and rerun setup

---

<div class="post-metadata">

**Author:** ![richbutler1\_gmail.com](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/richbutler1_gmail.com/32/9005_2.png) [@richbutler1\_gmail.com](https://forums.plex.tv/u/richbutler1_gmail.com)\
**Post date:** [February 23, 2015, 7:34pm UTC](https://forums.plex.tv/t/debugging-setup-failures/11495/344 "2015-02-23T19:34:43Z")

</div>

I've been battling install error for a day now. &nbsp;I has lost my agent list in a prior update, not sure how. &nbsp;I thought it would be easy to do a repair, didn't work. &nbsp;Then I renamed my Plex Media Server folder under my user folder. &nbsp;Deleted Framework and System bundles. &nbsp; Uninstalled, reinstalled. &nbsp;No go. &nbsp;Manually added a Firewall Inbound rule for port 32400 explicitely, all domains allowed. &nbsp; Uninstalled again, deleted registry entry completely, deleted PMS folder under Users completely. &nbsp;Uninstalled Plex As A Service helper. &nbsp;Uninstalled virus scanner. &nbsp;So that should have put me to a fresh install state. &nbsp; Reinstalled. &nbsp;Same error.

There is a ghost in this machine (latest version) that needs more urgent investigation.

I am now about to uninstall again and try the prior version.[EDIT]: &nbsp;but will try to use ioBit Uninstaller to completely strip PMS and try one last time with latest version(Yes, the digital signature was fine).

Further detail: &nbsp;This refers to 0.9.1107 running on Win8Pro. &nbsp;I am now going to try 0.9.1112 &nbsp; I was unaware that the main PMS download link still points to 0.9.1107

UPDATE: &nbsp;Tried clean install of 0.9.1112, same error "A problem has been detected with a core component of Plex Media Service" &nbsp;

Only 3 errors in PMS Log:

Feb 23, 2015 14:55:59:396 [4148] **ERROR** - Error cleaning up deactivated plug-ins.

Feb 23, 2015 14:55:59:397 [3300] DEBUG - File C:\Users\MyUserName\AppData\Local\Plex Media Server\Plug-ins changed: -1 =\> 1424721344.

Feb 23, 2015 14:55:59:397 [3300] DEBUG - Scanning for plug-ins in C:\Users\MyUserName\AppData\Local\Plex Media Server\Plug-ins

Feb 23, 2015 14:55:59:408 [3300] DEBUG - Starting plug-in C:\Users\MyUserName\AppData\Local\Plex Media Server\Plug-ins\System.bundle.

Feb 23, 2015 14:55:59:473 [3300] DEBUG - [com.plexapp.system] Setting plug-in to always running (daemon mode).

Feb 23, 2015 14:55:59:523 [3300] DEBUG - Starting file watcher for com.plexapp.system

Feb 23, 2015 14:55:59:525 [3300] DEBUG - Plugin::createProcess: Creating plugin process: "C:\Program Files (x86)\Plex\Plex Media Server\PlexScriptHost.exe" "C:\Users\MyUserName\AppData\Local\Plex Media Server\Plug-ins\Framework.bundle\Contents\Resources\Versions\2\Python/bootstrap.py" "C:\Users\MyUserName\AppData\Local\Plex Media Server\Plug-ins\System.bundle"

Feb 23, 2015 14:55:59:656 [3300] DEBUG - Spawned plug-in com.plexapp.system with PID 2916

Feb 23, 2015 14:55:59:656 [3300] DEBUG - [com.plexapp.system] Sending command: GET /:/prefixesFeb 23, 2015 14:58:59:672 [3300] ERROR - Timeout or error reading status line from plug-in pipe [com.plexapp.system], we're killing it.

Feb 23, 2015 14:58:59:673 [3300] DEBUG - Stopping [com.plexapp.system].

Feb 23, 2015 14:58:59:673 [3300] DEBUG - [com.plexapp.system] Killing.

Feb 23, 2015 14:58:59:725 [3300] ERROR - Error received reading configuration for com.plexapp.system

Feb 23, 2015 14:58:59:725 [3300] DEBUG - Stopping [com.plexapp.system].

Feb 23, 2015 14:58:59:725 [3300] DEBUG - Done with 1 synchronous plug-in starts, starting the rest in parallel.

Feb 23, 2015 14:58:59:725 [3300] DEBUG - Updating the list of agents known by the system.

Feb 23, 2015 14:58:59:725 [3300] DEBUG - Starting file watcher for com.plexapp.system

Feb 23, 2015 14:58:59:726 [3300] DEBUG - Plugin::createProcess: Creating plugin process: "C:\Program Files (x86)\Plex\Plex Media Server\PlexScriptHost.exe" "C:\Users\MyUserName\AppData\Local\Plex Media Server\Plug-ins\Framework.bundle\Contents\Resources\Versions\2\Python/bootstrap.py" "C:\Users\MyUserName\AppData\Local\Plex Media Server\Plug-ins\System.bundle"

Feb 23, 2015 14:58:59:729 [3300] DEBUG - Spawned plug-in com.plexapp.system with PID 4896

&nbsp;

...[LATER IN LOG FILE]...

Feb 23, 2015 15:00:53:625 [3820] DEBUG - WebSocket: client initiated close

Feb 23, 2015 15:00:53:625 [3820] DEBUG - WebSocket: processed 0 frame(s)

Feb 23, 2015 15:00:53:625 [4128] **ERROR** - handle\_stream\_read error 2 End of file

Feb 23, 2015 15:00:53:625 [4128] DEBUG - Removing notification stream because of error.

Feb 23, 2015 15:01:59:727 [3300] ERROR - Timeout or error reading status line from plug-in pipe [com.plexapp.system], we're killing it.

Feb 23, 2015 15:01:59:727 [3300] DEBUG - Stopping [com.plexapp.system].

Feb 23, 2015 15:01:59:727 [3300] DEBUG - [com.plexapp.system] Killing.

Feb 23, 2015 15:01:59:727 [3300] **ERROR** - Error received reading configuration for com.plexapp.system

Feb 23, 2015 15:01:59:727 [3300] DEBUG - Stopping [com.plexapp.system].

Feb 23, 2015 15:01:59:727 [3300] DEBUG - System bundle was restarted, we need to notify other plug-ins

Feb 23, 2015 15:01:59:727 [2692] DEBUG - Starting file watcher for com.plexapp.system

Feb 23, 2015 15:01:59:728 [2692] DEBUG - Plugin::createProcess: Creating plugin process: "C:\Program Files (x86)\Plex\Plex Media Server\PlexScriptHost.exe" "C:\Users

&nbsp;

\MyUserName\AppData\Local\Plex Media Server\Plug-ins\Framework.bundle\Contents\Resources\Versions\2\Python/bootstrap.py" "C:\Users\MyUserName\AppData\Local\Plex Media&nbsp;

&nbsp;

Server\Plug-ins\System.bundle"

Feb 23, 2015 15:01:59:730 [2692] DEBUG - Spawned plug-in com.plexapp.system with PID 2168

Feb 23, 2015 15:01:59:731 [2692] DEBUG - [com.plexapp.system] Sending command: GET /:/prefixesFeb 23, 2015 15:01:59:772 [3300] DEBUG - The system knows about 0&nbsp;

&nbsp;

agents.

Feb 23, 2015 15:01:59:773 [3300] DEBUG - Waiting for all 18 plug-ins to finish starting.

Feb 23, 2015 15:01:59:774 [3148] DEBUG - Starting plug-in C:\Users\MyUserName\AppData\Local\Plex Media Server\Plug-ins\Framework.bundle.

Feb 23, 2015 15:01:59:775 [0556] DEBUG - Starting plug-in C:\Users\MyUserName\AppData\Local\Plex Media Server\Plug-ins\HTbackdrops.bundle.

Feb 23, 2015 15:01:59:783 [4308] DEBUG - Starting plug-in C:\Users\MyUserName\AppData\Local\Plex Media Server\Plug-ins\IMDB.bundle.

Feb 23, 2015 15:01:59:801 [0556] DEBUG - [com.plexapp.agents.htbackdrops] Agent not known by system, so we're starting for sure.

Feb 23, 2015 15:01:59:801 [0556] DEBUG - Starting file watcher for com.plexapp.agents.htbackdrops

Feb 23, 2015 15:01:59:802 [0556] DEBUG - Plugin::createProcess: Creating plugin process: "C:\Program Files (x86)\Plex\Plex Media Server\PlexScriptHost.exe" "C:\Users

&nbsp;

\MyUserName\AppData\Local\Plex Media Server\Plug-ins\Framework.bundle\Contents\Resources\Versions\2\Python/bootstrap.py" "C:\Users\MyUserName\AppData\Local\Plex Media&nbsp;

&nbsp;

Server\Plug-ins\HTbackdrops.bundle"

Feb 23, 2015 15:01:59:806 [0556] DEBUG - Spawned plug-in com.plexapp.agents.htbackdrops with PID 860

Feb 23, 2015 15:01:59:806 [0556] DEBUG - [com.plexapp.agents.htbackdrops] Sending command: GET /:/prefixesFeb 23, 2015 15:01:59:838 [3148] DEBUG - Starting plug-in&nbsp;

&nbsp;

C:\Users\MyUserName\AppData\Local\Plex Media Server\Plug-ins\LastFM.bundle.

Feb 23, 2015 15:01:59:842 [4308] DEBUG - [com.plexapp.agents.imdb] Agent not known by system, so we're starting for sure.

Feb 23, 2015 15:01:59:842 [4308] DEBUG - Starting file watcher for com.plexapp.agents.imdb

Feb 23, 2015 15:01:59:842 [4308] DEBUG - Plugin::createProcess: Creating plugin process: "C:\Program Files (x86)\Plex\Plex Media Server\PlexScriptHost.exe" "C:\Users

&nbsp;

\MyUserName\AppData\Local\Plex Media Server\Plug-ins\Framework.bundle\Contents\Resources\Versions\2\Python/bootstrap.py" "C:\Users\MyUserName\AppData\Local\Plex Media&nbsp;

&nbsp;

Server\Plug-ins\IMDB.bundle"

Feb 23, 2015 15:01:59:845 [4308] DEBUG - Spawned plug-in com.plexapp.agents.imdb with PID 2688

Feb 23, 2015 15:01:59:846 [4308] DEBUG - [com.plexapp.agents.imdb] Sending command: GET /:/prefixesFeb 23, 2015 15:01:59:850 [3148] DEBUG -&nbsp;

&nbsp;

[com.plexapp.agents.lastfm] Agent not known by system, so we're starting for sure.

Feb 23, 2015 15:01:59:850 [3148] DEBUG - Starting file watcher for com.plexapp.agents.lastfm

Feb 23, 2015 15:01:59:850 [3148] DEBUG - Plugin::createProcess: Creating plugin process: "C:\Program Files (x86)\Plex\Plex Media Server\PlexScriptHost.exe" "C:\Users

&nbsp;

\MyUserName\AppData\Local\Plex Media Server\Plug-ins\Framework.bundle\Contents\Resources\Versions\2\Python/bootstrap.py" "C:\Users\MyUserName\AppData\Local\Plex Media&nbsp;

&nbsp;

Server\Plug-ins\LastFM.bundle"

Feb 23, 2015 15:01:59:856 [3148] DEBUG - Spawned plug-in com.plexapp.agents.lastfm with PID 1392

Feb 23, 2015 15:01:59:856 [3148] DEBUG - [com.plexapp.agents.lastfm] Sending command: GET /:/prefixes

&nbsp;

&nbsp;

&nbsp;

PlexPass Lifetime Member,

Rich

---

<div class="post-metadata">

**Author:** ![richbutler1\_gmail.com](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/richbutler1_gmail.com/32/9005_2.png) [@richbutler1\_gmail.com](https://forums.plex.tv/u/richbutler1_gmail.com)\
**Post date:** [February 23, 2015, 8:18pm UTC](https://forums.plex.tv/t/debugging-setup-failures/11495/345 "2015-02-23T20:18:44Z")

</div>

I am at a loss, at a dead stop with my Plex Media Server. &nbsp;Can this be escalated to a Plex Senior Technical support team member?

Regards,

Rich

PlexPass Lifetime Member

---

<div class="post-metadata">

**Author:** ![sa2000](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/sa2000/32/6922_2.png) [@sa2000](https://forums.plex.tv/u/sa2000)\
**Post date:** [February 23, 2015, 9:00pm UTC](https://forums.plex.tv/t/debugging-setup-failures/11495/346 "2015-02-23T21:00:54Z")

</div>

could you take a copy of the **Logs\PMS Plugin Logs** folder and zip it and attach the zip. Will look then at the bundles log files corresponding to the server log you attached

I presume the actual setup (install) went without errors and the issue only arises after launching Plex Media Server

What anti virus / security third party products do you have?

And I presume the firewall inbound rules for tcp port 32400 for all profiles are still in place?

Do you have any proxy? You can check that through:

Control Panel / All Control Panel Items / Internet Options / Connections tab

You may need to do one more system / framework bundles reset. Lets look at the logs first

Edit:

Please also check the firewall settings that separately from the inbound rules for the ports you also have in the program rules, all the Plex Media Server exe files specified as allowed - the most important for the bundles is PlexScriptHost.exe

Just add all the exe files in this folder&nbsp;**C:\Program Files (x86)\Plex\Plex Media Server**

to the firewall programs rules

---

<div class="post-metadata">

**Author:** ![richbutler1\_gmail.com](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/richbutler1_gmail.com/32/9005_2.png) [@richbutler1\_gmail.com](https://forums.plex.tv/u/richbutler1_gmail.com)\
**Post date:** [February 23, 2015, 9:28pm UTC](https://forums.plex.tv/t/debugging-setup-failures/11495/347 "2015-02-23T21:28:36Z")

</div>

OK, I just uninstalled Python 2.7.9 for Win along with pywin and pyopenssl because it looked like the errors started around there. &nbsp;I just wanted to isolate PMS from any external Python dependencies/conflicts. &nbsp; After doing these uninstalls (even with iobit ui) I tried 0.9.1112 and it also bombed.

No proxy, yes 32400 is still open, no logs in Logs\PMS Plugin Logs. &nbsp;Same errors in logs.

After install, I wait until system tray shows PMS icon, then Open Media Manager... via right click. &nbsp;Opens URL:&nbsp;[http://localhost:32400/web/index.html](http://localhost:32400/web/index.html), which has 'Agree', this leads to URL:&nbsp;http://plex.tv/web/app#!/setup &nbsp;where I get no further than the error message 'A problem..,..core component of Plex Media Server.'

I don't know where else to go with this or what to retry. &nbsp;I can't see having to rebuild a machine of this application. &nbsp;FYI, it is running in a VM on Win8.1 Pro fully updated with WinUpdate.

---

<div class="post-metadata">

**Author:** ![sa2000](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/sa2000/32/6922_2.png) [@sa2000](https://forums.plex.tv/u/sa2000)\
**Post date:** [February 23, 2015, 9:45pm UTC](https://forums.plex.tv/t/debugging-setup-failures/11495/348 "2015-02-23T21:45:09Z")

</div>

so after removal of your own installs of OpenSSL and Python, did you go through a reinstall of Plex Media Server or just relaunch?

Uninstall Python and OpenSSL

Reboot&nbsp;

Re-install Plex Media Server 0.9.11.12

Launch&nbsp;

If you get the error, shutdown Plex Media Server,&nbsp;

Reset System and Framework Bundles

Restart Plex Media Server

If problem persist,&nbsp;

upload Plex Media Server.log and PMS Plugin Logs\com.plexapp.system.log

---

<div class="post-metadata">

**Author:** ![richbutler1\_gmail.com](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/richbutler1_gmail.com/32/9005_2.png) [@richbutler1\_gmail.com](https://forums.plex.tv/u/richbutler1_gmail.com)\
**Post date:** [February 23, 2015, 10:05pm UTC](https://forums.plex.tv/t/debugging-setup-failures/11495/349 "2015-02-23T22:05:15Z")

</div>

I uninstalled those, restarted PC, relaunched PMS, received error. &nbsp;I have just stopped PMS, deleted Framework and system.bundle. &nbsp;Restarted PMS, takes time I assume to rebuild them, Get started, Please wait screen, same error. &nbsp;One interesting note: &nbsp;I went into settings and looked under devices. &nbsp;saw multiple grayed out server items all with same name. &nbsp;I deleted them all, then reconnected server and manually mapped to port 32400. &nbsp;Both successfully connected. &nbsp;Tried the delete frmaework and system files, no good.

No logs at all under Logs\PMS Plugin Logs

---

<div class="post-metadata">

**Author:** ![sa2000](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/sa2000/32/6922_2.png) [@sa2000](https://forums.plex.tv/u/sa2000)\
**Post date:** [February 23, 2015, 10:16pm UTC](https://forums.plex.tv/t/debugging-setup-failures/11495/350 "2015-02-23T22:16:04Z")

</div>

> I uninstalled those, restarted PC, relaunched PMS, received error. &nbsp;I have just stopped PMS, deleted Framework and system.bundle. &nbsp;Restarted PMS, takes time I assume to rebuild them, Get started, Please wait screen, same error. &nbsp;One interesting note: &nbsp;I went into settings and looked under devices. &nbsp;saw multiple grayed out server items all with same name. &nbsp;I deleted them all, then reconnected server and manually mapped to port 32400. &nbsp;Both successfully connected. &nbsp;Tried the delete frmaework and system files, no good.
> 
> No logs at all under Logs\PMS Plugin Logs

If there are no logs in the Logs\PMS Plugin Logs folder then that means that PlexScriptHost.exe is not launching the bundle

**Feb 23, 2015 16:53:31:648 [1504] DEBUG - Installing plug-in: Framework**

**Feb 23, 2015 16:53:40:028 [1504] DEBUG - Installing plug-in: System**

Feb 23, 2015 16:53:40:731 [1504] ERROR - Error cleaning up deactivated plug-ins.

Feb 23, 2015 16:53:40:731 [4700] DEBUG - File C:\Users\MyUsername\AppData\Local\Plex Media Server\Plug-ins changed: -1 =\> 1424728420.

Feb 23, 2015 16:53:40:747 [4700] DEBUG - Starting plug-in C:\Users\MyUsername\AppData\Local\Plex Media Server\Plug-ins\System.bundle.

Feb 23, 2015 16:53:40:747 [4700] DEBUG - [com.plexapp.system] Setting plug-in to always running (daemon mode).

Feb 23, 2015 16:53:40:747 [4700] DEBUG - Starting file watcher for com.plexapp.system

**Feb 23, 2015 16:53:40:747 [4700] DEBUG - Plugin::createProcess: Creating plugin process: "C:\Program Files (x86)\Plex\Plex Media Server\PlexScriptHost.exe" "C:\Users\MyUsername\AppData\Local\Plex Media Server\Plug-ins\Framework.bundle\Contents\Resources\Versions\2\Python/bootstrap.py" "C:\Users\MyUsername\AppData\Local\Plex Media Server\Plug-ins\System.bundle"**

Feb 23, 2015 16:53:40:747 [4700] DEBUG - Spawned plug-in com.plexapp.system with PID 716

Feb 23, 2015 16:53:40:747 [4700] DEBUG - [com.plexapp.system] Sending command: GET /:/prefixes

**Feb 23, 2015 16:56:40:756 [4700] ERROR - Timeout or error reading status line from plug-in pipe [com.plexapp.system], we're killing it.**

Feb 23, 2015 16:56:40:756 [4700] DEBUG - Stopping [com.plexapp.system].

&nbsp;

I have no experience of running Plex Media Server in a VM - and if this has a bearing on the problem, you will need someone else to step in and help/

&nbsp;

Did you check if the firewall has PlexScriptHost.exe in the list of programs permitted ?

&nbsp;

What anti virus ? Sometimes that blocks PlexScriptHost.exe

---

<div class="post-metadata">

**Author:** ![richbutler1\_gmail.com](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/richbutler1_gmail.com/32/9005_2.png) [@richbutler1\_gmail.com](https://forums.plex.tv/u/richbutler1_gmail.com)\
**Post date:** [February 23, 2015, 10:46pm UTC](https://forums.plex.tv/t/debugging-setup-failures/11495/351 "2015-02-23T22:46:29Z")

</div>

No anti-virus(I had uninstalled), checked Firewall and PlexScriptHost.exe is allowed. &nbsp;Running in a VM should be no different that a physical machine and should have no bearing on the issue. &nbsp;What else should be tried?

---

<div class="post-metadata">

**Author:** ![sa2000](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/sa2000/32/6922_2.png) [@sa2000](https://forums.plex.tv/u/sa2000)\
**Post date:** [February 23, 2015, 11:08pm UTC](https://forums.plex.tv/t/debugging-setup-failures/11495/352 "2015-02-23T23:08:35Z")

</div>

We have had the 3 minute timeout before on starting the bundle - i will see if i can find previous posts/topics

Any non standard characters in the windows username?

---

<div class="post-metadata">

**Author:** ![richbutler1\_gmail.com](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/richbutler1_gmail.com/32/9005_2.png) [@richbutler1\_gmail.com](https://forums.plex.tv/u/richbutler1_gmail.com)\
**Post date:** [February 23, 2015, 11:17pm UTC](https://forums.plex.tv/t/debugging-setup-failures/11495/353 "2015-02-23T23:17:23Z")

</div>

Nope, just letters in username.

---

<div class="post-metadata">

**Author:** ![sa2000](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/sa2000/32/6922_2.png) [@sa2000](https://forums.plex.tv/u/sa2000)\
**Post date:** [February 23, 2015, 11:30pm UTC](https://forums.plex.tv/t/debugging-setup-failures/11495/354 "2015-02-23T23:30:35Z")

</div>

whilst I try to find the old occurrences of such errors, could you manually launch the bundle in a debug session as outlined in the first post in the Debug Plugin Failures topic:&nbsp;

[https://forums.plex.tv/topic/31714-debugging-plugin-failures/](https://forums.plex.tv/topic/31714-debugging-plugin-failures/)

and see what gets returned in terms of errors

---

<div class="post-metadata">

**Author:** ![sa2000](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/sa2000/32/6922_2.png) [@sa2000](https://forums.plex.tv/u/sa2000)\
**Post date:** [February 24, 2015, 12:03am UTC](https://forums.plex.tv/t/debugging-setup-failures/11495/355 "2015-02-24T00:03:58Z")

</div>

Of all the previous occurrences that i could find with a search, this one sounds more likely. It is OpenSSL uninstall not completely removing all components of OpenSSL

This was the topic:&nbsp;[https://forums.plex.tv/topic/124308-complexappsystem-were-killing-it/](https://forums.plex.tv/topic/124308-complexappsystem-were-killing-it/)

OpenSSL found to be installed which then we linked to this topic:&nbsp;http://fix https://forums.plex.tv/topic/101920-agents-missing/

And someone still had issues and fix reported here:&nbsp;[https://forums.plex.tv/topic/124308-complexappsystem-were-killing-it/?p=749720](https://forums.plex.tv/topic/124308-complexappsystem-were-killing-it/?p=749720)&nbsp;with the problem identified as a fragment of pyOpenSSL that was not cleanly uninstalled by that package's utility.&nbsp;

&nbsp;

Other causes of this error seen before:&nbsp;

suspected foreign letters in username (not confirmed as the cause):&nbsp;[https://forums.plex.tv/topic/141459-plex-media-server-doesnt-work-on-my-computer/](https://forums.plex.tv/topic/141459-plex-media-server-doesnt-work-on-my-computer/)

&nbsp;

This similar timeout:&nbsp;[https://forums.plex.tv/topic/31335-debugging-setup-failures/?p=768515](https://forums.plex.tv/topic/31335-debugging-setup-failures/?p=768515)&nbsp;and reported by the user as fixed by adding Python to the firewall (PlexScriptHost.exe)

[https://forums.plex.tv/topic/31335-debugging-setup-failures/?p=777601](https://forums.plex.tv/topic/31335-debugging-setup-failures/?p=777601)

---

<div class="post-metadata">

**Author:** ![richbutler1\_gmail.com](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/richbutler1_gmail.com/32/9005_2.png) [@richbutler1\_gmail.com](https://forums.plex.tv/u/richbutler1_gmail.com)\
**Post date:** [February 24, 2015, 2:51pm UTC](https://forums.plex.tv/t/debugging-setup-failures/11495/356 "2015-02-24T14:51:14Z")

</div>

Thank you very, very much for your triage work. &nbsp;Unfortunately, it will be time better spent spinning up a fresh VM and reinstalling Plex. &nbsp;One huge feature request I have is a clean backup and restore feature for times like this. &nbsp;I know I can copy the DB and settings over manually, but I've seen data model conflicts and issues in the past. &nbsp;I'm hoping for this feature and as Plex grows that a DBA closely governs the data model so future restores to new versions will never clash with older backups. &nbsp;Thanks again sa2000, I see you're help here all the time and without it, I'm sure the user's support, payments and growth wouldn't be where it is today. &nbsp;A lot of times, users/employees are the unsung heros in a product's success. &nbsp;Kudos for the work you do!

Rich

---

<div class="post-metadata">

**Author:** ![sa2000](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/sa2000/32/6922_2.png) [@sa2000](https://forums.plex.tv/u/sa2000)\
**Post date:** [February 24, 2015, 3:32pm UTC](https://forums.plex.tv/t/debugging-setup-failures/11495/357 "2015-02-24T15:32:53Z")

</div>

> Thank you very, very much for your triage work. &nbsp;Unfortunately, it will be time better spent spinning up a fresh VM and reinstalling Plex. &nbsp;One huge feature request I have is a clean backup and restore feature for times like this. &nbsp;I know I can copy the DB and settings over manually, but I've seen data model conflicts and issues in the past. &nbsp;I'm hoping for this feature and as Plex grows that a DBA closely governs the data model so future restores to new versions will never clash with older backups. &nbsp;Thanks again sa2000, I see you're help here all the time and without it, I'm sure the user's support, payments and growth wouldn't be where it is today. &nbsp;A lot of times, users/employees are the unsung heros in a product's success. &nbsp;Kudos for the work you do!
> 
> Rich

Thanks for your kind words.

So do you think it was remnants of OpenSSL ?

Hope it will be ok with fresh clean install with no history of any python or openssl installation

By the way the resetting of system and framework is quite often needed as on some systems things go wrong during the initial launch after the install

---

<div class="post-metadata">

**Author:** ![richbutler1\_gmail.com](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/richbutler1_gmail.com/32/9005_2.png) [@richbutler1\_gmail.com](https://forums.plex.tv/u/richbutler1_gmail.com)\
**Post date:** [February 24, 2015, 3:55pm UTC](https://forums.plex.tv/t/debugging-setup-failures/11495/358 "2015-02-24T15:55:10Z")

</div>

FYI, clean install on Win 8.1 Pro works fine through the wizard. &nbsp;Still can't seem to get an smb share to work right. &nbsp;Is it possible to add SMB shares as a library folder using UNC naming like: \\SERVERNAME\ShareName &nbsp;I get 'This library has no content yet."

---

<div class="post-metadata">

**Author:** ![sa2000](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/sa2000/32/6922_2.png) [@sa2000](https://forums.plex.tv/u/sa2000)\
**Post date:** [February 24, 2015, 4:02pm UTC](https://forums.plex.tv/t/debugging-setup-failures/11495/359 "2015-02-24T16:02:56Z")

</div>

> FYI, clean install on Win 8.1 Pro works fine through the wizard. &nbsp;Still can't seem to get an smb share to work right. &nbsp;Is it possible to add SMB shares as a library folder using UNC naming like: \\SERVERNAME\ShareName &nbsp;I get 'This library has no content yet."

I add mine as \ ame\share-name\folder to appropriate library categories

but are the shares available inside the VM - presumably you tested ok with explorer?

Scanner uses folder modified date and time so best to operate at folder level and not drive level. I presume the share root does not have a 'last modified date/time' attribute. Anyway this is separate from your actual isse of no content

---

<div class="post-metadata">

**Author:** ![richbutler1\_gmail.com](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/richbutler1_gmail.com/32/9005_2.png) [@richbutler1\_gmail.com](https://forums.plex.tv/u/richbutler1_gmail.com)\
**Post date:** [February 24, 2015, 4:38pm UTC](https://forums.plex.tv/t/debugging-setup-failures/11495/360 "2015-02-24T16:38:54Z")

</div>

I had to tweak rights on the share I tried then it worked :) &nbsp;All looks back in order now.

[Previous page](https://forums.plex.tv/t/debugging-setup-failures/11495.md?page=17)

[Next page](https://forums.plex.tv/t/debugging-setup-failures/11495.md?page=19)
