Deleting Synced does not free up space

ios

#1

i tried deleting some files to add some new ones to my iPad. As seen in the screenshots plex says only 6.5 gigs are synced with 200 my free however my iPad shows 10 gigs taken up. The 4 gig difference is from the files I deleted. Is there a way to fix this without reinstalling the app?



#2

Now that you mention it, I'm having the same problem, I have nothing synced at the moment but Plex is taking 1.9 Gb of space?

Regards


#3

I'm having the same problem. Plex says 7.7 GB taken up, iOS reports 33.


#4

Same issue here.

Only way I've found to get the space back is to delete all, but that means resync the stuff that I still want on there.


#5

Add me to this. I had 14.3 GB of space taken up, even though I had used "delete all content". There were no defined syncs, but the space was still taken up. Resetting the cache had no effect.

And it definitely does not handle a full device gracefully.

The only way I could find to get the space back was to delete the app and re-install. Glad I have an unlimited data plan. :)


#6

I was able to fix it by deleting and reinstalling the app but it is not the
best solution.


#7

Is there still no solution to this absolutely monumental fuck up bug? I am about to go on holidays for three weeks and now I have to delete everything and add it again?! Can we get some dev input here? @elan


#8

I think the latest update should have fixed it.


#9

Nope, I am running the latest version on iOS 9.0.2 and it's still messed up...


#10

Unfortunately it's time to give up with Sync for iOS. I have been trying for weeks... There is an alternate way to put stuff on iPad. Try Waltr


#11

Can somebody test/confirm whether this is fixed in v 4.0.5? I am already on my trip and rather not update check this right now and risk breaking everything ;-)


#12

This is still not working. Files still show on iPad even after deletion and I a, not getting my space back. 

On Mon, Oct 12, 2015 at 1:54 PM -0700, "Turk" forums+d177016@plex.tv wrote:

Unfortunately it's time to give up with Sync for iOS. I have been trying for weeks... There is an alternate way to put stuff on iPad. Try Waltr


#13

This is actually working for me right now, but it seems only, if the shows are "automatically" deleted because I marked them as watched and only when I am connected to my plea server.


#14

I’ve noticed that whenever I cancel a sync operation before it completes, the storage space being reported by iOS becomes unreliable. It’s almost as though the cancelled sync operation does not do any clean up or garbage collection, so the data in limbo just sort of hangs around on the app forever, if that makes any sense. I trust the sync storage space reported by the server as completely authoritative, so whenever the iOS app starts reporting that more storage is being used, I typically refer to the usage reported by the server, and the server has never been wrong so far.

I was syncing a number of items, and after some time, after most items were synced, I ended up cancelling a sync operation of BBC’s Frozen Planet (using the settings: limit 3 episodes / unwatched / medium quality) because it was taking a long time to transcode. Ever since, the amount of storage space reported in use by the iOS app has been larger than the actual amount of storage space in use as reported by the server. I have a screenshot of the iOS storage settings screen, and the Plex Web client iOS device overview.

iOS storage overview:

Plex Web client of storage on that Plex iOS app:

Note that according to iOS’ storage overview screen, the Plex app is occupying 18.3 GB of storage. The server is reporting that the Plex iOS app has 15.8 GB of content synced to the device. That leaves a difference of 2.5 GB.

To make sense of the 2.5 GB difference, let’s say the Plex binary or full install of Plex on the iOS is about 100 MB. That leaves 2.4 GB of storage in use by Plex as reported by iOS itself. Further, let’s say there is another 1.0 GB of caches. That leaves 1.4 GB of unaccounted for storage space that Plex is using as reported by the iOS app, but the actual content of that 1.4 GB is nowhere to be found. This leads me to believe that remaining 1.4 GB of unaccounted for used space is the data in limbo I hypothesized about in the opening paragraph.

Also, I have logs for during the time this happened. It was two days ago, using iOS Plex 4.0.5 and PMS 0.9.12.13.1464-4ccd2ca. The context of the log: it was a fresh iOS Plex install of 4.0.5, so there was no sync content. I then performed multiple sync operations, queuing about 12 artists (multiple albums each), and about 4 TV shows (3 unwatched episodes, medium quality). It should also include the cancellation of the Frozen Planet sync operation. This debug log spans from that time to just a few minutes ago.


It may also be worth reading a similar sync issue I detailed here–again, related to the calculation of sync storage on the iOS Plex app: https://forums.plex.tv/discussion/comment/1037512/#Comment_1037512


#15

Any news from the Plex team? This bug has been publicly discussed for months and is still present in the production iOS app. Would appreciate an update! Thanks.


#16

Wow this bugs exists for months now. I personally noticed it yesterday for the first time. I have 3gb synced content but my app is taking 54gb of storage. I mean. What the fuck?!

Please plex! Do something about it!


#17

Plex, please fix this bug. It makes the IOS sync functionality unusable.


#18

I have this bugging suspicion Plex has given up on sync. :/


#19

Same here, just tried deleting a show to free up space only no change.


#20

Same problem here. I was syncing 4 movies and ran out of space in the middle. I freed up some space on my iPad and the sync started again but it kept all the space it partially took the first time around. The sync started from scratch and now took up all new space in addition to the old space. I then deleted all the sync content (which never finished) and it still did not give me my space back. I had 0 sync items and iOS reported Plex was taking up 10GB. I had to delete the app an re-install it to get my space back.