Direct Play Audio Track not changeable (SAMSUNG)

smart-tv

#1

Never had this problem before (using Plex for maybe 6month+).
Happens to all formats available to me (ac3 dts / mp4 mkv).
The TV App shows all languages, I can select them but it doesn't change the audio track. Changing via PC "Now playing" doesn't work either.
It defaults to audio track 1
When I disable DTS(DCA) under settings in the TV App and Plex starts transcoding the correct audio plays.
Windows Plex 3.9.1
Samsung Plex (3.1.0(3.8.0))
Reinstalled Plex on both systems and tried to change settings without success.
Can anyone replicate this? Has there been a recent update?


#2

Yes! I have realized of that issue with the last version of Plex Server using direct play. Fortunately so far that bug does not happen with Direct Streaming


#3

I started experiencing this just after getting a Plex update tonight on my Samsung tv.
Literally, a movie was playing in one language - I exited from Plex to check something else, started Plex again, got prompted with an update, and after then I wasn't able to change language anymore, in the same movie or any movie at all.

As you mentioned, by forcing encoding, it works (e.g. applying a subtitle). I can replicate it with DD, DTS and AC3

Plex 3.1.0 (3.8.0)
Tizen 2.4.0 (UE65KS9500)
Plex server Version 1.5.5.3634


#4

Same here.

And to make things even worse, the subtitle transcoding also seems to have deteriorated, so turning on subs will constantly buffer.

Edit: Turning direct play off and disable subtitles will also trigger transcoding and play the correct audio track. The transcoder is only utilizing 2,9% CPU with plenty of spare on my Synology, but it still buffers and staff like mad making it unusable. Seems worse on high bitrate files.

Disabling direct stream will trigger the full transcoder, which my synology isn't powerfull enough for.


#5

I have this issue too and it’s incredibly frustrating! Can we please get an update on when plex for tizen will be fixed? Mirx, thanks so much for the work around, it’s “back to normal” now. But, shouldn’t have happened in the first place.


#6

@Mirx said:
Disabling direct stream will trigger the full transcoder, which my synology isn't powerfull enough for.

Transcoding DTS buffers constantly for me too, the difference is I'm currently running Plex over LAN on a 4,5Ghz i7 processor. Processing speed doesn't seem to be the problem here.


#7

I am getting this issue too now on my Samsung KS8000. Hopefully there will be a quick fix for it.


#8

Dear Plex Team,

please fix this issue.


#9

Any news on fixing the bug?


#10

this was reported a month ago, and no "Employee" seems to care or have any updates on a fix. That's call quality service.


#11

Same issue here. Samsung KS9000. MKV264 with about 8 tracks of audio within in different formats (AAC, AC3, DTS). No matter which track i choose same is playing. Strange thing is that this bug appear not everywhere. I am watching GoT and in first 4 seasons everything was fine, but whole 5 season is bugged. Tried change flags in MKV. Tried converting episode to another audio codec. Tried repack MKV. Nothing helping.
And this appear only on TV. On my S8, iPad, Windows App and Web client it's all working great.

The only solutuon is to turn Direct Play off. Then it's working. But well, my Qnap start to hurt itself :)


#12

@Sifjar said:
The only solutuon is to turn Direct Play off. Then it's working. But well, my Qnap start to hurt itself :)

Since there is no fix for this yet you can always change the default or forced audio track to the one you want.
I use MKVToolNix (works on other formats too) and simply delete the audio tracks I don't need, takes a couple of minutes for big files


#13

Have the same issue. Its a big-time bug in the software. I've had movies where it straight-up won't play english unless you turn subtitles on. Really weird stuff. Just started happening a month or so ago. The MKVTool is nice as a workaround in the meantime.


#14

@mrgregb123 said:
Have the same issue. Its a big-time bug in the software. I've had movies where it straight-up won't play english unless you turn subtitles on. Really weird stuff. Just started happening a month or so ago. The MKVTool is nice as a workaround in the meantime.

Once you turn on subtitles it won't direct play any more, which means it will transcode and that makes it possible to change the aufio track, so it's not weird. But to transcode isn't an acceptable solution since it has worked before the latest update.

The main problem is that direct play force always the first audio track to play - no matter which one that is. In my case it's most of the time english, sometimes german. It's not possible to change the audio track while direct play is turned on. Thats it. And that sucks.

Please Plex Team we need to get this fixed!


#15

Same problem hereon my UE7090. This is so annoying :neutral: PLEASE fix this soon as it was working in previous versions!!!


#16

Same issue on Samsung ks8000 I cannot select audio track, it pretty much renders Plex useless to me on the TV.


#17

@wh0oot said:

@Sifjar said:
The only solutuon is to turn Direct Play off. Then it's working. But well, my Qnap start to hurt itself :)

Since there is no fix for this yet you can always change the default or forced audio track to the one you want.
I use MKVToolNix (works on other formats too) and simply delete the audio tracks I don't need, takes a couple of minutes for big files

Given up waiting for a fix for this now, decided to try the above. Worked a treat for me. Thanks for the suggestion. Even worked with my 4K files.


#18

Hi,
Same issue here also. This is the scenario:

Plex 3.1.0 (3.8.0)
Tizen 2.4.0 (UE40KU6400)
Plex server Version 1.8.4.4249

I hope the fix can arrive soon...


#19

Same problem here!


#20

Same issue, setup:
Plex 3.1.0 (3.8.0)
Tizen 2.4.0 (UE49KS7500)
Plex server Version 1.9.2.4285
Yamaha AV reciever