DLNA shows no content

server-dlna

#1

All of my DLNA clients see the Plex server, once I have enabled the tic box for it.

But none of the clients, even supported ones like the PS3, see any content. I have jpg photos, mp3 music files, etc on the server, so incompatible formats should not be the issue.

What are the settings I should get checking?


#2

I have normally only ran into this issue with 2 cases:
1) Trying to view movies libraries while browsing from the music section on the DLNA client. (Normally a DLNA client will block all other types of media from the one it is expecting to find)

2) With extremely large libraries that cause the client to timeout. On my PS3 this was around 300+ items (Which I was able to bypass by using filters) but on my LG it was around 1,000+ items (So it varies based on the device as well)

If neither of these two things appear to be the cause, the first place to check will be your Plex DLNA server.log which will show the requests from the client to the server for each section. From there you can see if any errors are being generated that may also be causing this issue.


#3

What version of PMS are you running?
I have a similar issue after upgrading to 0.9.14.1 (and with 0.9.14.2 as well).
I can browse the content of the DLNA server (as in directories), but no content in it. This was working fine with 0.9.12, but I can't seem to downgrade on my Synology (doesn't allow it)


#4

Uninstalled PMS 0.9.14 and installed 0.9.12.19 again
That seems to solve the problem, DLNA works as expected


#5

Out of curiosity, I tried to upgrade again to 0.9.14.2, and it broke again
So definitely something wrong with 0.9.14. I noticed that PlayZ Media client on my LG TV doesn't work either with 0.9.14 - it keeps on loading.


#6

Same problem here with my LG-TV. My other TV (Samsung) works fine!


#7

Same problem here, starting with version 0.9.12.19 and up, my LG tv does not list content via DLNA


#8

I've disabled my automatic update script because 0.9.14 breaks DLNA


#9

same here with my Viera Plasma, uninstalled and went back to 0.9.12.19 and now it works again. Any word on a fix for this


#10

Yes people I have an LG TV and indeed 0.9.14 does break DLNA


#11

I have an LG TV a Samsung TV, and a DNLA Airstream speaker and an ONKYO DNLA AMP and NONE will work with my PLEX using DNLA :/ Very disappointed that I spent all this money (lifetime) and it will not do what I want it to do!¬


#12

So has anyone been on here like a Plex mod to help us with our issue or to at least say he we are working on it. Since the Plex Pass version or the official version both have given me DLNA issuses


#13

just tested the latest version released and the DNLA issue is still there. I reverted back to 0.9.12.19 and it works again.


#14

The latest version is very strange. I got it to work once via my Viera TV. However it is very slow with DNLA. I enabled verbose logging and got this.

Jan 30, 2016 00:07:41:264 [3664] ERROR - Error issuing curl_easy_perform(handle): 28
Jan 30, 2016 00:07:41:264 [3664] WARN - HTTP error requesting GET http://127.0.0.1:32400/library/metadata/27609,27404,27405,27407,27408,27523,27409,27524,27410,27411,27412,27413,27414,27415,27416,27417,27418,27525,27585,27526,27419,27420,27421,27422,27423,27425,27527,27528,27576,27426,27594,27429,27529,27530,27430,27575,27586,27432,27433,27434,27531,27436,27532,27596,27598,27440,27441,27442,27439,27443,27444,27533,27445,27614,27446,27447,27534,27448,27599,27600,27451,27452,27453,27454,27455,27456,27457,27458,27459,27460,27461,27462,27463,27464,27465,27535,27536,27537,27538,27466,27467,27468,27613,27584,27471,27573,27472,27601,27473,27539,27474,27475,27477,27540,27478,27479,27480,27494,27597,27482,27483,27484,27486,27487,27610,27542,27543,27488,27495,27489,27490,27491,27493,27496,27544,27497,27498,27499,27500,27501,27502,27503,27504,27505,27545,27506,27507,27582,27508,27509,27577,27510,27511,27512,27513,27548,27514,27572,27608,27611,27515,27516,27517,27518,27519,27520,27574,27521,27612,27522,27424,27551,27552,27553,27555,27616,27557,27558,27578,27579,27580,27581,27406,27559,27615,27549,27588,27560,27587,27561,27562,27564 (28, Timeout was reached) (Operation timed out after 60031 milliseconds with 0 out of -1 bytes received)
Jan 30, 2016 00:07:41:264 [3664] DEBUG - Simulating 408 after curl timeout
Jan 30, 2016 00:07:41:264 [3664] ERROR - HTTP 408 downloading url http://127.0.0.1:32400/library/metadata/27609,27404,27405,27407,27408,27523,27409,27524,27410,27411,27412,27413,27414,27415,27416,27417,27418,27525,27585,27526,27419,27420,27421,27422,27423,27425,27527,27528,27576,27426,27594,27429,27529,27530,27430,27575,27586,27432,27433,27434,27531,27436,27532,27596,27598,27440,27441,27442,27439,27443,27444,27533,27445,27614,27446,27447,27534,27448,27599,27600,27451,27452,27453,27454,27455,27456,27457,27458,27459,27460,27461,27462,27463,27464,27465,27535,27536,27537,27538,27466,27467,27468,27613,27584,27471,27573,27472,27601,27473,27539,27474,27475,27477,27540,27478,27479,27480,27494,27597,27482,27483,27484,27486,27487,27610,27542,27543,27488,27495,27489,27490,27491,27493,27496,27544,27497,27498,27499,27500,27501,27502,27503,27504,27505,27545,27506,27507,27582,27508,27509,27577,27510,27511,27512,27513,27548,27514,27572,27608,27611,27515,27516,27517,27518,27519,27520,27574,27521,27612,27522,27424,27551,27552,27553,27555,27616,27557,27558,27578,27579,27580,27581,27406,27559,27615,27549,27588,27560,27587,27561,27562,27564
Jan 30, 2016 00:07:41:264 [3664] ERROR - PlexContainer::GetStreamMetadata - unable to get directory /library/metadata/27609,27404,27405,27407,27408,27523,27409,27524,27410,27411,27412,27413,27414,27415,27416,27417,27418,27525,27585,27526,27419,27420,27421,27422,27423,27425,27527,27528,27576,27426,27594,27429,27529,27530,27430,27575,27586,27432,27433,27434,27531,27436,27532,27596,27598,27440,27441,27442,27439,27443,27444,27533,27445,27614,27446,27447,27534,27448,27599,27600,27451,27452,27453,27454,27455,27456,27457,27458,27459,27460,27461,27462,27463,27464,27465,27535,27536,27537,27538,27466,27467,27468,27613,27584,27471,27573,27472,27601,27473,27539,27474,27475,27477,27540,27478,27479,27480,27494,27597,27482,27483,27484,27486,27487,27610,27542,27543,27488,27495,27489,27490,27491,27493,27496,27544,27497,27498,27499,27500,27501,27502,27503,27504,27505,27545,27506,27507,27582,27508,27509,27577,27510,27511,27512,27513,27548,27514,27572,27608,27611,27515,27516,27517,27518,27519,27520,27574,27521,27612,27522,27424,27551,27552,27553,27555,27616,27557,27558,27578,27579,27580,27581,27406,27559,27615,27549,27588,27560,27587,27561,27562,27564


#15

Has this been fixed yet?!


#16

My is working again. Not sure what version but it has been working for a few versions. At times the list of titles to display can be slow but it does seem to be working.


#17

I think it´s important to state WHICH Plex server plattform you are using... for example: I run two Plex servers, one on windows10 and one on raspberry pi (Linux), both latest software update versione, and while th DLNA service on Win10 works perfectly (offering all media files via DLNA as a UPNP device) on Linmux the DLNA is NOT wkroing - at least nor for me. Client see the Server, but there are no files offered. Sucks.
F


#18

Decided to update today as most of my other apps no longer work with the older Plex version. Unfortunately DLNA still has not been fixed with my LG tv.


#19

After suffering from to much stuttering on my LG TV Plex App, I decided to delete the app and go back to (Win 7) DLNA, only I'm getting the no files problem.


#20

Heyho, I installed plex server (1.10.1.4602 ) on an fresh freebsd machine wich does nothing else than plex.
I logged in with a new plexpass member, activated DLNA. I Threw 2 Albums (flac and wav) in the library.
I see the the server in DLNA clients like windows media player or vlc, but as described above, no content is visible.
I read through a bunch of threads with the same issue stating that it may be "plex home" wich deactivates dlna for some reason.
I am not sure if plex home is activated, I dont see the "Leave Home" Button. But if I create a managed user, I see the button and can leave.
DLNA is deactivated after that action. If I set the checkbox again. The server shows up in the clients. But without content.

How can I solve the problem? I really need that feature :)

edit: I also tried restarting the server, without success