Docker/Plex without --net=host



I just moved my server over to a linux/docker container (specifically and was having a hard time getting things to work the way I wanted. I did not want to use --net=host, so I setup just the ports. After starting up the container, I could not get Plex to detect server. I could see Plex running when I went to Linux.IP:32400/web, but it would not detect the server and show my library.

I was finally able to access the server by setting up a proxy tunnel and configuring my browser to use it. Once in, I noticed that the local IP address was reporting the docker container IP 172.17.X.X. I found that if I added the IP address of my Linux server hosting Docker to the "Custom server access URLs" field, my problem was solved.

You should be able to get away without having to tunnel by putting customConnections=" https://192.168.X.X:32400" (Server hosting Docker) in your preferences.xml. After restarting it took a few minutes for this address to publish to Plex. After that, everything worked great. I'm running Plex in Docker without --net=host.


now I understand my problem better. so which docker image did you use? it seems that none are working for me but from what I ve seen in the preferences.xml I have allowedNetworks=""
which doesn't seem right to me no? because if it works properly, none connection from outside this nat should arrive to the container. From my part, I can't access the docker, but it seems to answer at the beginning but just after I'me relocated to one of my other plex server on my nat networks (yes I have several) . If I deactivate the other plexserver I just go to interfaces and I land to one of the server of my friends...


I was wrong, the linuxserver/plex works out of the box but not timahaak docker


I use linuxserver/plex but I don't use --net=host like they suggest, it can be a security risk. I instead just configure the ports (bridged mode). If you're seeing for allowed networks, that means you too are running in bridged mode.

If running in bridged mode and you can't access your server, just do what I suggest from above. Put customConnections=" https://192.168.X.X:32400" (Server hosting Docker) in your preferences.xml and you should be good to go.


I wonder if this would work with multiple plex servers in docker?

I am just beginning to play with docker and using containers. I was considering having like three separate docker containers. Each plex container serving up different content. {complete separation of movies, shows, & music}

Unfortunately, I am not happy with the way the plex server segregates content. You do not get the choice for folders in folders. Only a multitude of "main" folders with no sub-sorting.


I'm having this same issue with my docker, I'm using the plexinc/pms-docker image, and I edited the Preferences.xml file and added the customConnections="192.168.x.x:32400" but It doesn't seem to be working. It keeps trying to point plex to the local IP of the docker at 172.17.x.x


I don't know how your using your docker, but my plex works great in the links in the signature block. I spent 3 days ironing out the issues. On top of that, install portainer for better oversight. The guide that I wrote up executes quite a few containers that require 0 network setup.


@allend87 I'm a newbie at Docker. Can you explain if someone wanted to use "--net=host" how they would do it? Using linuxserver/plex in Docker on Synology. Thanks