DS2413+ disable transcoding completely

server-synology

#1

Hello,

 

I've installed Plex on my DS2413+. How can I disable the transcoding?
Every video stored on the Diskstation is playable without transcoding on all of my devices.

My devices are:

- iPad 3

- iPhone 5

- Galaxy S4

- Samsung 2013 Smart TV

- Mac clients

 

I don't need the (on NAS to slow) transcoding.

The server tries to transcode every video I want to play.

 

Because the NAS is too slow, I'm unable to play any video file.

Please help.

 

Thanks.


#2

Hello,

I've installed Plex on my DS2413+. How can I disable the transcoding?
Every video stored on the Diskstation is playable without transcoding on all of my devices.

My devices are:

- iPad 3

- iPhone 5

- Galaxy S4

- Samsung 2013 Smart TV

- Mac clients

I don't need the (on NAS to slow) transcoding.

The server tries to transcode every video I want to play.

Because the NAS is too slow, I'm unable to play any video file.

Please help.

Thanks.

It only transcode media it has to, if your all media wants to transcode, then disabling the transcoder will just ensure none of your media will play at all.

The only way to remove the transcoder from the equation, is to ensure you media is compatible with the client device.

most info in the NAS sticky at the top of the forum.

post the .xml from a piece of media if you believe it should be able to direct play on your clients.


#3

It only transcode media it has to, if your all media wants to transcode, then disabling the transcoder will just ensure none of your media will play at all.

The only way to remove the transcoder from the equation, is to ensure you media is compatible with the client device.

I know and I am sure the files are all compatible because every other app plays them without a problem or transcoding. They are all

encoded by myself as m4v.

So the plex app/server seems to be not knowing what the devices can play.


#4

I know and I am sure the files are all compatible because every other app plays them without a problem or transcoding. They are all

encoded by myself as m4v.

So the plex app/server seems to be not knowing what the devices can play.

post the .xml

The most common cause of when people are sure their files are fine is that they have not been moov atom optimized. (aka optimized for streaming in the Plex/Web .xml)


#5

xml

EDIT: Seems that I have to set the streaming Bitrate to "Max" on the devices. Then it will play it without transcoding.






or







#6

xml

EDIT: Seems that I have to set the streaming Bitrate to "Max" on the devices. Then it will play it without transcoding.

and if you run qt-faststart on the ones with this

optimizedForStreaming="0"

they'll then work too.


#7

post the .xml

The most common cause of when people are sure their files are fine is that they have not been moov atom optimized. (aka optimized for streaming in the Plex/Web .xml)

When streaming from iTunes to iPad, iPhone or Apple TV there's no need to have media "atom optimised" as opposed to PMS. Thus, you may say that files are fine although they get transcoded by PMS.

Furthermore, videos that are not "atom optimised" play without transcoding via PlexConnect.


#8

When streaming from iTunes to iPad, iPhone or Apple TV there's no need to have media "atom optimised" as opposed to PMS. Thus, you may say that files are fine although they get transcoded by PMS.

Furthermore, videos that are not "atom optimised" play without transcoding via PlexConnect.

You are confusing proper streaming, which is what Plex does with the transcoder, with progressive downloading, which is how those other things work - they work differently and have different requirements.

You're comparing apples with oranges.


#9

You are confusing proper streaming, which is what Plex does with the transcoder, with progressive downloading, which is how those other things work - they work differently and have different requirements.

You're comparing apples with oranges.

OK, if that's the case and PMS doesn't support progressive downloads, why doesn't it read and store ATOM data for a file once media analysis is done on it? That should make needed data available for quick start streaming without a need to process videos additionally?


#10

OK, if that's the case and PMS doesn't support progressive downloads, why doesn't it read and store ATOM data for a file once media analysis is done on it? That should make needed data available for quick start streaming without a need to process videos additionally?

Plex does not modify original files in any ways, it is one of its goals.  People just need to rip their media correctly.

Been discussed before, so search if you want more info rather than hijacking anothers thread.


#11

I didn't suggest modifying videos but rather storing relevant data from ATOMs in Plex DB since media analysis is already run on them. 


 


#12

I didn't suggest modifying videos but rather storing relevant data from ATOMs in Plex DB since media analysis is already run on them. 


 

the atom needs to be in the file.


#13

Is there now a solution to disable transcoding?

I have files in 720p for DirectPlay.

Sometimes the files plays direct - sometimes plex transcode. Without change something at the device or server.

But when transcoding, the server is overload (see attachement) - i can not access something.

I must always make a hardreset. It is better, not playing then this...


#14

Is there now a solution to disable transcoding?

It is the same as it has always been - ensure you media is 100% compatible with the client you want to play it on - transcoding only happens when this is not the case, aka, when it is needed.


#15

This is the Metadata... and the client is a Samsung S4... When I start the Movies 5 times.: 3x plays direct, 2x transcode !?!

Medien

  • Dauer 1:31:01

  • Video Bildfrequenz 24p

  • Container MPEGTS

  • Seitenverhältnis 1.78

  • Height 720

  • Width 1280

  • Bitrate 1804 kbps

  • Video Auflösung 720p

Datei
  • Size 1.15 GB

  • Dauer 1:31:01

  • Container MPEGTS

  • Datei /Movies/Planet.ts

  • Packet Length 188

  • Indexes sd

  • Exists Yes

  • Accessible Yes

Video
  • Dauer 1:31:01

  • Height 720

  • Width 1280

  • Bitrate 1804 kbps

  • Scan Type progressive

  • Ref Frames 4

  • Profil high

  • Ebene 3.1

  • Has Scaling Matrix 0

  • Bildrate 23.976 fps

  • Color Space yuv

  • Chroma Subsampling 4:2:0

  • CABAC 1

  • Bit Depth 8

  • Codec H264


Audio
  • Sprache Deutsch

  • Dauer 1:31:01

  • Bitrate 140 kbps

  • Kanäle Stereo

  • Profil lc

  • Codec AAC

  • Abtastfrequenz 48000 Hz

  • Bitratenmodus VBR



#16

It is the same as it has always been - ensure you media is 100% compatible with the client you want to play it on - transcoding only happens when this is not the case, aka, when it is needed.

This is how it should work in theory, but it doesn't always work in practice.  I had a similar problem with my Roku 3; PMS on my NAS kept transcoding files that the Roku could play natively.  Because the NAS isn't powerful enough to transcode HD video, this would result in a lot of buffering and choking.  I finally set Plex on the Roku to use "Direct Play w/ Fallback" and now everything works fine.  PMS doesn't try to transcode, the Roku can handle the videos, it works like PMS is supposed to, except I had to change a setting to make it happen.  So while Plex is supposed to only transcode when necessary, it doesn't always work that way.


#17

This is how it should work in theory, but it doesn't always work in practice.  I had a similar problem with my Roku 3; PMS on my NAS kept transcoding files that the Roku could play natively.  Because the NAS isn't powerful enough to transcode HD video, this would result in a lot of buffering and choking.  I finally set Plex on the Roku to use "Direct Play w/ Fallback" and now everything works fine.  PMS doesn't try to transcode, the Roku can handle the videos, it works like PMS is supposed to, except I had to change a setting to make it happen.  So while Plex is supposed to only transcode when necessary, it doesn't always work that way.

but that isn't a server issue, it is a client issue.  The client is telling PMS is needs to transcode.  Hopefully you have reported this, given media info and potentially media samples in the Roku forums (as the guys have been asking for so this sort of thing can be fixed)


#18

but that isn't a server issue, it is a client issue.  The client is telling PMS is needs to transcode.  Hopefully you have reported this, given media info and potentially media samples in the Roku forums (as the guys have been asking for so this sort of thing can be fixed)

Two points, then:

1) How can you know with such certainty that this is a client problem and not a server problem, if you haven't seen any logs or samples?

2) This is essentially the same thing that "stehohrhase" posted.  If there is a client-side problem that forces PMS to needlessly transcode videos that otherwise work fine on a device, you should have told him, "There is a client issue with the client you are using."  Instead, you told him the problem is that his media is not compatible, even though he said that it is.  (He said that sometimes it will direct play just fine, and other times it will try to transcode, when playing the same video file.  It wouldn't direct play some of the time if the file was simply incompatible.)  Why did you blame him, instead of telling him it was a client problem, if you really think this is a client problem?


#19

Two points, then:

1) How can you know with such certainty that this is a client problem and not a server problem, if you haven't seen any logs or samples?

2) This is essentially the same thing that "stehohrhase" posted.  If there is a client-side problem that forces PMS to needlessly transcode videos that otherwise work fine on a device, you should have told him, "There is a client issue with the client you are using."  Instead, you told him the problem is that his media is not compatible, even though he said that it is.  (He said that sometimes it will direct play just fine, and other times it will try to transcode, when playing the same video file.  It wouldn't direct play some of the time if the file was simply incompatible.)  Why did you blame him, instead of telling him it was a client problem, if you really think this is a client problem?

1) All the logic is client side, the server purely sends what the client asks for.

2) No one blamed anyone, re-read the response.  The client does not think the media is 100% compatible, there is clearly something different if it does something one time, and something else the next. (which could be as simple as enabling subs)


#20

1) All the logic is client side, the server purely sends what the client asks for.

2) No one blamed anyone, re-read the response.  The client does not think the media is 100% compatible, there is clearly something different if it does something one time, and something else the next. (which could be as simple as enabling subs)

You said this:  "ensure you media is 100% compatible with the client you want to play it on - transcoding only happens when this is not the case"  Then you said that "there is clearly something different" even though he said he's playing the same file repeatedly and getting different results.  Your solution to this problem is that whatever is "different" is him doing something that changes the result.  You are assigning responsibility for the issue to something he is doing.  Ergo, you are blaming him.  If you're going to tell someone that they are the problem, you should at least own it.

And like I said, I've had the same problem.  And I don't even use subtitles.  I'll try to get logs the next time it happens.