EAC3 (DD+ / Dolby Digital Plus) is Direct Playing but silent on tvOS and iOS

apple-tv

#1

Is anyone else experiencing this? I'm constantly having to select a lower quality file to hear audio. Both devices natively support DD+ and Plex is showing that it's Direct Playing the entire file so I'm confused why it's silent.

Is this a known problem? Based on the iOS profile, I'd expect the EAC3 to be transcoded but it's not.

Any info that could steer me in a good direction would be greatly appreciated!


[How To] Apple TV 4k MKV 4k HEVC HDR Playback
#2

What version? I’m seeing this on the beta (1.22) when the audio is transcoded from TrueHD to EAC.


#3

1.11.0.4666 (latest Plex Pass release as of 12/30/17).

The files where I’m seeing this have 5.1 EAC3 tracks as the only audio and there is no transcoding going on.


#4

I’ll see if I can find something with just EAC3. And I meant the Apple TV app version. With 1.22 I have this problem (beta) but not in 1.21 for transcoding.


#5

Sorry… the Apple TV version I’m using is v1.21 (7688).

For the first time I’m attempting to create my own client profile for iOS/tvOS to force transcoding of the EAC3 audio, but I’m having no luck. It appears that the custom profile is being ignored by the system. I’m going to look at the log files and see if I can’t figure out what’s going on.

Thanks for your replies!


#6

Hello,

Same problem with me, I have a sinology 416 play an Apple TV 4 and a Denon 3300.
Movies with EAC3 tracks are silents too.

When I launch the movie on my iMac (works) and when I continue it on my Apple TV it works. So it’s very strange because when I start watching this movie on TV OS it doesn’t work.

Can you please help.

Thanks.


#7

Glad it’s not just me! It should definitely work because these devices support EAC3. I’m really surprised there aren’t more people having this issue. EAC3 tracks are very popular, as is the tvOS and iOS.

Hoping someone can chime in and provide us some assistance.


#8

Yes I’m surprised too, EAC3 is now common so I don’t understand why I can not find any solution to this problem.


#9

No one else is experiencing this? BTW, my system is on Synology as well (and Apple TV 4K).


#10

It’s really hard to believe there are only two people having this problem. Can a Plex dev attempt to replicate (Syno DSM hosted PMS --> tvOS or iOS client… pushing EAC3 audio)?

At a minimum, can someone guide me in creating a custom profile for tvOS and iOS that can circumvent this problem? I’ve unsuccessfully attempted to do this already by doing the following:

-Copied default tvOS and iOS profiles to this location /volume1/Plex/Library/Application Support/Plex Media Server/Profiles
-Removed EAC3 from the DirectPlayProfiles part of these

It’s still direct playing the files with EAC3 audio. Is there a step I’m missing that triggers the custom profiles?

This is a huge issue for my library, especially because it removes the shuffle ability on my shows with EAC3 tracks. Please help!

Thanks in advance!


#11

Bump… Anyone out there that can help? Or at the least can a Plex dev attempt to replicate?

Thanks!


#12

The native tvOS video player (which Plex uses) does not support EAC3 passthrough as far as I know - it doesn’t work with DTS or DTS-HD either.

You might try changing the Apple TV settings to have ‘Dolby Digital’ as the output instead of ‘Best Available’.


#13

@ersan thank you for the reply! I’m going to try this when I get home from work. I know I’ve always kept this setting on “Best Available” so it would be great if this works.

The official specs for the Apple TV do show that it supports EAC3 so this still has me a bit confused:

Audio Formats Supported
HE-AAC (V1), AAC (up to 320 Kbps), protected AAC (from iTunes Store), MP3 (up to 320 Kbps), MP3 VBR, Apple Lossless, FLAC, AIFF, and WAV; AC-3 (Dolby Digital 5.1) and E-AC-3 (Dolby Digital Plus 7.1 surround sound)

The iPhone X also apparently supports EAC3 but I have the same issue there. Wish I had known this was going to be a pain before encoding so many files with EAC3 tracks! I wish I could get the custom profile working so it would force Plex to transcode EAC3 audio to AC3 when playing on tvOS or iOS…


#14

My EAC3 files will play on AppleTV if within a MKV container but not a MP4 container.


#15

If there is an issue with EAC3 audio please get some logs and media info

Ensure Debug Logging is enabled on the Plex Media Server
See https://support.plex.tv/articles/201643703-reporting-issues-with-plex-media-server/
Restart the server to get fresh logs created

Reproduce the problem and note down the time of the problem and the symptoms

Capture the Plex app logs and server logs
For the server See https://support.plex.tv/articles/200250417-plex-media-server-log-files/
and for the app - for Apple TV see https://support.plex.tv/articles/212639598-apple-tv-logs/
for iOS see https://support.plex.tv/articles/201636593-ios-logs/

and please also include the media info xml for the file being streamed
See https://support.plex.tv/articles/201998867-investigate-media-information-and-formats/

Attach logs / zip / media info xml (copy to text file) and details : time of problem and symptoms


#16

I have the same problem with a movie. Its Dolby Digital Plus and it the TV is silent. The DTS Track works. I tried to create all the logs, but there were so many, even after a restart. which logs do you need exactly?


#17

@dacula said:
I have the same problem with a movie. Its Dolby Digital Plus and it the TV is silent. The DTS Track works. I tried to create all the logs, but there were so many, even after a restart. which logs do you need exactly?

The instructions are in the post above yours.
There would be:
a zip of the server logs
Media Info xml text file
Apple TV Plex log copied into text file or Plex for iOS zipped Logs which you email to yourself and then attach
and indication of time of error and symptoms


#18

Happening here as well. Definitely EAC3 is the root of the problem.

Latest beta of the server, and tvOS stream is converting DCA to EAC3.

iOS mobile is converting the same clip DCA to AAC.

iOS mobile works like a champ, tvOS is silent.


#19

Okay now im losing my mind. somehow it started working… but only on certain movies… and doesnt work on others. will send along the logs when they finish baking in 20 min


#20

As a sidenote: Marantz Receiver, limited support… http://us.marantz.com/us/Products/Pages/ProductDetails.aspx?CatId=avreceivers&ProductId=NR1508

Appears AppleTV is attempting to passthrough the audio and failing.

Would be great if we could just force AAC or standard AC3