# EasyAudioEncoder failed (13)

**URL:** <https://forums.plex.tv/t/easyaudioencoder-failed-13/834110>\
**Category:** Plex Media Server\
**Tags:** server-linux\
**Created:** [March 11, 2023, 3:17pm UTC](https://forums.plex.tv/t/easyaudioencoder-failed-13/834110 "2023-03-11T15:17:04Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![Italicize4786](https://avatars.discourse-cdn.com/v4/letter/i/e480ec/32.png) [@Italicize4786](https://forums.plex.tv/u/Italicize4786)\
**Post date:** [March 11, 2023, 3:17pm UTC](https://forums.plex.tv/t/easyaudioencoder-failed-13/834110/1 "2023-03-11T15:17:05Z")

</div>

Server Version#: Current  
Player Version#: Current

Audio issues with TrueHD again. You JUST resolved this in the previous update and you’ve managed to break it again somehow. Guess I’ll be downgrading again until it gets fixed, but come on guys. Why is this happening again?

Movies can’t play with TrueHD audio codec. The easyaudio encoder fails:

 ![image](https://global.discourse-cdn.com/plex/original/4X/3/f/b/3fb33194ebde140d15149c35f5cab83187ddbbee.jpeg)

We had this issue a couple of versions ago with a different error, but under the same category. It only fails with movies that have the TrueHD audio codec.

Here’s the link to the previous issue: [link](https://forums.plex.tv/t/trouble-transcoding-decoder-error-121/818988)

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [March 11, 2023, 6:04pm UTC](https://forums.plex.tv/t/easyaudioencoder-failed-13/834110/2 "2023-03-11T18:04:52Z")

</div>

See the error ? (13) ??

> [chuck@lizum ~.2001]$ perror 13  
> Exit code(13): error “Permission denied”  
> [chuck@lizum ~.2002]$

What’s wrong with your container storage ?

---

<div class="post-metadata">

**Author:** ![Italicize4786](https://avatars.discourse-cdn.com/v4/letter/i/e480ec/32.png) [@Italicize4786](https://forums.plex.tv/u/Italicize4786)\
**Post date:** [April 4, 2023, 12:05am UTC](https://forums.plex.tv/t/easyaudioencoder-failed-13/834110/3 "2023-04-04T00:05:36Z")

</div>

I’m not sure. I think I have PTSD from the last issue so I quickly assumed it was Plex. If it something that I can fix on my end please let me know.

---

<div class="post-metadata">

**Author:** ![Italicize4786](https://avatars.discourse-cdn.com/v4/letter/i/e480ec/32.png) [@Italicize4786](https://forums.plex.tv/u/Italicize4786)\
**Post date:** [April 4, 2023, 12:10am UTC](https://forums.plex.tv/t/easyaudioencoder-failed-13/834110/4 "2023-04-04T00:10:40Z")

</div>

I have plenty of storage so I don’t know why there would be an issue with that. I check the temp file and it’s completely empty.

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [April 4, 2023, 12:20am UTC](https://forums.plex.tv/t/easyaudioencoder-failed-13/834110/5 "2023-04-04T00:20:38Z")

</div>

The error snippet you posted shows “permission denied”

It tried to download the EAE but couldn’t unzip it.

It’s going to be a silly permissions / ownership issue writing to the Codecs directory

---

<div class="post-metadata">

**Author:** ![Italicize4786](https://avatars.discourse-cdn.com/v4/letter/i/e480ec/32.png) [@Italicize4786](https://forums.plex.tv/u/Italicize4786)\
**Post date:** [April 4, 2023, 12:57am UTC](https://forums.plex.tv/t/easyaudioencoder-failed-13/834110/6 "2023-04-04T00:57:20Z")

</div>

What’s strange is this didn’t happen until I updated the Plex Server. I don’t even know what permissions I need to change. Everything that deals with Plex is under the same umbrella of permissions.

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [April 4, 2023, 1:00am UTC](https://forums.plex.tv/t/easyaudioencoder-failed-13/834110/7 "2023-04-04T01:00:02Z")

</div>

> [@Italicize4786](#):
>
> happen until I updated the Plex Server.

☝ This is when it would update.

Can you give me a `ls -la` of the Codecs directory ?

---

<div class="post-metadata">

**Author:** ![Italicize4786](https://avatars.discourse-cdn.com/v4/letter/i/e480ec/32.png) [@Italicize4786](https://forums.plex.tv/u/Italicize4786)\
**Post date:** [April 4, 2023, 1:03am UTC](https://forums.plex.tv/t/easyaudioencoder-failed-13/834110/8 "2023-04-04T01:03:33Z")

</div>

![image](https://global.discourse-cdn.com/plex/original/4X/b/0/6/b0694527e1b6b43a86852e7c945713aa51ea1d28.png)  
Is this what you are looking for?

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [April 4, 2023, 1:07am UTC](https://forums.plex.tv/t/easyaudioencoder-failed-13/834110/9 "2023-04-04T01:07:09Z")

</div>

Not quite.

under the “Plex Media Server” directory

1. get into the container command line
2. cd “/config/Plex Media Server”
3. `ls -la`
4. `ls -la Config`

you can highlight the console output and copy it  
then paste here in your reply. (easier than a screenshot)

---

<div class="post-metadata">

**Author:** ![Italicize4786](https://avatars.discourse-cdn.com/v4/letter/i/e480ec/32.png) [@Italicize4786](https://forums.plex.tv/u/Italicize4786)\
**Post date:** [April 4, 2023, 1:14am UTC](https://forums.plex.tv/t/easyaudioencoder-failed-13/834110/10 "2023-04-04T01:14:34Z")

</div>

Here’s what it gave me in the container command line:

> sh-5.1# cd “/config/Plex Media Server”  
> sh-5.1# ls -la  
> total 32  
> drwxrwxrwx 1 nobody users 215 Apr 3 17:54 .  
> drwxrwxrwx 1 nobody users 31 Nov 16 12:33 …  
> drwxrwxrwx 1 nobody users 233 Apr 3 17:45 Cache  
> drwxrwxrwx 1 nobody users 39 Apr 3 16:51 Codecs  
> drwxrwxrwx 1 nobody users 35 Apr 3 16:54 ‘Crash Reports’  
> drwxrwxrwx 1 nobody users 6 Nov 17 02:01 Diagnostics  
> drwxrwxrwx 1 nobody users 6 Nov 15 09:43 Drivers  
> -rw-rw-rw- 1 nobody users 42 Apr 3 16:54 .LocalAdminToken  
> drwxrwxrwx 1 nobody users 4096 Apr 3 18:06 Logs  
> drwxrwxrwx 1 nobody users 23 Nov 15 09:49 Media  
> drwxrwxrwx 1 nobody users 20 Nov 16 20:31 Metadata  
> -rw-rw-rw- 1 nobody users 2 Apr 3 16:54 plexmediaserver.pid  
> drwxrwxrwx 1 nobody users 6 Nov 15 09:44 Plug-ins  
> drwxrwxrwx 1 nobody users 35 Nov 15 09:44 ‘Plug-in Support’  
> -rw-rw-rw- 1 nobody users 1339 Apr 3 17:54 Preferences.xml  
> drwxrwxrwx 1 nobody users 39 Feb 15 02:53 Scanners  
> -rw-rw-rw- 1 nobody users 12330 Apr 3 16:54 ‘Setup Plex.html’  
> drwxrwxrwx 1 nobody users 6 Nov 15 09:44 Updates  
> sh-5.1# ls -la Config  
> ls: cannot access ‘Config’: No such file or directory

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [April 4, 2023, 1:18am UTC](https://forums.plex.tv/t/easyaudioencoder-failed-13/834110/11 "2023-04-04T01:18:39Z")

</div>

Ooops… “Codecs”.

The “nobody” bothers me.

What’s the PUID/PGID , or PLEX\_UID/PLEX\_GID, ? mapping as “Nobody” isn’t a good sign.

---

<div class="post-metadata">

**Author:** ![Italicize4786](https://avatars.discourse-cdn.com/v4/letter/i/e480ec/32.png) [@Italicize4786](https://forums.plex.tv/u/Italicize4786)\
**Post date:** [April 4, 2023, 1:24am UTC](https://forums.plex.tv/t/easyaudioencoder-failed-13/834110/12 "2023-04-04T01:24:02Z")

</div>

> sh-5.1# ls -la Codecs  
> total 996  
> drwxrwxrwx 1 nobody users 39 Apr 3 16:51 .  
> drwxrwxrwx 1 nobody users 215 Apr 3 17:54 …  
> drwxrwxrwx 1 nobody users 31 Apr 3 16:51 2584b51-4483-linux-x86\_64  
> -rw-rw-rw- 1 nobody users 36 Nov 15 09:43 .device-id  
> drwxrwxrwx 1 nobody users 30 Nov 21 08:45 EasyAudioEncoder-1847-linux-x86\_64  
> -rw-rw-rw- 1 nobody users 1011734 Dec 9 14:12 EasyAudioEncoder-1847-linux-x86\_64.zip

Here you go! I haven’t messed with permissions and the default was nobody. Do you have a preference as to what I should change it to?

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [April 4, 2023, 2:03am UTC](https://forums.plex.tv/t/easyaudioencoder-failed-13/834110/13 "2023-04-04T02:03:22Z")

</div>

I have Unraid now and the container I have looks like this:

```auto
root@BabyNUC:~# docker container list
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
1060595ada26 plexinc/pms-docker "/init" 6 weeks ago Up 6 minutes (healthy) Plex-Media-Server
root@BabyNUC:~# docker exec -it Plex-Media-Server bash
root@BabyNUC:/# ls
DBR.sh config etc home lib libexec mnt plex_service.sh run sys usr
bin data glock init lib32 libx32 opt proc sbin tmp var
boot dev healthcheck.sh installBinary.sh lib64 media plex-common.sh root srv transcode version.txt
root@BabyNUC:/# cd /config
root@BabyNUC:~# ls
Library glock transcode
root@BabyNUC:~# cd Library/Application\ Support/Plex\ Media\ Server/
root@BabyNUC:~/Library/Application Support/Plex Media Server# ls -la
total 40
drwxr-xr-x 1 plex users 4096 Apr 3 21:52 .
drwxr-xr-x 1 root root 39 Feb 17 16:36 ..
-rw------- 1 plex users 42 Apr 3 21:52 .LocalAdminToken
drwxr-xr-x 1 plex users 4096 Apr 3 21:53 Cache
drwxr-xr-x 1 plex users 115 Feb 28 20:27 Codecs
drwxr-xr-x 1 plex users 301 Apr 3 21:52 'Crash Reports'
drwxr-xr-x 1 plex users 6 Feb 17 16:36 Diagnostics
drwxr-xr-x 1 plex users 40 Feb 17 17:32 Drivers
drwxr-xr-x 1 plex users 4096 Apr 3 21:58 Logs
drwxr-xr-x 1 plex users 31 Feb 17 17:17 Media
drwxr-xr-x 1 plex users 48 Feb 17 17:41 Metadata
drwxr-xr-x 1 plex users 120 Feb 17 16:37 'Plug-in Support'
drwxr-xr-x 1 plex users 6 Feb 17 16:36 Plug-ins
-rw------- 1 plex users 1312 Apr 3 21:52 Preferences.xml
-rw------- 1 plex users 12330 Apr 3 21:52 'Setup Plex.html'
drwxr-xr-x 1 plex users 6 Feb 17 16:36 Updates
-rw-r--r-- 1 plex users 3 Apr 3 21:52 plexmediaserver.pid
root@BabyNUC:~/Library/Application Support/Plex Media Server# cd Codecs
root@BabyNUC:~/Library/Application Support/Plex Media Server/Codecs# ls -la
total 12
drwxr-xr-x 1 plex users 115 Feb 28 20:27 .
drwxr-xr-x 1 plex users 4096 Apr 3 21:52 ..
-rw-r--r-- 1 plex users 36 Feb 17 16:36 .device-id
drwxr-xr-x 1 plex users 4096 Feb 28 20:27 2584b51-4483-linux-x86_64
drwxr-xr-x 1 plex users 38 Feb 17 17:50 EasyAudioEncoder-1847-linux-x86_64
root@BabyNUC:~/Library/Application Support/Plex Media Server/Codecs# uname -a
Linux BabyNUC 5.19.17-Unraid #2 SMP PREEMPT_DYNAMIC Wed Nov 2 11:54:15 PDT 2022 x86_64 x86_64 x86_64 GNU/Linux
root@BabyNUC:~/Library/Application Support/Plex Media Server/Codecs#

```

---

<div class="post-metadata">

**Author:** ![Italicize4786](https://avatars.discourse-cdn.com/v4/letter/i/e480ec/32.png) [@Italicize4786](https://forums.plex.tv/u/Italicize4786)\
**Post date:** [April 4, 2023, 2:19am UTC](https://forums.plex.tv/t/easyaudioencoder-failed-13/834110/14 "2023-04-04T02:19:44Z")

</div>

Would changing it fix my issue?

---

<div class="post-metadata">

**Author:** ![Italicize4786](https://avatars.discourse-cdn.com/v4/letter/i/e480ec/32.png) [@Italicize4786](https://forums.plex.tv/u/Italicize4786)\
**Post date:** [April 4, 2023, 2:20am UTC](https://forums.plex.tv/t/easyaudioencoder-failed-13/834110/15 "2023-04-04T02:20:22Z")

</div>

Either way, they are all under the same user “nobody” so I wouldn’t think changing that would fix it.

---

<div class="post-metadata">

**Author:** ![Italicize4786](https://avatars.discourse-cdn.com/v4/letter/i/e480ec/32.png) [@Italicize4786](https://forums.plex.tv/u/Italicize4786)\
**Post date:** [April 4, 2023, 2:47am UTC](https://forums.plex.tv/t/easyaudioencoder-failed-13/834110/16 "2023-04-04T02:47:25Z")

</div>

I’m rebooting my server for other reasons, but once it’s back up I’ll send you my PUID/PGID numbers.

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [April 4, 2023, 2:51am UTC](https://forums.plex.tv/t/easyaudioencoder-failed-13/834110/17 "2023-04-04T02:51:10Z")

</div>

I just figured out what you’re showing me…

You’re showing me outside the container.

```auto
cd /mnt/user/appdata/Plex-Media-Server/Library/Application\ Support/
root@BabyNUC:/mnt/user/appdata/Plex-Media-Server/Library/Application Support# ls -la
total 4
drwxr-xr-x 1 root root 39 Feb 17 13:36 ./
drwxr-xr-x 1 root root 41 Feb 17 13:36 ../
drwxr-xr-x 1 nobody users 4096 Apr 3 18:52 Plex\ Media\ Server/
root@BabyNUC:/mnt/user/appdata/Plex-Media-Server/Library/Application Support# cd Plex\ Media\ Server/
root@BabyNUC:/mnt/user/appdata/Plex-Media-Server/Library/Application Support/Plex Media Server# ls -la Codecs
total 12
drwxr-xr-x 1 nobody users 115 Feb 28 17:27 ./
drwxr-xr-x 1 nobody users 4096 Apr 3 18:52 ../
-rw-r--r-- 1 nobody users 36 Feb 17 13:36 .device-id
drwxr-xr-x 1 nobody users 4096 Feb 28 17:27 2584b51-4483-linux-x86_64/
drwxr-xr-x 1 nobody users 38 Feb 17 14:50 EasyAudioEncoder-1847-linux-x86_64/
root@BabyNUC:/mnt/user/appdata/Plex-Media-Server/Library/Application Support/Plex Media Server# 

```

Inside the container, you see

```auto
root@BabyNUC:/# cd /config/Library/Application\ Support/Plex\ Media\ Server/
root@BabyNUC:~/Library/Application Support/Plex Media Server# cd Codecs
root@BabyNUC:~/Library/Application Support/Plex Media Server/Codecs# ls -la
total 12
drwxr-xr-x 1 plex users 115 Feb 28 20:27 .
drwxr-xr-x 1 plex users 4096 Apr 3 21:52 ..
-rw-r--r-- 1 plex users 36 Feb 17 16:36 .device-id
drwxr-xr-x 1 plex users 4096 Feb 28 20:27 2584b51-4483-linux-x86_64
drwxr-xr-x 1 plex users 38 Feb 17 17:50 EasyAudioEncoder-1847-linux-x86_64
root@BabyNUC:~/Library/Application Support/Plex Media Server/Codecs# 

```

Whose Plex image are you using ?  
It’s not Plex

---

<div class="post-metadata">

**Author:** ![Italicize4786](https://avatars.discourse-cdn.com/v4/letter/i/e480ec/32.png) [@Italicize4786](https://forums.plex.tv/u/Italicize4786)\
**Post date:** [April 4, 2023, 2:52am UTC](https://forums.plex.tv/t/easyaudioencoder-failed-13/834110/18 "2023-04-04T02:52:28Z")

</div>

I’m inside the container’s command line, so I thought I was showing you within the container, not outside it.

I’m using the binhex image.

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [April 4, 2023, 2:54am UTC](https://forums.plex.tv/t/easyaudioencoder-failed-13/834110/19 "2023-04-04T02:54:29Z")

</div>

I will spin up a binhex container and see what happens but using the official, I can’t replicate your issue with EAE downloading / permissions unzipping.

---

<div class="post-metadata">

**Author:** ![Italicize4786](https://avatars.discourse-cdn.com/v4/letter/i/e480ec/32.png) [@Italicize4786](https://forums.plex.tv/u/Italicize4786)\
**Post date:** [April 4, 2023, 2:56am UTC](https://forums.plex.tv/t/easyaudioencoder-failed-13/834110/20 "2023-04-04T02:56:22Z")

</div>

Good to know. I might have to use the official, but to have to rebuild my media all back together would be an absolute nightmare. Hopefully you’re able to replicate. Keep me updated.

[Next page](https://forums.plex.tv/t/easyaudioencoder-failed-13/834110.md?page=2)
