embedded subtitles not displaying in Plex for Kodi

plex-for-kodi

#1

Hi all--
I've never been able to get embedded subtitles to work in PfK, both with Kodi 17.5, PfK 0.1.3, as well as the beta Kodi 18.0-Alpha1 and PfK 0.1.4a1 . This is on an AFTV ARMv7 box, with PMS 1.9.7.4460

I have several videos that use either SRT or ASS subtitling and I can never get those subtitles to display on PfK. I also have media with the "sidecar" .srt files, and these are not working with PfK. And yet all these same media files play with subtitles properly displaying on the web browser player, or even my Android player (a Dell 8 Venue tablet).

Can anyone recommend troubleshooting/settings to check? I feel like I've tried everything. thanks!


#2

Same problem here. Can’t get any subtitles to work with kodi. Any way to fix this?

They show up in the dropdown as available but won’t show on screen.


#3

use mkvtoolnix to embedded subtitles


#4

I regularly use subtitles. Both .srt and embedded as I give the media to my father who is a little hard of hearing. Do the subtitles work directly within kodi. I’m using a raspberry pi running libreelec and they’ve been working fine on kodi 17 and 18 on all current and previous versions of pfk


#5

Never had a single issue with subs, embedded or sidecar. Using 17.6 on multiple platforms: Win, Mac and Android (Nvidia Shield).

I think you should post the log files for the devs to have a look at the issue.


#6

Only things I can suggest are:

Ensure you’ve set all your regional and language settings correctly in Kodi

https://kodi.wiki/view/subtitles

Set your default sub language to english as per kodi subtitle wiki

Ensure you have followed the PLEX naming convention for subs:

Ie. Subtitle.en.srt

Ensure subs are enabled from the kodi audio settings selectable from within PFK when an item is playing


#7

I have the exact same issue: my videos all are mp4 and most have embedded subtitles. The only thing the Plex plug-in can show me in the film parameters section is “none - 1 available” (message may not be accurate, I have the french version “aucun - 1 disponible”). Selecting this item produces nothing.

Kodi logs say:
21:16:55.894 T:1249899264 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<–
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <type ‘exceptions.UnicodeEncodeError’>
Error Contents: ‘ascii’ codec can’t encode character u’\xe9’ in position 12: ordinal not in range(128)
Traceback (most recent call last):
File “/home/osmc/.kodi/addons/script.plex/lib/windows/playersettings.py”, line 51, in onClick
self.editSetting()
File “/home/osmc/.kodi/addons/script.plex/lib/windows/playersettings.py”, line 130, in editSetting
showSubtitlesDialog(self.video, non_playback=self.nonPlayback)
File “/home/osmc/.kodi/addons/script.plex/lib/windows/playersettings.py”, line 245, in showSubtitlesDialog
options.append((s, s.getTitle(metadata.apiTranslate)))
File “/home/osmc/.kodi/addons/script.plex/lib/_included_packages/plexnet/plexstream.py”, line 67, in getTitle
title += " ({0})".format(’/’.join(extras))
UnicodeEncodeError: ‘ascii’ codec can’t encode character u’\xe9’ in position 12: ordinal not in range(128)
–>End of Python script error report<–


#8

As a side note to developers, changing line 67 of plexstream.py (and restarting Plex) with:

            title += u" ({0})".format('/'.join(extras))

solves the issue.


#9

Since my Plex for Kodi plugin was upgraded to 0.1.4, I have the same problem as JéromeLa.
About 70% of my library is MP4 videos with embedded subtitles (mov_text / tx3g)

With PfK v0.1.4, when I try to play a video, I can’t access the select box for selecting subtitles… It says ‘Aucun - 3 available’ but whenever I click on the select box, nothing happens. Moreover, on some videos, when I open the Parameter popup for the video (the place where you can select the audio/subtitle stream to play and its quality), the popup is simply empty… nothing is displayed inside it. Tested and reproductible on MP4 videos with embedded subtitles, and also on MKV videos with external subtitles.

I reverted to PfK v0.1.3 and it works perfectly. Then I restored PfK v0.1.4 and the problem was back.

My Plex Server is on NVidia Shield. When using official Plex client for the Shield, audio streams and subtitles are correctly selectable and displayed when the videos are playing. So I assume this is a regression inside PfK v0.1.4 code since it worked perfectly on 0.1.3.

Plex Media Server v1.13.5003 (on Nvidia Shield)
Kodi v17.6
Plex for Kodi v0.1.4


#10

Same annoying bug for me.
I was using Plex Android client on my Shield until February and switched to Kodi with the Plex extension to avoid the bugs and transcoding for almost everything that uses subtitles or audio formats other than AAC…
Plex client quality is really poor since using exoplayer…

So, Plex for Kodi was working flawlessy until yesterday. Now the parameters windows allowing to select audio or subtitles doesn’t work. For some videos it appears empty, for other it displays infos but it’s impossible to open the subtitles selection window.

As mentioned above, I tried to revert to 0.1.4. Same problem.
Problem is solved when I switch back to 0.1.3.

Plex Media Server v1.12.3.4973 (on Nvidia Shield)
Kodi v17.6
Plex for Kodi v0.1.5


#11

@“JérômeLa”: Thanks for the useful info.

@mbarbeaux, @adzer0: I’ve implemented fixes based on @“JérômeLa”'s info, but that is in code that has been here forever. It’s likely that it will have no effect on your issues since those started with 0.1.4. If you could provide me with a Kodi log (feel free to PM it o me) that would be very helpful, as I can’t duplicate the issue here.


#12

@mbarbeaux, @adzer0: Why don’t you try the attached version. On reflection I remembered that there were some translations added for French (and other languages) in 0.1.4 that may have triggered the error @“JérômeLa” pointed to.

Edit: Testing now with language set to French without the fix causes the error, and using the attached version it goes away, so I’m hopeful that this might fix your issue if you are both using one of the translated languages.


#13

Had another user verify the fix. Pushed the changes to the official Kodi repo.