Enabling remote access

server-linux

#1

Hi, I need some help here making my server reachable from an outside client.

Here you can see my server’s IP and MAC address:

In my router, I opened the port for this IP:

Yet Plex is still unreachable…

Am I missing something here?

Thanks for the help.

Moderator Edit: User IP address removed for security reasons


#2

Which distribution and version of Linux please?


#3

Ubuntu 17.04 64 bits.


#4

If your firewall is enabled, you must also open the port for it to come through sudo ufw allow 32400/tcp


#5

Just did that...nothing has changed
But thanks :(


#6

Pull the log files (Settings - Server - Help - Download Logs) and attach the ZIP file here. Let me see if there's something obvious getting in the way


#7

Firewall is disabled anyway:
ytagger@ytagger-server:~$ sudo ufw status verbose
Status: inactive


#8

Here they are...


#9

Thanks.. Found a major problem right away.

Sep 28, 2017 20:30:14.641 [0x7f2eca7fd700] ERROR - Error issuing curl_easy_perform(handle): 6
Sep 28, 2017 20:30:14.641 [0x7f2eca7fd700] WARN - HTTP error requesting GET http://ocspx.digicert.com/MFEwTzBNMEswSTAJBgUrDgMCGgUABBSnVdbEyh8T3xvVlkPGHNCJxnqCPgQUlIuJ90hyifJRStmIe%2BVhtaqc1QECEAFt4t3E9SbwzlNYy0MLa%2B4%3D (0, No error) (Couldn't resolve host 'ocspx.digicert.com')
Sep 28, 2017 20:30:14.642 [0x7f2eca7fd700] ERROR - OCSP response error: -6
Sep 28, 2017 20:30:14.642 [0x7f2ecc7ff700] DEBUG - DVR:Grabber: Cleaning up orp

DNS lookup failure. Check the IP of the DNS server in the host's network settings

Test it with nslookup plex.tv


#10

This is what I get:
ytagger@ytagger-server:~$ nslookup plex.tv
Server: 127.0.0.53
Address: 127.0.0.53#53

Non-authoritative answer:
Name:   plex.tv
Address: 52.18.201.205
Name:   plex.tv
Address: 52.48.171.114
Name:   plex.tv
Address: 52.212.16.88
Name:   plex.tv
Address: 52.17.42.37
Name:   plex.tv
Address: 52.48.208.249
Name:   plex.tv
Address: 54.72.10.166

#11

mmm...a while back I changed the DNS settings on the router to use 8.8.8.8 and 8.8.4.4. Could this be related?


#12

I can only show you that PMS is has a lookup failure.

I apologize for sending you on a bit of wild chase. This was buried further down in your logs.

Sep 28, 2017 20:30:22.593 [0x7f2ebebf4700] DEBUG - PublicAddressManager: got WAN IP 100.66.62.169 from router

Your ISP uses CGNAT (Carrier Grade NAT). This means they put your modem on a (big) LAN internal to them.. What PMS sees is:

Computer -> Your LAN -> modem -> ISP LAN - ISP router -> Internet.

there is no way to connect through that.

Your only recourse is to contact your ISP and ask/ subscribe (some charge) for a Public IP address. It doesn't need to be static. You only need a public-facing real IP address.


#13

Here is the full block which you can find in your logs.

Sep 28, 2017 20:30:22.593 [0x7f2ebebf4700] DEBUG - NAT: UPnP, public address is 100.66.62.169
Sep 28, 2017 20:30:22.593 [0x7f2ebebf4700] DEBUG - PublicAddressManager: got WAN IP 100.66.62.169 from router
Sep 28, 2017 20:30:22.593 [0x7f2ebebf4700] WARN - PublicAddressManager: WAN IP on router does not match public IP from plex.tv
Sep 28, 2017 20:30:23.421 [0x7f2eca7fd700] DEBUG - PubSubManager: Time to connect to 139.162.144.200 was 135 ms.
Sep 28, 2017 20:30:23.421 [0x7f2eca7fd700] DEBUG - PubSubManager: Time to connect to 139.162.164.202 was 142 ms.

Notice the WAN IP on router does not match public IP from plex.tv. This is verification you're behind another layer of NAT


#14

Thanks for the help. Would have never discovered that by myself.
(Thank you too for removing the picture with my IP).

How do I mark you post as an answer?? I don’t see the option:


#15

Hi, just wanted to update.
Called my ISP and it was indeed that they were usinh CGNAT, now it's working.
Thanks!!