Enabling subtitles grows more difficult in latest releases?

plex-media-player

#1

Turning subtitles on/off while playing seems to have gotten even harder with the recent release.

When I go to the player settings and enable subtitles, the [back] button stops the video and returns me to the episode info screen. In the previous release, it would just go back to playing (maybe after a quick rebuffer).

Is there an way to toggle subtitles with the remote that's easier than "[ok] [right] [right] [right] [right] [right] [ok] [down] [right] [down] [ok] [back] [ok] [ok]"? I do this several times a week and it's awful.


#2

Do you have some keys available on your remote?
You can assign them the desired action.
https://support.plex.tv/articles/216459997-create-your-own-inputmap/

cycle_subtitles – cycle forward between available subtitle streams
cycle_subtitles_back – cycle backward between available subtitle streams
toggle_subtitles – toggle whether to display (current) subtitles


#3

Thanks! I’m going to give that a shot later.

Still, I’d say the UX folks at Plex should be giving some thought to how difficult they’re making it to toggle subtitles in the default configuration.


#4

@addingnumbers said:
When I go to the player settings and enable subtitles, the [back] button stops the video and returns me to the episode info screen. In the previous release, it would just go back to playing (maybe after a quick rebuffer).

This sounds to me like the ‘Back’ button is triggered twice.
Are you able to use the Esc button instead?

What kind of remote are you using?


#5

Are you able to use the Esc button instead?

Yeah, [esc] closes the Player Setting window and goes back to the video while [back] goes all the way back to the media screen only if I changed the subtitle setting.

What kind of remote are you using?

Logitech Harmony Smart Control


#6

Unfortunately I have no Harmony to reproduce the issue.
When I press the ‘Backspace’ key (which is the equivalent to ‘Return’) I get immediately back to the playing movie.
Which suggests it has something to do with the way the Harmony maps this particular key.


#7

I think the Harmony is just mapping the inputs to the old Windows MCE remote signals.

You’ve got to be right, though, about the remote using some wonky mapping – both [esc] and [backspace] give me the behavior I’d seen with this remote in previous releases. I’m going to try to map the button directly to [backspace] instead of using the straight MCE emulation.

Still, I’d like for someone at Plex to consider how difficult it is to toggle subtitles with the default controls. I’m glad to go back to twelve presses instead of fourteen, but that’s still a lot of button mashing for a routine operation.


#8

If you can remap buttons easily, then I suggest you map

L cycle_subtitles – cycle forward between available subtitle streams
CTRL+L cycle_subtitles_back – cycle backward between available subtitle streams
S toggle_subtitles – toggle whether to display (current) subtitles

(These are the default mappings on a regular keyboard)

You can’t get more direct than that.


#9

Since the four “color” buttons weren’t mapped to anything on my remote, I mapped red to L and green to S.

It’s been working great, thanks for the tips!