Enabling Vobsub/ASS subtitles severley lowers video quality

samsung-smart-hub

#1

Hi,

Whenever I watch anime through the Samsung Smart Hub app that requires subtitles, after about a minute of playback the video quality degrades to a lower resolution. Stopping the video and then continuing seems to fix it, only for it to happen again shortly afterwards.

This only seems to happen with Vobsub and ASS subtitles, SRT is fine. It happens when streaming and transcoding.

To prevent this from happening I have to burn in the subtitles using Handbrake. Surely there's a way to fix this?


#2

Could you check if you have “Auto adjust transcoding quality” turned on?
If so try to switch it off and set a fixed transcoding quality under advanced.


#3

The only setting in PMS I can find that resembles that is “Automatically adjust quality (Beta)”. Video quality dips whenever using streaming/transcoding regardless of whether this setting is turned on or off.

It was set to on with video quality set to 8 Mbps, 1080p. I now have it turned off with video quality set to Maximum and I’m getting the same result.


#4

I was talking about the TV app setting, found under Preferences > Player


#5

I don’t see a setting called “Auto adjust transcoding quality” on the TV app.

Are any of these the one?

Initial Buffer - Auto
Pending Buffer - Auto
Total Buffer - Auto

I have no clue what these settings are for. :stuck_out_tongue:


#6

OK lets start with what version app your are using and what model TV.
If it’s a 2016+ model, you are in the wrong forum, you need to go here .


#7

According to the Plex app:

Your TV: UE55JU6400 is a J-series (2015) model
Plex app version: 2.008


#8

There is a newer version (2.009) available, you should be able to install it from the appstore on your TV.


#9

Found the app on the app store and there is indeed a new version. I don’t see an option to update it. Delete the app and install it again, perhaps?


#10

Select the app icon then Press and Hold the enter button on your remote. A new menu should appear.


#11

Pressing and holding the enter button gives me the option to delete the app, pin the app and open the app in Multi-Screen. No update option.

I’ve found a post of yours from 2015 telling someone to uninstall the app, power down the TV for a while and then reinstall the app. Reckon this will still work?


#12

Oh wait you have a 2015 model, that tip only works on older models.

Just go ahead and uninstall it, unplug the TV fro a minute , to be safe, then add it from the store

https://www.youtube.com/watch?v=Hf1IUlNstYQ


#13

Done.

Now about those settings…


#14

Please download the manual, it explains how the app works and where to find the settings.
The link to the manuals is in my footer.


#15

Having disabled the now present setting “Auto adjust transcoding quality”, video no longer decreases when streaming/transcoding subtitles! B)

I knew there’d be an easy fix for this. I never imagined it would be a matter of simply updating the app. Do Samsung apps not update automatically or something?

This kind of feature really needed to be turned off, for me at least. Thanks for the help, Orca.