# EPG (Guide Data) Not Showing - Database Error on fresh install

**URL:** <https://forums.plex.tv/t/epg-guide-data-not-showing-database-error-on-fresh-install/822334>\
**Category:** Live TV & DVR\
**Tags:** livetv-dvr, server-linux, livetv-streaming\
**Created:** [December 11, 2022, 5:34pm UTC](https://forums.plex.tv/t/epg-guide-data-not-showing-database-error-on-fresh-install/822334 "2022-12-11T17:34:23Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![tylerwmarrs](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/tylerwmarrs/32/294321_2.png) [@tylerwmarrs](https://forums.plex.tv/u/tylerwmarrs)\
**Post date:** [December 11, 2022, 5:34pm UTC](https://forums.plex.tv/t/epg-guide-data-not-showing-database-error-on-fresh-install/822334/1 "2022-12-11T17:34:23Z")

</div>

Server Version#: 1.29.2.6364-6d72b0cf6  
Docker Container: linuxserver/plex  
Player Version#: N/A  
Tuner Make/Model: HDHomeRun FLEX 4K  
Guide/Lineup name:  
Using XMLTV?: No

When running the refresh guide, the debug logs show that the database cannot be swapped out due to an error. This is on a fresh install of Plex using the docker container image:

See below.

Dec 11, 2022 11:01:44.935 [0x7f2115a80b38] ERROR - [Req#11cf] SQLITE3:0x80000001, 11, database corruption at line 66843 of [1b256d97b5]  
Dec 11, 2022 11:01:44.935 [0x7f2115a80b38] ERROR - [Req#11cf] SQLITE3:0x80000001, 11, database corruption at line 66993 of [1b256d97b5]  
Dec 11, 2022 11:01:44.935 [0x7f2115a80b38] ERROR - [Req#11cf] SQLITE3:0x80000001, 11, statement aborts at 10: database disk image is malformed  
Dec 11, 2022 11:01:44.935 [0x7f2115a80b38] ERROR - [Req#11cf] SQLITE3:0x80000001, 11, database disk image is malformed in “PRAGMA cache\_size=2000”  
Dec 11, 2022 11:01:44.937 [0x7f2115a80b38] ERROR - [Req#11cf] SQLITE3:0x80000001, 11, database corruption at line 66843 of [1b256d97b5]  
Dec 11, 2022 11:01:44.937 [0x7f2115a80b38] ERROR - [Req#11cf] SQLITE3:0x80000001, 11, database corruption at line 66993 of [1b256d97b5]  
Dec 11, 2022 11:01:44.937 [0x7f2115a80b38] ERROR - [Req#11cf] SQLITE3:0x80000001, 11, statement aborts at 10: database disk image is malformed  
Dec 11, 2022 11:01:44.937 [0x7f2115a80b38] ERROR - [Req#11cf] SQLITE3:0x80000001, 11, database disk image is malformed in “select \* from metadata\_items limit 1”  
Dec 11, 2022 11:01:44.937 [0x7f2115a80b38] ERROR - [Req#11cf] EPG: We caught an exception trying to swap out the database: sqlite3\_statement\_backend::prepare: database disk image is malformed for SQL: PRAGMA cache\_size=2000

---

<div class="post-metadata">

**Author:** ![FordGuy61](https://avatars.discourse-cdn.com/v4/letter/f/22d042/32.png) [@FordGuy61](https://forums.plex.tv/u/FordGuy61)\
**Post date:** [December 11, 2022, 5:44pm UTC](https://forums.plex.tv/t/epg-guide-data-not-showing-database-error-on-fresh-install/822334/2 "2022-12-11T17:44:12Z")

</div>

You’ve three choices:  
a) [repair the database](https://support.plex.tv/articles/repair-a-corrupted-database/)  
b) [restore from a backup](https://support.plex.tv/articles/202485658-restore-a-database-backed-up-via-scheduled-tasks/)  
c) delete it and start over

If you choose the last option you will have to re-create your libraries. Your media is not touched.

Click on the links above to see directions on repairing or restoring.

Also, check out @ChuckPA’s database repair utility posted on GitHub. It is easier than typing in the SQLite commands yourself.

> **[GitHub - ChuckPa/PlexDBRepair: Database repair utility for Plex Media Server...](https://github.com/ChuckPa/PlexDBRepair)**
>
> Database repair utility for Plex Media Server databases - GitHub - ChuckPa/PlexDBRepair: Database repair utility for Plex Media Server databases

---

<div class="post-metadata">

**Author:** ![tylerwmarrs](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/tylerwmarrs/32/294321_2.png) [@tylerwmarrs](https://forums.plex.tv/u/tylerwmarrs)\
**Post date:** [December 11, 2022, 5:46pm UTC](https://forums.plex.tv/t/epg-guide-data-not-showing-database-error-on-fresh-install/822334/3 "2022-12-11T17:46:57Z")

</div>

Sorry I forgot to mention that this is the output from a clean install. I have also went through the process of database repair to no avail. Every time I refresh the guide, it gives this error.

---

<div class="post-metadata">

**Author:** ![FordGuy61](https://avatars.discourse-cdn.com/v4/letter/f/22d042/32.png) [@FordGuy61](https://forums.plex.tv/u/FordGuy61)\
**Post date:** [December 11, 2022, 6:07pm UTC](https://forums.plex.tv/t/epg-guide-data-not-showing-database-error-on-fresh-install/822334/4 "2022-12-11T18:07:30Z")

</div>

> [@tylerwmarrs](#):
>
> Sorry I forgot to mention that this is the output from a clean install.

I thought you were updating to a new release.

If a completely new install, with no pre-existing database, libraries, etc, try deleting the Plex database.

1. Stop Plex Media Server
2. Navigate to the [Plex Data Folder](https://support.plex.tv/articles/202915258-where-is-the-plex-media-server-data-directory-located/) → Plug-in Support → Databases
3. Delete all the files in the Databases folder
4. Restart Plex Media Server

If the database is still corrupted, then something is wrong with the installation.

  
If there is a pre-existing database, then use the repair utility.

Depending on how things are configured, uninstalling Plex Media Server does not necessarily remove the [Plex Data Folder](https://support.plex.tv/articles/202915258-where-is-the-plex-media-server-data-directory-located/), where the database is located.

It is possible a pre-existing db was corrupt, but Plex could still run.

When updating to a new release, Plex may also update how the db is organized. If the db was already corrupt, the update may fail, and cause additional problems or Plex may even refuse to run.

Basically, there are degrees or db corruption. If only slightly corrupted, it may not yet be noticeable. However, updating to a new release may push things over the edge, necessitating the db repair process.

---

<div class="post-metadata">

**Author:** ![tylerwmarrs](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/tylerwmarrs/32/294321_2.png) [@tylerwmarrs](https://forums.plex.tv/u/tylerwmarrs)\
**Post date:** [December 11, 2022, 6:23pm UTC](https://forums.plex.tv/t/epg-guide-data-not-showing-database-error-on-fresh-install/822334/5 "2022-12-11T18:23:55Z")

</div>

I’ve went through these processes before. The one difference I can think of from a previous install is that I’m storing the plex database on a Samba share. My previous installation used a path on the local virtual machine. I’ll test this to see if it makes a difference.

---

<div class="post-metadata">

**Author:** ![FordGuy61](https://avatars.discourse-cdn.com/v4/letter/f/22d042/32.png) [@FordGuy61](https://forums.plex.tv/u/FordGuy61)\
**Post date:** [December 11, 2022, 6:38pm UTC](https://forums.plex.tv/t/epg-guide-data-not-showing-database-error-on-fresh-install/822334/6 "2022-12-11T18:38:22Z")

</div>

> [@tylerwmarrs](#):
>
> I’m storing the plex database on a Samba share

The db is on a different system, accessed via SMB or NFS?

That will lead to database corruption.

See Linux Tips: [Plex’s metadata on a network share. (Advanced users only)](https://forums.plex.tv/t/linux-tips/276247/14)

You _might_ be able to use iSCSI, since it appears as a local drive to the system. I’ve no experience with iSCSI, so don’t know how well it works (or doesn’t).

---

<div class="post-metadata">

**Author:** ![tylerwmarrs](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/tylerwmarrs/32/294321_2.png) [@tylerwmarrs](https://forums.plex.tv/u/tylerwmarrs)\
**Post date:** [December 11, 2022, 6:44pm UTC](https://forums.plex.tv/t/epg-guide-data-not-showing-database-error-on-fresh-install/822334/7 "2022-12-11T18:44:39Z")

</div>

This was 100% my problem. I switched the mount point to a local path on the VM and it works perfectly. I wasted 3 days trying to figure this out. Too bad Plex doesn’t use a different database instead of SQLITE. Thanks for your micro-journey helping me figure this out.

---

<div class="post-metadata">

**Author:** ![system](https://global.discourse-cdn.com/plex/original/3X/2/a/2acb9765406f63293d357b4ec509ec39aa28f2ad.png) [@system](https://forums.plex.tv/u/system)\
**Post date:** [March 11, 2023, 6:44pm UTC](https://forums.plex.tv/t/epg-guide-data-not-showing-database-error-on-fresh-install/822334/8 "2023-03-11T18:44:46Z")

</div>

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.
