Error message - problem selecting stream



I have a very strange issue which I think started after the previous update. I was running PMS under Windows when the problem first started but have since upgraded to The latest update has not fixed the problem.

I am casting music to a machine running Plex Media Player for Windows 64 bit version 3.14.1. When I play a track from the web app on the same machine as the PMS is running, the volume control displays that the speaker on the player is muted. It is not and the track actually plays correctly. If I try to change the volume I can see the volume bar for a moment and change it but then the display reverts to showing the speakers as muted. The volume change does work though.

Also when selecting a track to play when casting to the Windows device I get a red message box up for a few seconds saying "There was problem selecting this stream" yet it works.

I have tried restarting the server and all the apps. I also tried casting to the same device from another computer but I get the same thing, the error message displays but the track plays correctly. If I cast to a different device (Android tablet) it works correctly.

Has anyone come across before? Is it a bug in PMS or the Plex Media Player?


I suddenly realised that I have only tested this using the Plex web app as the device controlling the playing of the music. Despite testing casting to different devices I only tried it with the Plex web app on both machines. I have now tested it with several different apps on different devices with the following results:

  1. Using the Android app on a tablet to cast to the same Plex Media Player which fails in the tests above (PMP downloaded from the Google store). This works perfectly, no error messages, except that I cannot control the volume on the device I am casting to. This is not because it doesn’t work, it is because there appears to be no ability to control the volume on the casting device from the Android app. Please let me know if I just can’t find it.
  2. Using Plex Media Player for Windows on a 32bit Windows tablet casting to the same device (PMP downloaded from the Microsoft store). This also works perfectly with no error messages however, I still cannot control the volume on the casting device. This time it is not because there is no volume control, it is because the volume control doesn’t work. Muting the casting device works fine but changing the volume using the volume slider has no effect.
  3. Using Plex Media Player for Windows 64bit on the same device as PMS is running but casting to the same device as previously (PMP downloaded from the Plex website). This was one of the computers which failed using the Plex web app as described above. This appears to work correctly in all respects. No error messages, the volume control both displays correctly and works correctly.

I can only conclude that the errors are related to the Plex web app and its communication with PMS. It used to work fine until the last 2 PMS updates so, presumably, something has changed in PMS with affects the Plex web app. Please let me know what logs you need in order to address this error and how I can obtain them and send them to you. Thanks


since new Plex update same is happening to me. While casting audio files to Chromecast on Macbook pro I get the error “there was a problem selecting the stream” yet the file will play. I cant find any info on this issue.


I have the same issue since the latest updates (installed on a Freenas 10.3, Plex version is
I have also the same issue with Plex installed on my Windows 10 machine.
This error only occurs when I try to cast to my Raspberry (latest version of RasPlex
It works fine when I cast to my Chromecast.



At last someone else is hitting the same problems as me. I was beginning to think I was the only one and it must be all my particular hardware.


I just updated to the latest level (PMS and web app 3.20.5) hoping this had addressed the problem but it is exactly the same. Error message: problem selecting stream and the volume appears a muted and doesn’t slide.


I noticed that I have the issue only when I try to use IE or Chrome to command my Rasberry.
It’s working fine from the phone or from my tablet.
I also noticed that sometimes (not all the time), the subtitles seems to freeze for some few seconds (not diplaying the next text). And this happened since the latest updates…
My guess is that Rasplex will need some fix and upgrade.


Have you tried doing the same thing on a windows machine from the web app (IE, Chrome or Firefox) and from Plex Media Player? I think the problem is the Plex web app as I presume you are using the Android or iPhone app on your tablet and phone which is why they work.


I just updated again to latest level (Version of PMS and Version 3.20.5 of the web app) hoping it would resolve the error but it is exactly the same. The volume control still doesn’t work correctly and the error message “problem selecting the stream” still appears. Other than that it still seems to work fine.


Still same the problem here…
Are you directly viewing videos on your browser or (as I do) to control a remote app (such as Rasplex or a Chromecast) ?
I can see Rasplex is still with the same version (1.8)… perhaps something will be fixed with new versions…


I have tried with PMP and it works fine. I will probably keep using it.


I have the problem now with PMP since its latest update (today’s one)…


Same happening here. My plex server is on an ubuntu VM, my player is rasplex on raspberry pi and I control it through a webbrowser on my windows box (chrome on windows7 64bit)

Further to that, as soon as what I played is over, my browser refuses to talk to the plex web interface for about 5 minutes.
(the process is running on port 32400 and nothing is logged in plex server logs, so this might be a virtualbox networking issue)
Has been like this for the past 3 versions of the plex server. Hope a fix is coming is this is related to the webapp
as said above, if I can provide any details/logs just let me know.


I am glad that others are finally posting with the same problem. Hopefully that means it will get picked up and a fix released.


I just updated PMS to the latest version but that still has not solved the problem, it is exactly the same error message and volume control as before.


@tel19 said:
I just updated PMS to the latest version but that still has not solved the problem, it is exactly the same error message and volume control as before.

Same here with PMS


I have same error each time I am start to play new album to my google chromcast audio ! I see the message for about 1-2 secs, error disapearing and music starts to play.
Than I’m switching next track inside of album, no messages.
If I’m not casting to Chromcast everithing is OK, no messages.
After that I have tested old versions and found that the problem begins with version PMS 1.7.5.

(/uploads/default/original/3X/e/1/e15b67d39a8511b38fa2550680de8c990d60e8ca.png “”)


System: Windows 7 64x, PMS 1.5.5 and older versions works fine.


Sorry for mistake: 1.7.5 is fine, problem begins with version 1.8.4


Still not fixed on version