# Error reinstalling after database corruption

**URL:** <https://forums.plex.tv/t/error-reinstalling-after-database-corruption/932947>\
**Category:** Plex Media Server\
**Tags:** server-synology\
**Created:** [October 28, 2025, 12:27pm UTC](https://forums.plex.tv/t/error-reinstalling-after-database-corruption/932947 "2025-10-28T12:27:04Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Nigel-Bennett](https://avatars.discourse-cdn.com/v4/letter/n/7cd45c/32.png) [@Nigel-Bennett](https://forums.plex.tv/u/Nigel-Bennett)\
**Post date:** [October 28, 2025, 12:27pm UTC](https://forums.plex.tv/t/error-reinstalling-after-database-corruption/932947/1 "2025-10-28T12:27:04Z")

</div>

Server Version: any (Synology default ot latest from Plex)

DSM 7.2.2

Hi all. I’d appreciate some help. I’m a long-term user of Plex media server on DSM. Yesterday I got a corruption on the Plex database on one particular video library. I followed the suggested steps via SQLite but the intergrity check failed as it was unable to write to the database - I tried from an admin user and the plex user with the same result.

After much angst, I decided to reinstall the server. The first attempt (normal install) seemed to discover my corrupted database so added the corrupt library on install. I then went for a complete wipe install and first get a mult-language popup : “system internal user PlexMediaServer cannot write to the shared folder PlexMedia Server”. The server tries to run but won’t load.

I cannot see a /Volume1/PlexMediaServer folder or a /var/packages/PlexMediaServer folder on the NAS when using ssh.

DSM’s control panel (shared folders) however shows a PlexMediaServer folder and a Plex folder. If I click on edit for either I get a message that the volume where the share is located does not support ACL.

How do I recover this please?

Thanks for your help.

---

<div class="post-metadata">

**Author:** ![dbirch](https://avatars.discourse-cdn.com/v4/letter/d/f19dbf/32.png) [@dbirch](https://forums.plex.tv/u/dbirch)\
**Post date:** [October 28, 2025, 1:09pm UTC](https://forums.plex.tv/t/error-reinstalling-after-database-corruption/932947/2 "2025-10-28T13:09:37Z")

</div>

I would try using [GitHub - ChuckPa/DBRepair: Database repair utility for Plex Media Server databases](https://github.com/ChuckPa/PlexDBRepair) and see if that can fix your issue,

---

<div class="post-metadata">

**Author:** ![Nigel-Bennett](https://avatars.discourse-cdn.com/v4/letter/n/7cd45c/32.png) [@Nigel-Bennett](https://forums.plex.tv/u/Nigel-Bennett)\
**Post date:** [October 28, 2025, 1:12pm UTC](https://forums.plex.tv/t/error-reinstalling-after-database-corruption/932947/3 "2025-10-28T13:12:09Z")

</div>

Thanks I will look at this

---

<div class="post-metadata">

**Author:** ![Nigel-Bennett](https://avatars.discourse-cdn.com/v4/letter/n/7cd45c/32.png) [@Nigel-Bennett](https://forums.plex.tv/u/Nigel-Bennett)\
**Post date:** [October 28, 2025, 2:17pm UTC](https://forums.plex.tv/t/error-reinstalling-after-database-corruption/932947/4 "2025-10-28T14:17:09Z")

</div>

Guys, thanks for taking the time to view this. I appear to have fixed it with a bit of sideways thinking which I’m sharing.

Deleting the PlexMediaServer and Plex shared folders allow the server to run. However, when I add the libray that as corrupt, it adds a corrupt librray which as bizarre.

My brainwave was to completely delete the Plex server and do a full install but renaming the server at the first step. Then it all springs back into life. I’m left with a greyed out old server showing under “more” on the menu which I’m ignoring until I rebuild the libraries.

Perhaps some sort of Plex bug?

Thanks agan!

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [October 28, 2025, 3:54pm UTC](https://forums.plex.tv/t/error-reinstalling-after-database-corruption/932947/5 "2025-10-28T15:54:11Z")

</div>

[https://app.plex.tv/desktop/#!/settings/devices/pms](https://app.plex.tv/desktop/#!/settings/devices/pms)

look at the list of servers on your account.

delete the instance you just removed. (look at the timestamps)

( Plex.tv doesn’t know you deleted the server – so the apps don’t know. You have to manually remove ‘dead’ server instances )

---

<div class="post-metadata">

**Author:** ![Nigel-Bennett](https://avatars.discourse-cdn.com/v4/letter/n/7cd45c/32.png) [@Nigel-Bennett](https://forums.plex.tv/u/Nigel-Bennett)\
**Post date:** [October 28, 2025, 4:15pm UTC](https://forums.plex.tv/t/error-reinstalling-after-database-corruption/932947/6 "2025-10-28T16:15:27Z")

</div>

Thanks. That’s really helpful.

---

<div class="post-metadata">

**Author:** ![system](https://global.discourse-cdn.com/plex/original/3X/2/a/2acb9765406f63293d357b4ec509ec39aa28f2ad.png) [@system](https://forums.plex.tv/u/system)\
**Post date:** [January 26, 2026, 4:16pm UTC](https://forums.plex.tv/t/error-reinstalling-after-database-corruption/932947/7 "2026-01-26T16:16:04Z")

</div>

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.
