External Player Failure




I have Plex Media Server (PMS) on my Synology NAS DS214Play. Streaming everything from PMS to internal player of Plex for my android phone (Samsung S8+) is fine. However I could never stream movies to any external android player.

I tried playing externally on different android video players and here are the error messages:

External Player 1: MX Player:
Error Message: can't play this link

External Player 2: BS Player
Error Message: error opening file file.mkv

External Player 3: Samsung Android Video Player
Error Message: Your device has been disconnected from the network. Connect to a network and try again.

External Player 4: Musics and Video Studio Video Player
Error Message: The location https://192-168-1-16.f0555e353a514959b1 d4cad5e5dffd54.plex.direct:32400/library/parts/59133/1512281606/file.mkv?AutoAdjustQuality=O&hasMDE=1 &location=lan&X-Plex-Client-ldentif1er=324eccdc6697b5bb-com-plexapp-android&X-Plex-Supported-Commands=abort&X-Plex-Token=TOKENHERE cannot be played.

It looks like Plex Android App or PMS submit wrong link to the external player. From the error messages it looks like the file which is being played is named "file.mkv", but the real name of file is something else.

Setting of Plex Android Software:
Player>Device Support>H264 maximum level: 5.1 (Recommended)
Player>Device Support>Audio passthrough: Disabled
Player>Device Support>Optional Audio Support: None
Player>Other players> Use Android media player: Unchecked
Player>Other players> Use external player: Checked

I have installed Plex Android Software from Google Play and it is the latest version: (c21bd300)
Logs of PMS and Android are attached here.

Any comments?



From Your Logs:

Dec 05, 2017 16:58:47.897 [0xab911b40] WARN - SLOW QUERY: It took 2090.000000 ms to retrieve 70 items.
Dec 05, 2017 17:04:27.733 [0xab911b40] ERROR - [Transcoder] [mp4 @ 0xa7ccde0] Application provided duration: -16 / timestamp: 284616 is out of range for mov/mp4 format

The first line shows a very slow database query. At the very least you should:

  1. Optimise Database
  2. Empty Trash
  3. Clean Bundles

I am not sure what file or what device the second line refers to, but clearly the file is damaged/poorly encoded. The file needs to be re-encoded or replaced.

Dec 05, 2017 17:57:27.384 [0x88e6bb40] DEBUG - [Now] Device is Android (Galaxy S8+).
Dec 05, 2017 17:57:27.393 [0x88e6bb40] DEBUG - Statistics: (324eccdc6697b5bb-com-plexapp-android) Reporting active playback in state 3 of type 1 (scrobble: 0) for account 1
Dec 05, 2017 17:57:27.396 [0x88e6bb40] DEBUG - Streaming Resource: Terminated session 0x9b7b3914:324eccdc6697b5bb-com-plexapp-android with reason Client stopped playback.
Dec 05, 2017 17:57:27.396 [0x88e6bb40] DEBUG - Streaming Resource: Removing session 0x9b7b3914:324eccdc6697b5bb-com-plexapp-android
Dec 05, 2017 17:57:27.398 [0xb0fffb40] ERROR - Session 0x9b7b3914 terminated

The above errors show that the client (Samsung Galaxy S8) terminated playback. That may have been because you pressed stop or it may have been because the file was not suitable for playback on that device.

Dec 05, 2017 05:01:42.211 [0xb3efd780] ERROR - Exception analyzing media file '/volume1/Download/Inspector Rex 1994/Season 01/Kommissar Rex 1994/S01E04. The Old Lady Murder.avi' (Could not parse /volume1/Download/Inspector Rex 1994/Season 01/Kommissar Rex 1994/S01E04. The Old Lady Murder.avi (error=-2): No such file or directory)

Dec 05, 2017 04:51:59.767 [0xb3f44780] ERROR - Exception analyzing media file '/volume1/Download/Inspector Rex 1994/Season 01/Kommissar Rex 1994/S01E05. Dance on the Volcano.avi' (Could not parse /volume1/Download/Inspector Rex 1994/Season 01/Kommissar Rex 1994/S01E05. Dance on the Volcano.avi (error=-2): No such file or directory)

Clearly the file is missing. That could be caused by bad file permissions. See Q18 on the Synology FAQ’s page, link in my signature.

Also, you should not allow files to be downloaded directly into your Plex media folders. Download to a folder that is not part of your Plex media folders, then manually move those files into your Plex media folder.


Hi Andy,

Thanks for your feedback. Actually I am aware of some errors that you mentioned. Earlier, I was doing a maintenance on my server and majority of the issues in the log are irrelevant to this specific problem.

To make it easier to spot the issue, I have generated logs after I tried to reproduce the issue.

I reviewed the log file and I spotted the lines which are relevant to this issue:

Dec 05, 2017 19:52:17.698 [0xa0623b40] DEBUG - [Now] Device is Android (Galaxy S8+).
Dec 05, 2017 19:52:17.699 [0xa0623b40] DEBUG - [Now] Profile is Android
Dec 05, 2017 19:52:17.700 [0xa0623b40] DEBUG - [Now] Updated play state for /library/metadata/29972.
Dec 05, 2017 19:52:17.703 [0xa0623b40] DEBUG - Statistics: (324eccdc6697b5bb-com-plexapp-android) Reporting active playback in state 3 of type 1 (scrobble: 0) for account 1
Dec 05, 2017 19:52:17.703 [0xb0fffb40] DEBUG - Failed to stream media, client probably disconnected: 104 - Connection reset by peer
Dec 05, 2017 19:52:17.704 [0xb0fffb40] DEBUG - Completed: [] 200 GET /library/parts/59133/1512281606/file.mkv?autoAdjustQuality=0&hasMDE=1&location=lan&mediaBufferSize=74944 (12 live) TLS 3965ms 48168960 bytes (pipelined: 2)
Dec 05, 2017 19:52:17.705 [0xa0623b40] DEBUG - Streaming Resource: Terminated session 0x9cecb3d4:324eccdc6697b5bb-com-plexapp-android with reason Client stopped playback.
Dec 05, 2017 19:52:17.705 [0xa0623b40] DEBUG - Streaming Resource: Removing session 0x9cecb3d4:324eccdc6697b5bb-com-plexapp-android

Could you please give your comments?



Your log snippet just reinforces what I stated earlier. The 104 disconnect can be caused by a failed transcoding session which in turn may relate to a damaged/poorly encoded file or a file that simply cannot be played on your Android device.

Keep in mind that most external players can play mildly damaged files, but Plex is a little more ridgid and does not have as much error correction as some players, such as VLC etc.

If you are a Windows user, then see Q28 on the Synology FAQ’s page, link in my signature. That should help you to identify damaged files. Be aware, that it will also identify some non-critical errors within your files, but since you will be looking to repair your files, you may as well fix them all while you are at it.

When it comes time to re-encode the files, I recommend HandBrake (free for PC/Mac) or any similar software.

If using HandBrake, start with the Fast 1080p 30 preset and enable ‘Web Optimised’ and on the Video tab, enable ‘Fast Decode’. The rest of the settings will be fine, so leave them alone. Do check the Audio, Subtitle and Chapter tabs are to your liking though.


The issue I mentioned here does not have anything to do with Plex player. Inside plex everything works fine. While trying to switch streaming to External Player, then error message pops up in Android External Player. If Plex had any issue with the files, they should not have been played inside the Plex, too.

The files will play directly to all Android players without any issue (through local network). Problem arises when files are addressed to external player from within Plex App for Android.

The issue is consistent with all my videos. Among all videos, I could not find any single file to be played in any Android External Player. It is impossible that 100% of videos among 10,000+ videos are all damaged!


I will re-encode one of the files with HandBrake according to your recommendation and will update you about the result.


Your Android is not capable of playing multi-channel audio, without it being transcoded. External players do not transcode anything, unlike Plex which can do so, provided the server machine is powerful enough.

In order to redirect a file to an external player, it MUST be Direct Playable, which AC3 and DTS is not Direct Playable on the Android phone you have, it must be transcoded.

If you want to use an external player, you will have to make sure that your files use AAC audio, preferably in stereo and not multi-channel.

Correction, I am able to play AC3 and DTS audio using VLC on the Galaxy Tab A via Plex which is a bit puzzling.


I double checked right now. Exactly the same thing happens to AAC audio. Nothing plays externally.


OK, so something must be wrong on the S8. Either your player is not co-operating or the Plex app is not co-operating. I am using the same version of Plex app as you, and VLC 2.0.6 and DTS and AC3 are both playing back without issue.

Try VLC and see if that makes a difference.


I installed latest version of VLC from Google Play right now. The same error message. No external playback with any combination of Video/Audio (AAC/AC3/DTS).


I just updated VLC, still have no problem playing DTS or AC3 from my NAS or PC.

This page may be of interest to you: https://techcrunch.com/2017/06/14/plex-can-now-play-local-video-files-on-android-no-media-server-required/

Try it and see if you can play your files that way. Let me know if it works, if not, then you may have an issue with the Plex app.


Local files play fine within Plex. External play from Plex Android App arises the issue.
Is you NAS powerful enough to transcode DTS/AC3? Is it DS1813+? Does it have GPU?


In that case, you can only try re-installing Plex and hope for the best.

Yes I have the DS1813+ and it is able to transcode some audio, but generally not DTS. It does not have a GPU either.

All of my files are Direct Playable on my Raspberry Pi running RasPlex/OpenPHT so the NAS rarely needs to transcode anything. All of my files have been through my error finding script and have either been replaced or re-encoded to eliminate errors.

I still find the odd .avi file that has to be re-encoded for one reason or another, but generally speaking, all of my files are healthy.

I normally use the PC server when I’m using the Galaxy Tab A though, because it is capable of transcoding just about anything if need be.


I had same problem with OnePlus 5t running Android. External player cannout read url from Plex.

Did you fix your issue?


No I couldn’t solve it. This is a bug from Plex which doesn’t deliver
proper link to the external player in conditions I have explained in this



It’s 2018 and they still didn’t fix it