# Failed to start  Plex Media Server for Linux

**URL:** https://forums.plex.tv/t/failed-to-start-plex-media-server-for-linux/235838
**Category:** Apps & Creations
**Tags:** server-linux-arm
**Created:** [May 16, 2018, 5:23pm UTC](https://forums.plex.tv/t/failed-to-start-plex-media-server-for-linux/235838 "2018-05-16T17:23:37Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![master555](https://avatars.discourse-cdn.com/v4/letter/m/ea666f/32.png) [@master555](https://forums.plex.tv/u/master555)
#### Post date: [May 16, 2018, 5:23pm UTC](https://forums.plex.tv/t/failed-to-start-plex-media-server-for-linux/235838/1 "2018-05-16T17:23:37Z")

</div>

sudo systemctl status plexmediaserver

plexmediaserver.service - Plex Media Server for Linux  
Loaded: loaded (/lib/systemd/system/plexmediaserver.service; enabled; vendor  
preset: enabled)  
Active: inactive (dead) (Result: exit-code) since Wed 2018-05-16 14:13:19 BRT  
; 7min ago  
Process: 12577 ExecStart=/bin/sh -c LD\_LIBRARY\_PATH=/usr/lib/plexmediaserver "  
/usr/lib/plexmediaserver/Plex Media Server" (code=exited, status=126)  
Process: 12574 ExecStartPre=/bin/sh -c /usr/bin/test -d “{PLEX\_MEDIA\_SERVER\_A PPLICATION\_SUPPORT\_DIR}" || /bin/mkdir -p "{PLEX\_MEDIA\_SERVER\_APPLICATION\_SUPPO  
RT\_DIR}” (code=exited, status=0/SUCCESS)  
Main PID: 12577 (code=exited, status=126)

May 16 14:13:19 systemd[1]: plexmediaserver.service:  
Service hold-off time over, scheduling restart.  
May 16 14:13:19 systemd[1]: Stopped Plex Media Serve  
r for Linux.  
May 16 14:13:19 systemd[1]: plexmediaserver.  
service: Start request repeated too quickly.  
May 16 14:13:19 systemd[1]: Failed to start  
Plex Media Server for Linux.  
May 16 14:14:01 systemd[1]: plexmediaserver.  
service: Start request repeated too quickly.  
May 16 14:14:01 systemd[1]: Failed to start  
Plex Media Server for Linux.

---

<div class="post-metadata">

### Author: ![Menel](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/menel/32/21732_2.png) [@Menel](https://forums.plex.tv/u/Menel)
#### Post date: [May 16, 2018, 5:48pm UTC](https://forums.plex.tv/t/failed-to-start-plex-media-server-for-linux/235838/2 "2018-05-16T17:48:17Z")

</div>

You might need to provide people more information, hardware infomation, distribution version, etc etc. Is this a new installation? If not, what systems changes have occurred recently?

---

<div class="post-metadata">

### Author: ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)
#### Post date: [May 16, 2018, 5:49pm UTC](https://forums.plex.tv/t/failed-to-start-plex-media-server-for-linux/235838/3 "2018-05-16T17:49:09Z")

</div>

Would you please let me know a few more things? All that tells me is it’s not running.

1. OS and version
2. PMS version installed + 32 or 64 bit
3. `sudo journalctl -xe | grep -i plex` to see what the specific error reported in the system log is

---

<div class="post-metadata">

### Author: ![master555](https://avatars.discourse-cdn.com/v4/letter/m/ea666f/32.png) [@master555](https://forums.plex.tv/u/master555)
#### Post date: [May 16, 2018, 8:02pm UTC](https://forums.plex.tv/t/failed-to-start-plex-media-server-for-linux/235838/4 "2018-05-16T20:02:02Z")

</div>

Sorry guys, I got not edit the first topic.  
32bits  
ARM Cortex

Firstly I had a problem installing it.  
“package architecture (i386) does not match system (armhf)”

I was able to solve by executing the following command:  
sudo dpkg --add-architecture i386

After that it installed normally, but Plex is not starting.

Thanks for listening.

---

<div class="post-metadata">

### Author: ![master555](https://avatars.discourse-cdn.com/v4/letter/m/ea666f/32.png) [@master555](https://forums.plex.tv/u/master555)
#### Post date: [May 16, 2018, 8:05pm UTC](https://forums.plex.tv/t/failed-to-start-plex-media-server-for-linux/235838/5 "2018-05-16T20:05:56Z")

</div>

sudo journalctl -xe | grep -i plex  
May 16 16:50:35 ---------- systemd[1]: Starting Plex Media Server for Linux…  
– Subject: Unit plexmediaserver.service has begun start-up  
– Unit plexmediaserver.service has begun starting up.  
May 16 16:50:36 ---------- systemd[1]: Started Plex Media Server for Linux.  
– Subject: Unit plexmediaserver.service has finished start-up  
– Unit plexmediaserver.service has finished starting up.  
May 16 16:50:36 ---------- sh[1163]: /bin/sh: /usr/lib/plexmediaserver/Plex Media Server: cannot execute binary file: Exec format error  
May 16 16:50:36 ---------- systemd[1]: plexmediaserver.service: Main process exited, code=exited, status=126/n/a  
May 16 16:50:36 ---------- systemd[1]: plexmediaserver.service: Unit entered failed state.  
May 16 16:50:36 ---------- systemd[1]: plexmediaserver.service: Failed with result ‘exit-code’.  
May 16 16:50:41 ---------- systemd[1]: plexmediaserver.service: Service hold-off time over, scheduling restart.  
May 16 16:50:41 ---------- systemd[1]: Stopped Plex Media Server for Linux.  
– Subject: Unit plexmediaserver.service has finished shutting down  
– Unit plexmediaserver.service has finished shutting down.  
May 16 16:50:41 ---------- systemd[1]: Starting Plex Media Server for Linux…  
– Subject: Unit plexmediaserver.service has begun start-up  
– Unit plexmediaserver.service has begun starting up.  
May 16 16:50:41 ---------- systemd[1]: Started Plex Media Server for Linux.  
– Subject: Unit plexmediaserver.service has finished start-up  
– Unit plexmediaserver.service has finished starting up.  
May 16 16:50:41 ---------- sh[1268]: /bin/sh: /usr/lib/plexmediaserver/Plex Media Server: cannot execute binary file: Exec format error  
May 16 16:50:41 ---------- systemd[1]: plexmediaserver.service: Main process exited, code=exited, status=126/n/a  
May 16 16:50:41 ---------- systemd[1]: plexmediaserver.service: Unit entered failed state.  
May 16 16:50:41 ---------- systemd[1]: plexmediaserver.service: Failed with result ‘exit-code’.  
May 16 16:50:46 ---------- systemd[1]: plexmediaserver.service: Service hold-off time over, scheduling restart.  
May 16 16:50:46 ---------- systemd[1]: Stopped Plex Media Server for Linux.  
– Subject: Unit plexmediaserver.service has finished shutting down  
– Unit plexmediaserver.service has finished shutting down.  
May 16 16:50:46 ---------- systemd[1]: Starting Plex Media Server for Linux…  
– Subject: Unit plexmediaserver.service has begun start-up  
– Unit plexmediaserver.service has begun starting up.  
May 16 16:50:46 ---------- systemd[1]: Started Plex Media Server for Linux.  
– Subject: Unit plexmediaserver.service has finished start-up  
– Unit plexmediaserver.service has finished starting up.  
May 16 16:50:46 ---------- sh[1275]: /bin/sh: /usr/lib/plexmediaserver/Plex Media Server: cannot execute binary file: Exec format error  
May 16 16:50:46 ---------- systemd[1]: plexmediaserver.service: Main process exited, code=exited, status=126/n/a  
May 16 16:50:46 ---------- systemd[1]: plexmediaserver.service: Unit entered failed state.  
May 16 16:50:46 ---------- systemd[1]: plexmediaserver.service: Failed with result ‘exit-code’.  
May 16 16:50:51 ---------- systemd[1]: plexmediaserver.service: Service hold-off time over, scheduling restart.  
May 16 16:50:51 ---------- systemd[1]: Stopped Plex Media Server for Linux.  
– Subject: Unit plexmediaserver.service has finished shutting down  
– Unit plexmediaserver.service has finished shutting down.  
May 16 16:50:51 ---------- systemd[1]: plexmediaserver.service: Start request repeated too quickly.  
May 16 16:50:51 ---------- systemd[1]: Failed to start Plex Media Server for Linux.  
– Subject: Unit plexmediaserver.service has failed  
– Unit plexmediaserver.service has failed.  
May 16 16:56:21 ---------- sudo[1390]: root : TTY=pts/0 ; PWD=/root ; USER=root ; COMMAND=/bin/systemctl status plexmediaserver  
May 16 16:56:26 ---------- sudo[1401]: root : TTY=pts/0 ; PWD=/root ; USER=root ; COMMAND=/bin/systemctl start plexmediaserver  
May 16 16:56:26 ---------- systemd[1]: Starting Plex Media Server for Linux…  
– Subject: Unit plexmediaserver.service has begun start-up  
– Unit plexmediaserver.service has begun starting up.  
May 16 16:56:26 ---------- systemd[1]: Started Plex Media Server for Linux.  
– Subject: Unit plexmediaserver.service has finished start-up  
– Unit plexmediaserver.service has finished starting up.  
May 16 16:56:26 ---------- sh[1411]: /bin/sh: /usr/lib/plexmediaserver/Plex Media Server: cannot execute binary file: Exec format error  
May 16 16:56:26 ---------- systemd[1]: plexmediaserver.service: Main process exited, code=exited, status=126/n/a  
May 16 16:56:26 ---------- systemd[1]: plexmediaserver.service: Unit entered failed state.  
May 16 16:56:26 ---------- systemd[1]: plexmediaserver.service: Failed with result ‘exit-code’.  
May 16 16:56:29 ---------- sudo[1419]: root : TTY=pts/0 ; PWD=/root ; USER=root ; COMMAND=/bin/systemctl status plexmediaserver  
May 16 16:56:31 ---------- systemd[1]: plexmediaserver.service: Service hold-off time over, scheduling restart.  
May 16 16:56:31 ---------- systemd[1]: Stopped Plex Media Server for Linux.  
– Subject: Unit plexmediaserver.service has finished shutting down  
– Unit plexmediaserver.service has finished shutting down.  
May 16 16:56:31 ---------- systemd[1]: Starting Plex Media Server for Linux…  
– Subject: Unit plexmediaserver.service has begun start-up  
– Unit plexmediaserver.service has begun starting up.  
May 16 16:56:31 ---------- systemd[1]: Started Plex Media Server for Linux.  
– Subject: Unit plexmediaserver.service has finished start-up  
– Unit plexmediaserver.service has finished starting up.  
May 16 16:56:31 ---------- sh[1432]: /bin/sh: /usr/lib/plexmediaserver/Plex Media Server: cannot execute binary file: Exec format error  
May 16 16:56:31 ---------- systemd[1]: plexmediaserver.service: Main process exited, code=exited, status=126/n/a  
May 16 16:56:31 ---------- systemd[1]: plexmediaserver.service: Unit entered failed state.  
May 16 16:56:31 ---------- systemd[1]: plexmediaserver.service: Failed with result ‘exit-code’.  
May 16 16:56:36 ---------- systemd[1]: plexmediaserver.service: Service hold-off time over, scheduling restart.  
May 16 16:56:36 ---------- systemd[1]: Stopped Plex Media Server for Linux.  
– Subject: Unit plexmediaserver.service has finished shutting down  
– Unit plexmediaserver.service has finished shutting down.  
May 16 16:56:36 ---------- systemd[1]: Starting Plex Media Server for Linux…  
– Subject: Unit plexmediaserver.service has begun start-up  
– Unit plexmediaserver.service has begun starting up.  
May 16 16:56:36 ---------- systemd[1]: Started Plex Media Server for Linux.  
– Subject: Unit plexmediaserver.service has finished start-up  
– Unit plexmediaserver.service has finished starting up.  
May 16 16:56:36 ---------- sh[1439]: /bin/sh: /usr/lib/plexmediaserver/Plex Media Server: cannot execute binary file: Exec format error  
May 16 16:56:36 ---------- systemd[1]: plexmediaserver.service: Main process exited, code=exited, status=126/n/a  
May 16 16:56:36 ---------- systemd[1]: plexmediaserver.service: Unit entered failed state.  
May 16 16:56:36 ---------- systemd[1]: plexmediaserver.service: Failed with result ‘exit-code’.  
May 16 16:56:42 ---------- systemd[1]: plexmediaserver.service: Service hold-off time over, scheduling restart.  
May 16 16:56:42 ---------- systemd[1]: Stopped Plex Media Server for Linux.  
– Subject: Unit plexmediaserver.service has finished shutting down  
– Unit plexmediaserver.service has finished shutting down.  
May 16 16:56:42 ---------- systemd[1]: plexmediaserver.service: Start request repeated too quickly.  
May 16 16:56:42 ---------- systemd[1]: Failed to start Plex Media Server for Linux.  
– Subject: Unit plexmediaserver.service has failed  
– Unit plexmediaserver.service has failed.

---

<div class="post-metadata">

### Author: ![drmagoo](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/drmagoo/32/13982_2.png) [@drmagoo](https://forums.plex.tv/u/drmagoo)
#### Post date: [May 16, 2018, 8:15pm UTC](https://forums.plex.tv/t/failed-to-start-plex-media-server-for-linux/235838/6 "2018-05-16T20:15:51Z")

</div>

> @cantalupo555 said:  
> Sorry guys, I got not edit the first topic.  
> 32bits  
> ARM Cortex
> 
> Firstly I had a problem installing it.  
> “package architecture (i386) does not match system (armhf)”
> 
> I was able to solve by executing the following command:  
> sudo dpkg --add-architecture i386

Ähem. That’s an interesting approach 😄 armhf and i368 are not compatible. Please try my approach 😃 And definitively remove the i386 architecture and purge your current plex package.

[https://forums.plex.tv/discussion/309553/plex-media-server-for-armhf-and-arm64-using-debian-or-ubuntu](https://forums.plex.tv/discussion/309553/plex-media-server-for-armhf-and-arm64-using-debian-or-ubuntu)

---

<div class="post-metadata">

### Author: ![master555](https://avatars.discourse-cdn.com/v4/letter/m/ea666f/32.png) [@master555](https://forums.plex.tv/u/master555)
#### Post date: [May 16, 2018, 8:50pm UTC](https://forums.plex.tv/t/failed-to-start-plex-media-server-for-linux/235838/7 "2018-05-16T20:50:49Z")

</div>

> @uglymagoo said:
> 
> > @cantalupo555 said:  
> > Sorry guys, I got not edit the first topic.  
> > 32bits  
> > ARM Cortex
> > 
> > Firstly I had a problem installing it.  
> > “package architecture (i386) does not match system (armhf)”
> > 
> > I was able to solve by executing the following command:  
> > sudo dpkg --add-architecture i386
> 
> Ähem. That’s an interesting approach 😄 armhf and i368 are not compatible. Please try my approach 😃 And definitively remove the i386 architecture and purge your current plex package.
> 
> [https://forums.plex.tv/discussion/309553/plex-media-server-for-armhf-and-arm64-using-debian-or-ubuntu](https://forums.plex.tv/discussion/309553/plex-media-server-for-armhf-and-arm64-using-debian-or-ubuntu)

Thank you uglymagoo and ChuckPA!  
 ![](https://sea1.discourse-cdn.com/plex/uploads/default/original/3X/a/a/aa40b288d296ca84c24f4bc04cb026810e6b40b3.png)

---

<div class="post-metadata">

### Author: ![system](https://global.discourse-cdn.com/plex/original/3X/2/a/2acb9765406f63293d357b4ec509ec39aa28f2ad.png) [@system](https://forums.plex.tv/u/system)
#### Post date: [January 8, 2020, 7:43pm UTC](https://forums.plex.tv/t/failed-to-start-plex-media-server-for-linux/235838/8 "2020-01-08T19:43:54Z")

</div>


