Fails to load items of playlist

plex-web

#1

Hi everyone.

Finally I started to create some playlists, but I ran into some trouble, hope you can help.

I created the Premium Music library.

I can add any number of tracks to a playlist, but when I go into the playlist, Plex/Web says: "Failed to load items for this playlist".

But if I click the play button, the playist plays.

The playlists suddenly are "not available", while the rest of the content is (movies and tv shows are still available).

Playlists show up, but won't play in PHT for Mac 1.4.1.469-47a90f01. Just "Please wait" and then nothing.

 

I'm running the Plex Server Version 0.9.12.3 on a Synology NAS DS413j and Plex/Web on Mac (I've tried Safari, Chrome and Opera) version 2.4.9.

Can I get you anything else to help me?

Thanks


#2

Same here - anyone can help?

Plex Server Version 0.9.12.4 on Debian Linux, Plex Web Version 2.4.9 on Mac/Safari.

Regards


#3

@igno2k said:
Same here - anyone can help?

Plex Server Version 0.9.12.4 on Debian Linux, Plex Web Version 2.4.9 on Mac/Safari.

Regards

I would suggest you try and get a Debug Plex Media Server.log for this to see what happens when the playlist is created and when it is requested. Follow advice in Reporting Issues with Plex Media Server to ensure a fresh log file is created

If this is happening with Plex Home Theater please also add a debug Plex Home Theater.log.

Screen capture should also be obtained showing the time when the error was returned to make it easier to find the related log file entries


#4

Thank you - I have found the issue. The sqlite database was corrupted.

I could repair the database following this guide:
https://support.plex.tv/hc/en-us/articles/201100678-Repair-a-Corrupt-Database

Now playlists work like a charm again :)

Regards


#5

I am experiencing this issue. I repaired the sqlite database, but the issue is still there. It seems to only happen on playlists with more than 50 items.

Thanks for your help.


#6

@wdugas said:
I am experiencing this issue. I repaired the sqlite database, but the issue is still there. It seems to only happen on playlists with more than 50 items.

Thanks for your help.

see my post above yours concerning diagnostics and server log files to be uploaded when the error is shown. please include full uncropped screenshot as well


#7

I don't really want to post my server logs to a public forum. Is there any other way to send them?


#8

@wdugas said:
I don’t really want to post my server logs to a public forum. Is there any other way to send them?

Hi Plex Team,

I looked through the logs and didn’t see any obvious entries related to this. That is, I reproduced the issue and no new log entries were created.

Steps to reproduce:

Plex Media Server version: 1.2.7.2987
Plex Web version: 2.10.10

  1. Create a playlist with 116 items
  2. Try to view playlist and you receive the error “Failed to load items for this playlist.” (See screenshots attached

I created a test playlist with 100 items and it works fine. Somewhere between 101 and 116 items the failure occurs. All playlists I have with more than 100 items have this error. I am able to play the playlist, just not view the items.

Thanks for your help!


#9

My Plex Media Server is running on a Mac Mini:

Nov 29, 2016 11:02:28.182 [0x700000429000] INFO - Plex Media Server v1.2.7.2987-1bef33a - Apple Mac - build: darwin-x86_64 macosx - GMT 01:00
Nov 29, 2016 11:02:28.182 [0x700000429000] INFO - MacOSX version: 10.11.6, language: en
Nov 29, 2016 11:02:28.182 [0x700000429000] INFO - Processor Intel(R) Core(TM) i7-3720QM CPU @ 2.60GHz
Nov 29, 2016 11:02:28.182 [0x700000429000] INFO - /Applications/Plex Media Server.app/Contents/MacOS/Plex Media Server


#10

It could be database fragmentation and responses taking too long - without the logs I cannot help you

But on the chance It is that, try to Optimize the Database
See Library Actions : Optimize https://support.plex.tv/hc/en-us/articles/200392106-Library-Actions


#11

Optimize Database worked!

Thanks for your help!


#12

Same issue, larger playlists (over 100) not displaying content. Optimized the database and that took care of it, thanks for the help!


#13

Is it too much to ask for this to have been fixed by now? My bad but I am not PC illiterate enough to play around inside registries or with .exe files or any of the other suggestions above. I tried optimize which is the only suggestion above which I could understand as it is a function within the platform itself but this did not fix the problem. How did it work for one person above and not for mine? By no means do I consider myself a technophobe but should not understanding the above technical info/sqlite etc mean I should not be allowed to use a platform such as Plex? I just want to be able to list all my music by tracks or view my playlists. I am longing for this to be fixed or given a simple solution.


#14

@biomoebious said:
Is it too much to ask for this to have been fixed by now? My bad but I am not PC illiterate enough to play around inside registries or with .exe files or any of the other suggestions above. I tried optimize which is the only suggestion above which I could understand as it is a function within the platform itself but this did not fix the problem. How did it work for one person above and not for mine? By no means do I consider myself a technophobe but should not understanding the above technical info/sqlite etc mean I should not be allowed to use a platform such as Plex? I just want to be able to list all my music by tracks or view my playlists. I am longing for this to be fixed or given a simple solution.

Hopefully you are able to follow the steps here

https://support.plex.tv/hc/en-us/articles/201643703-Reporting-issues-with-Plex-Media-Server
This is for enabling debug logging and restarting the server to get log files created afresh

Reproduce the problem
Get a screenshot of the error showing the time and url used and save the screenshot jpg file
You can google search how to get a screenshot capture for your platform

Then download the logs zip
see
https://support.plex.tv/hc/en-us/articles/200250417-Plex-Media-Server-Log-Files

Then attach the evidence here in a post
see
https://support.plex.tv/hc/en-us/articles/202756326-How-do-I-attach-files-in-the-forums-