False "Not available outside your network" warning


#1

I'm wondering if anyone else is having the same experience as I am. For the longest time my server worked perfectly, and then every time there was an update I had trouble with Remote Access failing. I'd redo the settings, it would come up green for a half-second and then right back into the red "Not available outside your network" error message. I tried to tweak it in every way I read in the forums but it seemed nothing I could do would fix it.

The funny thing is, though, my Plex server actually IS available outside my network. It just took me a long time to stumble across that fact by accident. So now every time there's an update I install it, and every time my Remote Access goes red. But now I don't bother worrying about it.

As I sit here my Server is showing red/no Remote Access, but I was listening to music on my iPhone outside the house earlier and my Status is showing my friend is watching a TV show from my Plex server across town at his place.

Surely I can't be the only one experiencing this. Any ideas what's going on?


#2

I did have that same exact issue happen to me early 2017. I cannot recall which update it was but it was your issue exactly.

**skip to the next asterisk line to skip story**

So around the same time I was playing the game “The Crew” on Xbox One. On the main screeen before you press start it was telling me that I had a strict Nat type and that was causing certain players in the games I was in to become invisible! (Crazy in know.. hopefully other people experienced this too so I don’t seem like a crazy person) And those 2 issues combined made me get to action to figure it out.

I had a Linksys e6400 smart router at the time and it had port forwarding options so I port forwarded my Xbox one and it fixed the “STRICT” NAT type issue and now said “OPEN” immediately after Xbox One reboot. but my Plex STOPPED working outside the network entirely. I didn’t think it could be related.

Then I looked up options to port forward plex and did it and it still didn’t work outside the network. Then I turned off my Xbox One port forward and left plex port forward and remote access was restored (with green icon in plex remote settings). But I played a lot of “The Crew” so I couldn’t deal anymore if I knew it could be fixed.

So then I tried an old Netgear wireless-N router with t-base 100 ports then I port forwarded plex and Xbox One and it worked flawlessly.

**end of story**

The problem was my router.

I now use a old slim pc box with router software and a x2 gigabit lan cards. Works so good now. Much happy.