FEATURE REQUEST: Custom Library Icons

plex-classic-for-roku

#14

Don't thank me, thank the person who wrote that great guide.  To find pictures just do a Google search.  I would suggest keeping the images around 300 x 300, as that seems to be what the default icons are sized at.  Here is what I used for James Bond and Disney.

Thank you for connecting people; glad the guide is helpful :)


#15

I was able to view the xml using (http://localhost:32400/library/sections) which had the path to the icon, but I couldn't find where the xml file was to edit it.  However, I was able to accomplish this by using the below guide and sql editor.

http://raspberrypihtpc.wordpress.com/how-to/how-to-plex-media-server-change-the-section-icons/

http://sourceforge.net/projects/sqlitebrowser/

This was surprisingly easy. My new icons are looking nice. Thanks for posting the links and thanks to the author who wrote it.


#16

I came across some nice looking icons doing a web search. Gonna give this a try and see how they work out. :)


#17

I came across some nice looking icons doing a web search. Gonna give this a try and see how they work out. :)

Sharing is caring


#18

Wow, that was pretty easy to do. Tedious, but pretty easy. And in my opinion, looks a lot better now. :)

Thanks for the instructions on how to do it everyone. They were easy to follow. :)

The Icon Pack I used can be found by following the url link below. The pack I used was labeled as "Xenzer's MediaBrowser Icons" (second Icon Pack listed on the page). I didn't have to do anything to them other than load them up to my photobucket account, and then link to the one's I wanted to use. Very simple, and they look pretty cool. :)

http://community.mediabrowser.tv/permalinks/1436/xzener-s-fanart-collection

Thanks again, and have fun!


#19

Wow, that was pretty easy to do. Tedious, but pretty easy. And in my opinion, looks a lot better now. :)

Thanks for the instructions on how to do it everyone. They were easy to follow. :)

The Icon Pack I used can be found by following the url link below. The pack I used was labeled as "Xenzer's MediaBrowser Icons" (second Icon Pack listed on the page). I didn't have to do anything to them other than load them up to my photobucket account, and then link to the one's I wanted to use. Very simple, and they look pretty cool. :)

http://community.mediabrowser.tv/permalinks/1436/xzener-s-fanart-collection

Thanks again, and have fun!

Those are the ones I ended up using - wish they had a transparent background though!


#20

Those are the ones I ended up using - wish they had a transparent background though!

That's strange? The pack I downloaded were all .png's with a  transparent background. I'm sure of this because I opened a few up in photoshop and could see they had transparent backgrounds before I ever used them. I also used the included .psd template and created a new one that I needed myself, and the .psd is designed with a transparent background as well. I'm actually about to create a few more that I need in a little while. The background looks great on my Roku's.


#21

I'm running into a small problem with this. I redesigned a few of the icons I originally setup the other day. When I go to change them, for some reason it's not picking up the new icon, even though it has an entirely different name. I even tried deleting the image from my photobucket account, and keeps showing the old image I setup a couple of days ago. I'm guessing that the Plex Server is caching this somewhere after first read. Does anyone know where this is so I can go in and delete the one's I updated, and force a new download?


#22

I'm running into a small problem with this. I redesigned a few of the icons I originally setup the other day. When I go to change them, for some reason it's not picking up the new icon, even though it has an entirely different name. I even tried deleting the image from my photobucket account, and keeps showing the old image I setup a couple of days ago. I'm guessing that the Plex Server is caching this somewhere after first read. Does anyone know where this is so I can go in and delete the one's I updated, and force a new download?

Have you tried a library scan from the main plex/web page? That worked for me. Plex just needed to refresh the library.


#23

I'm running into a small problem with this. I redesigned a few of the icons I originally setup the other day. When I go to change them, for some reason it's not picking up the new icon, even though it has an entirely different name. I even tried deleting the image from my photobucket account, and keeps showing the old image I setup a couple of days ago. I'm guessing that the Plex Server is caching this somewhere after first read. Does anyone know where this is so I can go in and delete the one's I updated, and force a new download?

Along with the above advice, make sure when you are changing the database that PMS isn't running.


#24

I assume there's no way to change the Genre or Collection icons?


#25

Have you tried a library scan from the main plex/web page? That worked for me. Plex just needed to refresh the library.

Actually, I did not try that. I was able to fix the issue by going through all the cached transcoded images, and deleting the one's I wanted to replace. Which was a very lengthy process, but did resolve the problem.

I do have a few more icons that I assigned the other night, that I now want to replace with custom ones I am creating myself, so I am going to run into this problem again in the near future. When I do, I'll try as you suggest and see if that works. Thanks for mentioning the idea.


#26

Do I really have to install Firefox to change the Library icons using SQLite Manager? I currently use the Chrome browser.


#27

Do I really have to install Firefox to change the Library icons using SQLite Manager? I currently use the Chrome browser.

Use the program I linked to on page 1.


#28

Do I really have to install Firefox to change the Library icons using SQLite Manager? I currently use the Chrome browser.



No, any SQLite editor will work, the reason it's mentioned so much is mainly that Firefox is cross-platform and ubiquitous.


#29

I am having trouble entering the url address to the "user thumb url" in the Browse Data section of SQLite Database Browser. I can see all Library sections but get a window that pops open and closes when I double click in my attempt to enter the url for a specific section. Any help is appreciated.


#30

I am having trouble entering the url address to the "user thumb url" in the Browse Data section of SQLite Database Browser. I can see all Library sections but get a window that pops open and closes when I double click in my attempt to enter the url for a specific section. Any help is appreciated.

Double click on the blank space under "user thumb url" for the section you want to customize.  A blank window pops up, enter the url address there.  Click "apply changes", and then close the window.  Then save the database and exit.


#31

That is just it. I double click the blue highlighted "user thumb url" for a section and the window pops up, then quickly disappears. 


#32



That is just it. I double click the blue highlighted "user thumb url" for a section and the window pops up, then quick y disappears.



have you turned off plex?


#33

Yes. I went to system tray and exited Plex there. I can get into the Library section in SQLite in the Browser Data area. Every time I double click the "user thumb url" for any section, the window pops up then quickly disappears.