[Fedora 25] cannot connect to server

server-linux

#1

Linux Fedora 25

Plex pass: yes

PMS: plexmediaserver-1.13.2.5154-fd05be322.x86_64.rpm

Migrating server from Mac mini to headless HP rack server running Fedora 25. Access to server is via SSH.

Mac mini had been running fine. Signed out, shut down, migrated database to Linux but fails to connect from laptop on local subnet using 10.0.1.xxx:32400/web/index

Turned on verbose logging but no obvious explanatory messages that I were obvious to me. Logs included.

cat Preferences.xml
<?xml version="1.0" encoding="utf-8"?>

systemctl status plexmediaserver
● plexmediaserver.service - Plex Media Server for Linux
Loaded: loaded (/usr/lib/systemd/system/plexmediaserver.service; enabled; vendor preset: disabled)
Active: active (running) since Sun 2018-06-10 15:31:25 EDT; 28min ago
Process: 22572 ExecStartPre=/bin/sh -c /usr/bin/test -d "${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR}" || /bin/mkdir -p "${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR}" (code=exited, status=0/SUCCESS)
Main PID: 22575 (Plex Media Serv)
Tasks: 69 (limit: 4915)
CGroup: /system.slice/plexmediaserver.service
├─22575 /usr/lib/plexmediaserver/Plex Media Server
├─22589 Plex Plug-in [com.plexapp.system] /usr/lib/plexmediaserver/Resources/Plug-ins-fd05be322/Framework.bundle/Contents/Resources/Versions/2/Python/bootstrap.py --server-version 1.13.2.5154-fd05b
├─22637 /usr/lib/plexmediaserver/Plex DLNA Server
├─22638 /usr/lib/plexmediaserver/Plex Tuner Service /usr/lib/plexmediaserver/Resources/Tuner/Private /usr/lib/plexmediaserver/Resources/Tuner/Shared 1.13.2.5154-fd05be322 32600 /waitmutex
└─22683 Plex Plug-in [com.plexapp.agents.imdb] /usr/lib/plexmediaserver/Resources/Plug-ins-fd05be322/Framework.bundle/Contents/Resources/Versions/2/Python/bootstrap.py --server-version 1.13.2.5154-

Jun 10 15:31:25 jjdmdsrv systemd[1]: Starting Plex Media Server for Linux...
Jun 10 15:31:25 jjdmdsrv systemd[1]: Started Plex Media Server for Linux.

netstat -l -p -e -e --numeric-ports | head
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State User Inode PID/Program name
tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN root 20788 1/systemd
tcp 0 0 0.0.0.0:32400 0.0.0.0:* LISTEN plex 10549029 22575/Plex Media Se
tcp 0 0 localhost.localdo:32401 0.0.0.0:* LISTEN plex 10549030 22575/Plex Media Se
tcp 0 0 0.0.0.0:32469 0.0.0.0:* LISTEN plex 10551729 22637/Plex DLNA Ser
tcp 0 0 jjdmdsrv:53 0.0.0.0:* LISTEN root 15186 1488/dnsmasq
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN root 17759 988/sshd
tcp 0 0 localhost.localdoma:631 0.0.0.0:* LISTEN root 71135 1090/cupsd
tcp 0 0 localhost.localdo:32600 0.0.0.0:* LISTEN plex 10519046 22638/Plex Tuner Se

pwd

/var/lib/plexmediaserver/Library/Application Support/Plex Media Server
[root@jjdmdsrv Plex Media Server]# ls -l
total 176
drwxr-xr-x. 4 plex plex 4096 Jun 10 15:31 Cache
drwxr-xr-x. 4 plex plex 4096 Jun 9 11:58 Codecs
drwxr-xr-x. 24 plex plex 4096 Jun 9 11:58 'Crash Reports'
drwxr-xr-x. 2 plex plex 4096 May 10 02:09 Diagnostics
-rw-r--r--. 1 root root 3853 Jun 10 16:22 jjd.note
drwxr-xr-x. 3 plex plex 4096 Jun 10 16:22 Logs
-rw-r--r--. 1 root root 36725 Jun 10 16:23 log.tar.gz
drwxr-xr-x. 3 plex plex 4096 Jun 1 08:15 Media
drwxr-xr-x. 4 plex plex 4096 Jun 1 08:11 Metadata
-rw-r--r--. 1 plex plex 5 Jun 10 15:31 plexmediaserver.pid
drwxr-xr-x. 10 plex plex 4096 Jun 9 11:59 Plug-ins
drwxr-xr-x. 7 plex plex 4096 Jan 21 2015 'Plug-in Support'
-rw-------. 1 plex plex 624 Jun 10 15:30 Preferences.xml
drwxr-xr-x. 2 plex plex 4096 Jan 21 2015 Scanners
drwxr-xr-x. 3 plex plex 4096 Jun 1 08:11 Thumbnails
-rw-r--r--. 1 plex plex 81247 May 9 17:08 update-log.txt
drwxr-xr-x. 51 plex plex 4096 May 9 17:07 Updates


Media is on network attached storage (same location as when on mac mini).
The overall db migration may need work/tweaking but I would think I that I should be able to connect as a starting point.

Attached log files (not large).


#2

Logs look good.
Subnet is compliant.

Did you expect the web app, which previously knew it to be at the old IP to find it at the new IP automatically? Changing OS isn’t as slam dunk as we’re used to with Linux distro to distro moves.
It will find it after that first connection and update to Plex.tv (which your logs don’t show as happening).

Go to the Fedora system, by IP or directly on the http://127.0.0.1:32400/web (best way) and say “Hello” in Settings - Server - General.
Since it’s headless, do the SSH tunnel technique if it gets stubborn:

ssh -L 8888:127.0.0.1:32400 ip.addr.of.fedora

Sign that in and let it sit

On the same host the SSH is coming from, open http://127.0.0.1:8888/web

Now you’re on a SSH tunnel as if on the loopback adapter to the graphics head


#3

Thanks for the response @ChuckPA.

You wrote: Did you expect the web app, which previously knew it to be at the old IP to find it at the new IP automatically? Changing OS isn’t as slam dunk as we’re used to with Linux distro to distro moves.

Best case yes, but I quickly realized that wasn’t going to happen. I specified the local fedora IP address directly on my Mac laptop: 10.0.1.xxx:32400/web/index but to no avail.

I’ll try your other recommendations tomorrow and let you know how it goes.


#4

@ChuckPA , I tried the ssh -L 8888:127.0.0.1:32400 10.0.1.xx from my laptop and logged in without problem. However, from Safari on my laptop, http://127.0.0.1:32400/web still failed with;

Safari can’t open the page “127.0.0.1:8888/web” because Safari can’t connect to the server “127.0.01”.

When I try the fedora ip address directly as in http://10.0.1.xx:32400/web I get;

Safari can’t open the page “10.0.1.xx:32400/web” because the server where this page is located is not responding.

Is it possible that it hasn’t finished initializing in some way?


#5

Is PMS running?

sudo systemctl status plexmediaserver

If not running, start it

sudo systemctl start plexmediaserver
sudo systemctl enable plexmediaserver    # this enables autostart on reboot

If it should be running but isn’t, let’s find out what the system journal has to say about the problem. Be prepared to scroll through output looking for some exotic and silly error (like “permission denied”). Let me know what you find.

sudo journalctl -xe | grep -i plex

#6

systemctl shows it is started
last few journalctl entries show that it was started the other day:

Jun 10 15:31:25 jjdmdsrv systemd[1]: Started Plex Media Server for Linux.
– Subject: Unit plexmediaserver.service has finished start-up
– Unit plexmediaserver.service has finished starting up.
Jun 10 15:31:25 jjdmdsrv audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg=‘unit=plexmediaserver comm=“systemd” exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success’


#7

then it should be as simple as:

  1. ssh -L 8888:127.0.0.1:32400 ip.addr.of.server
  2. http://127.0.0.1:8888/web

I am wondering if, because it's been unclaimed so long, it's locked itself up to self-protect (it will do this)

In the shell:

sudo sh
systemctl stop plexmediaserver
rm -f "/var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Preferences.xml"
systemctl start plexmediaserver

Wait about 10 seconds for it to start back up
Now attempt to connect in the browser.

If you still cannot connect, you have a firewall or something blocking


#8

tried that, no joy. firewalld is not running. Uploaded fresh log.tar.gz in case that may be helpful


#9

Use a different browser. Safari is no joy. Go FireFox.

PMS is running just fine and waiting for someone to claim it


#10

Firefox made no difference. I’m beginning to think i have a networking problem.
On the PMS/Fedora box I installed nc (netcat) and and shutdown plex.

[root@jjdmdsrv Plex Media Server]# nc -4 -vv -l 32400
Ncat: Version 7.40 ( https://nmap.org/ncat )
Ncat: Listening on 0.0.0.0:32400
^C

in the above case, no sign of a connection being made and firefox times out

[root@jjdmdsrv Plex Media Server]# nc -4 -vv -l 80
Ncat: Version 7.40 ( https://nmap.org/ncat )
Ncat: Listening on 0.0.0.0:80
Ncat: Connection from 10.0.1.128.
Ncat: Connection from 10.0.1.128:53002.
GET / HTTP/1.1
Host: 10.0.1.87
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:60.0) Gecko/20100101 Firefox/60.0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,/;q=0.8
Accept-Language: en-US,en;q=0.5
Accept-Encoding: gzip, deflate
DNT: 1
Connection: keep-alive
Upgrade-Insecure-Requests: 1

In this case i see the connection being made and firefox says waiting for 10.0.1.xx

Networking is not my strong point. I did change the network config file so that the ipv4 address was static, not dhcp.

Firewalld is disabled…I’m wondering if there is some global option which, by default, disallows non-well known ports from connecting??

[root@jjdmdsrv Plex Media Server]# systemctl status firewalld
● firewalld.service - firewalld - dynamic firewall daemon
Loaded: loaded (/usr/lib/systemd/system/firewalld.service; disabled; vendor preset: enabled)
Active: inactive (dead)
Docs: man:firewalld(1)


#11

Your networking is ok if you can SSH (IPv4) to the box.
The problem is within your MAC and the SSH tunnel within ssh


#12

@ChuckPA, success! I decided to try a different tact. I installed the KDE desktop on the fedora/hp server, attached a keyboard/mouse/monitor and brought up firefox and connected via the actual loopback device, claimed the server and now all seems to be working. Need to confirm remote access works but suspect it will. Moving the database from Apple to Linux also seems to have worked without any issues. Thanks for all the help.