Fire TV Stick no longer plays 5.1 audio in Plex since last update

android-tv
fire-tv

#1

The plex app updated itself to 3.8.0 and no titles which used to play in 5.1 DTS or AAC downmix to 2.0. The fire stick is set to Dolby Digital Plus automatic and plex is set to Dolby Digital as well.


#2

Same problem here, I wish someone would come up with a fix


#3

Same here.
Work around is to turn off DD support in the client which forces an audio transcode to AAC. By default that will be 2 channel, but if you edit the android.xml file in your plex server (location varies depending on platform but it will be in the Profiles directory where you PMS is installed), and change the AAC at the end that says to use 2 channels to 6 - simply change the 2 to 6. Then you will get 6 channel audio. This is not ideal.

Question for you both : what version of Fire TV Stick are you on? I have the gen 2 version, and if I have Dolby Digital turned on, my audio keeps skipping - momentary pauses before moving on. This has been reported as an issue for the Fire TV, but I don’t know if this is a broader issue that also affects the Fire TV Stick Gen 2.

I had a Gen 1 Stick, and the DD audio issue didn’t affect that.


#4

I have both the generation 2 stick and box. Appreciate the work around, but wish they’d just fix it. All was fine a few weeks back !!


#5

Indeed. I’m not happy with the work around either.
My aim is to have a library of films, direct ripped from the DVDs (I have the disk space), and have no transcoding at all, with audio using DD pass through to my AVR.

On the Gen 1 Stick it worked, but that stick wasn’t powerful enough.

Plex say it Amazon’s fault, so I think we have to wait until they fix it.


#6

I’ve just tried the plex add-on for kodi and that’s working fine so I’d suggest that for the time being. Nicer layout too imo. You can also set plex to start when you start kodi which makes life easier. This and the fact amazon movies play in 5.1 would suggest this is an issue with Plex rather than Amazon.


#7

Hi Jonny. That’s weird as my Plex add on in Kodi is not coming through in 5.1 either.


#8

I just spent about an hour trying to get 5.1 to work on my Gen 2 Fire Stick. I thought I had fumbled a setting somewhere because I like to tinker once in a while. This makes me feel better than I’m not going crazy and my equipment isn’t on the fritz. I knew something was up with the Plex app once I went into Netflix on the Fire Stick and D+ worked just fine. PLEASE FIX THIS!!!


#9

No Bogey it’s not just you !! It’s so annoying and I wish they would fix it. As you mentioned it’s exclusive to Plex as Netflix and Amazon are working fine. PLEASE PLEASE fix it and will someone from Plex please address our concerns on here ? Thank you.


#10

Brand new redesigned app out and it doesn’t support 5.1+. Very frustrating!


#11

Exactly Bogey. All that effort for the crappy redesign and still,they haven’t solved or indeed have yet to comment on the 5.1 issue. I wish there was another alternative other than Emby.


#12

@midwaybrit said:
Hi Jonny. That’s weird as my Plex add on in Kodi is not coming through in 5.1 either.

I can confirm the same, to be sure I messed with every setting around 4 times, directly connected to my receiver and I can not get Dolby digital 5.1 to work on plex or plex for kodi, haven’t tried vanilla kodi to be fair, Netflix works no problem every time.


#13

My Fire TV stick was converting my 5.1 AC3 and DTS no problem before the most recent update. Now with update 6.4.3.1944 it will no longer actively transcode the audio into a format my system uses. I have the stick plugged into a simple TV with no surround sound setup, so 2 ch stereo only. When playing movies I get the L and R channels but no center (which means no vocals) and nothing else. It also will no longer actively convert FLAC into a use able format for the TV either.

I have messed with every setting I can find in both the Fire TV settings and in Plex and nothing will work (DTS on or off, audio pass through on or off, play original video quality or force transcode down). All my other devices work fine, Roku, Web, Xbox, even Windows app, but Fire TV stick is dead in the water.

I am also currently on Plex Server version 1.8.4.4349


#14

it’s ok, plex-apologists have assured us “it’s the same playback engine” therefore nothing possibly could be wrong, id est user-error.


#15

How can the Plex hierarchy be so ignorant as to realize there is a major problem. ? What with this and the new interface it’s almost as if Plex doesn’t want you to use Fire TV and is driving you towards Apple TV, Roku etc.


#16

I have a few ac3 files that work so let me get their confit up so you can compare.

Edit: one file plays direct (can’t force it not to anymore !) and this one doesn’t do 5.1 the other transcodes and works 5.1 fine. Will edit shortly with differences.


#17

Audio
ID : 2
Format : AC-3
Format/Info : Audio Coding 3
Mode extension : CM (complete main)
Codec ID : A_AC3
Duration : 1h 34mn
Bit rate mode : Constant
Bit rate : 448 Kbps
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE
Sampling rate : 48.0 KHz
Bit depth : 16 bits
Compression mode : Lossy
Delay relative to video : 150ms
Stream size : 302 MiB (18%)
Language : English
Default : Yes
Forced : No

This stream gets encoded and plays 5.1 as expected.

Audio
ID : 2
Format : AC-3
Format/Info : Audio Coding 3
Mode extension : CM (complete main)
Codec ID : A_AC3
Duration : 1h 35mn
Bit rate mode : Constant
Bit rate : 448 Kbps
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE
Sampling rate : 48.0 KHz
Bit depth : 16 bits
Compression mode : Lossy
Delay relative to video : 150ms
Stream size : 306 MiB (18%)
Language : English
Default : Yes
Forced : No

This steam does not get encoded and play direct and does not output 5.1 only stereo sound… both hit amp and show as 48hz linear pcm.


#18

Since the update, there are no controls on the client side, just the toggle for pass-through.

If I turn that on, non of my AC-3 5.1 videos play 5.1 sound. My fire stick (gen 2) is plugged directly into my Onkyo AVR, which supports DD and DD+ amongst other things. The sound input appears as stereo PCM which my AVR upmixes through Dolby Prologic.

Before the update, I could turn off DD support in Plex on the fire stick and that would force an audio transcode from AC-3 to AAC 6 channel (after I updated the android.xml profile). Now that doesn’t work either - the sound still comes through as 2 channel stereo.

Note all my video is MKV container with MPEG2 and AC-3 5.1 sound, taken straight from the disk using MakeMKV.

Getting a bit frustrating.


#19

But this is the weird thing, the above files are identical almost and one transcodes the other does not but I can’t see a difference as to what triggers the encoding here. Have you triad multiple files or are they all the same ?

It’s not the amp as both my Sony and Yamaha have the same issue with the same files so it’s either the stick or most likely Plex.

If like me you can’t stand ‘stereo’ movies unless they are made that way then try Xmedia Recode, select Matroska profile, copy in video section the convert in the audio section to AAC don’t forget to change setting to 5.1 and bit rate to at least 448. Take about 10 mins to convert the audio.


#20

Seems to get weirder.

Since the new update, any of my MKVs with AAC in them (where I have used Handbrake and added an AAC track to the existing AC3) cause transcoding. This happen before. What is really strange is that it says the video has to be transcoded, but the audio is direct play…
Turning passthough on or off makes no difference - I think that is simple broken.

I just tried Interstellar - this is a Handbraked MKV H264 video with AC3, DTS and AAC 5.1 audio, from BluRay.
It happily Direct Plays! BUT the AC3 5.1 audio is coming out as PCM on my AVR! huh? Same thing happens if I play DTS. I can only assume that it isn’t really Direct Play, but the audio is being transcoded to PCM in the background. If I pick the AAC track, it causes the whole thing to be transcoded. Why?

Next I tried Lord of the Rings. Another Bluray, turned into H264 MKV just like Interstellar. Guess what? If I play the AC3 track, it arrives at my AVR as stereo. Erm… Confused.

Could it be audio bitrate that is an issue here?