[FIX] EAC3 playback on AppleTV gen4

apple-tv

#1

I've seen multiple reports of EAC3 Direct Play not working with AppleTV.
The issue is real.
Result: If the container has EAC3, audio output is silent, AVR shows two channel PCM.

Some posts imply this is fixed by the current release, but that is not the case (I updated to the beta channel to test).
Note: I tried all (three) settings for audio in AppleTV Settings. Same result for each.

My system:
Plex Media Server running on Windows Home Server 2011
WHS machine + AppleTV gen 4 on wired GbE.
Plex Media Server Version 1.13.1.5063 (latest on Beta channel)
AppleTV connected to (HDMI) Yamaha RX-V867 (EAC3 native, others too: TrueHD, DTS-MA, etc)

The content is mkv container with:
One video stream: 16.3 Mpbs VC-1 (Advanced@L3) 1920x1080 @ 23.976
One audio stream: 1536 Kbps E-AC-3, 48KHz, 6 channel
(it is an HD-DVD backup)

The same content plays fine on my HTPC (Sandy Bridge/HD3000 running Windows 7 Media Center, LAV mkv splitter, My Movies).

Playing to AppleTV Plex Media Server status shows:
As expected, the VC-1 is transcoded.
The EAC3 track is transmitted directly.

Workaround/Fix:
I changed a line in c:\Program Files (x86)\Plex\Plex Media Server\Resources\Profiles vOS.xml

From:

<VideoProfile protocol="hls" container="mpegts" codec="h264" audioCodec="aac,eac3,ac3,mp3" context="streaming" />

To:

<VideoProfile protocol="hls" container="mpegts" codec="h264" audioCodec="aac,ac3,mp3" context="streaming" />

Note: You must exit+restart the Plex Media Server for this change to take effect.

Now the EAC3 track is transcoded to AC3 and we have sound (and AVR shows Dolby Digital 5.1).


#2

Note that even though this solved the problem with EAC3, there were other problems with native Blu-ray and HD-DVD content. Although the ATV4 should have support for H.264 (AVC) natively, it cannot handle all content that may be on these discs.

Some files would play but with choppy video (approx. 1 frame/sec) with direct stream. For some, PMS would transcode (H.264->H.264) which would then work fine. And still others would play H.264 content just fine with direct stream. I could not determine why certain H.264 content worked vs. didn’t work, and I could not determine what the trigger was for H.264->H.264 transcode. I even tried changes to the tvOS.xml as it relates to max resolution (tried setting it lower than the example files) to force a transcode, but even that didn’t work (still would direct stream content that should have been transcoded).

In the end, I decided to re-encode everything as H.265(HEVC)+AC3+subs burned in as appropriate (I kept originals, of course). It took seven computers going 24x7 for a week to convert my collection. With the appropriate tweaks to tvOS.xml for HEVC, my entire collection appears to play with DirectPlay just fine and is very reliable.

Conclusion: We cannot expect ATV4 to play native Blu-ray and HD-DVD content. The software just isn’t up to the task.