fullmoviesonreddit channel not working


PMS ..4885 PMP 3.39.5 W10 box

Not seeing anywhere else to ask this. I have the fullmoviesonreddit plugin. Seems like since the 4885 update, it reports a problem for every link, "An error occurred trying to play ...". No error code is given, and I see no errors in the logs. I have tried deleting and reinstalling the plugin, deleting the plugin cache, rebooting. The same movies play fine from the reddit page. Before I go back to the prior PMS, I thought I'd ask if anyone else saw this?


I just tried using WIn10/PMS and remote Win10 machine with Firefox (latest) on Plex/Web local.
Two videos (Thunderbirds fan edit and Making of Clerks)
Both played fine for the 3-4 minutes I watched.


Thanks, that mirrors my setup. I also noticed that the youtubeTV plugin isn’t responding either. Both plugins stream youtube, so I wonder if that helps identify the problem.


A repair install failed to fix it. I also tried again to remove and reinstall the FMOReddit plugin (via webtools v3) rebooting at each step. What’s odd is for any of those movie links on that channel I can pull up the associated info dialog and what it shows seems fine. If I plug the media url from that dialog directly into my browser it plays fine, but will not play though Plex.

I have attached the logs if anyone can help.

In the PMS plugin folder 'system' log, I found a critical exception - "certificate verify failed (_ssl.c:590)", which seems to happen for every youtube url. I see other other posts about manually adding certificates, but would like some advice.
> 2018-04-03 09:17:36,576 (9a0) :  DEBUG (networking:166) - Requesting 'https://www.youtube.com/watch?v=G_JTOInMEuQ'
> 2018-04-03 09:17:36,674 (9a0) :  CRITICAL (core:574) - Exception (most recent call last):
>   File "C:\Program Files (x86)\Plex\Plex Media Server\Resources\Plug-ins-1046ba85f\Framework.bundle\Contents\Resources\Versions\2\Python\Framework\components\runtime.py", line 843, in handle_request
>     result = f(**d)
>   File "C:\Program Files (x86)\Plex\Plex Media Server\Resources\Plug-ins-1046ba85f\System.bundle\Contents\Code\proxyservice.py", line 49, in do_proxy
>     immediate = True
>   File "C:\Program Files (x86)\Plex\Plex Media Server\Resources\Plug-ins-1046ba85f\Framework.bundle\Contents\Resources\Versions\2\Python\Framework\api
etworkkit.py", line 194, in Request
>     method=method,
>   File "C:\Program Files (x86)\Plex\Plex Media Server\Resources\Plug-ins-1046ba85f\Framework.bundle\Contents\Resources\Versions\2\Python\Framework\api
etworkkit.py", line 67, in _http_request
>     req = self._core.networking.http_request(url, *args, **kwargs)
>   File "C:\Program Files (x86)\Plex\Plex Media Server\Resources\Plug-ins-1046ba85f\Framework.bundle\Contents\Resources\Versions\2\Python\Framework\components
etworking.py", line 370, in http_request
>     return HTTPRequest(self._core, url, data, h, url_cache, encoding, errors, timeout, immediate, sleep, opener, follow_redirects, method)
>   File "C:\Program Files (x86)\Plex\Plex Media Server\Resources\Plug-ins-1046ba85f\Framework.bundle\Contents\Resources\Versions\2\Python\Framework\components
etworking.py", line 141, in __init__
>     self.load()
>   File "C:\Program Files (x86)\Plex\Plex Media Server\Resources\Plug-ins-1046ba85f\Framework.bundle\Contents\Resources\Versions\2\Python\Framework\components
etworking.py", line 181, in load
>     f = self._opener.open(req, timeout=self._timeout)
>   File "C:\Program Files (x86)\Plex\Plex Media Server\python27.zip\urllib2.py", line 429, in open
>     response = self._open(req, data)
>   File "C:\Program Files (x86)\Plex\Plex Media Server\python27.zip\urllib2.py", line 447, in _open
>     '_open', req)
>   File "C:\Program Files (x86)\Plex\Plex Media Server\python27.zip\urllib2.py", line 407, in _call_chain
>     result = func(*args)
>   File "C:\Program Files (x86)\Plex\Plex Media Server\python27.zip\urllib2.py", line 1241, in https_open
>     context=self._context)
>   File "C:\Program Files (x86)\Plex\Plex Media Server\python27.zip\urllib2.py", line 1198, in do_open
>     raise URLError(err)
> URLError: <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)>
> 2018-04-03 09:17:36,677 (9a0) :  DEBUG (runtime:88) - Sending packed state data (575 bytes)
> 2018-04-03 09:17:36,677 (9a0) :  DEBUG (runtime:924) - Response: [500] 2553 bytes


I also just tried this channel on a Windows 10 machine with PMS and in Chrome. Video playback works on most videos. For the ones that fail it is due to the fact that the video has been removed from YouTube.

Looking at your log files (com.plexapp.system.log) you’re running into the “well-known” SSL issue(s). What I find strange is that our setups look the same and still you (and other people) are running into problems…

Some questions:

  • Are you using any sort of VPN or Smart DNS on the machine you have PMS on?
  • What is the exact Windows 10 version you’re running? (You can find this in Settings > System > About)

I can’t promise any solutions, but would love to find out why same setups work differently.


My last quick test was only with two vids.
Please give me some sample titles to try that get the SSL error and I’ll try them too.
I’ve experienced the same SSL issue in the past with other plugins, as @sander1 is aware.


deleted duplicate


Win10 x64 pro 1709 16299.309
Firefox 59.0.2

No VPN. No special DNS settings (cox ISP defaults).
I have tried shutting down all anti-virus stuff. I also took the steps to check for sql database corruption (none). I DO use the basic MVPS hosts file, but it made no difference to disable it.

In the short time I have used Plex, I have added and later removed many channels. Several times I noticed that webtools v3 would have a UAS channel marked as installed when I had manually deleted it from the plugins folder. In this case it seems to require an update in webtools followed by an uninstall to fix. I also noticed that logs for channels long removed aren’t getting cleaned. Don’t know if any of that is related to the issue.

Of the dozens of links I tried on FMOReddit, including the ones tested by JamminR, one did work. This was “Loaded Weapon 1”, a movie I had marked as ‘watch later’ some time ago, perhaps even before the 4885 update. This strikes me as odd, since that movie is streamed just like all the others. It is as if the ‘watch later’ action downloaded a critical piece of info that is now blocked for other vids. Today I tried marking some as ‘watch later’, but the magic is gone.


I just tried the King of jazz, which seems to be what spawned the SSL error for tns1.
I too am on both server, and client, on Win10 1709 16299.309.
Client was Plex Web on Firefox 59.0.2,
I tried both my https //local.PMS.ip:32400 and https //app.plex.tv/desktop - both played fine.
Because I occasionally use forks of releases as they get changed/updated/fixed/improved, I verified the Git address I use for FMoR and it’s from https://github.com/jwdempsey/FullMoviesOnReddit.bundle


I checked that the FMoR bundle files matched the above link. Next I used webtools to delete the UAS channels it showed as installed, then I used the webtools factory reset feature and waited until it responded again. Next I used plex to delete webtools and manually deleted the associated cache. I rebooted and manually installed webtools v3 again, and used the UAS to add the FMoR channel.

The problem remains. I can watch the “Loaded Weapon” vid I previously marked as ‘watch later’, but any other vid, including those mentioned above, will give me a ‘This plugin is not responding’, or ‘An error occurred trying to play…’ depending on if I click the title link or the play arrow.

If this is a previously seen issue, how did others fix it?

I recently downgraded my ISP connection to a mere 30mbps (verified). Plenty fast but I did see that page loads in my browser are taking a few more seconds to start. This may be a punitive measure taken by the ISP to further differentiate the tiers. Could it be that this is a timeout issue? Can I adjust any timeout settings in Plex that may be associated?


Webtools has nothing to do with it (at least, a .000001% chance). You can stop re-installing it.

SSL errors have to do with certificates on the website and the fact a Python web function can’t verify the site. In other channels, changes were made to the code by the main release developer, other community coders, and sometimes sander1 that prevented verification requirement.

The mystery here is why it’s working for Sander1 and I but not you.

Unless your ISP is using a proxy of some sort, they should have nothing to do with it either.


OK, I see several discussions about this issue with one common hack being to bypass or cheat the verification. It looks like the python functions are in the python27.zip. Is there anything to be learned by me editing the responsible function to perform the same hack, or enabling a more verbose error dialog?


It was broken in early versions of Python 2.7. Then came later that supposedly fix it, I think.
Plex for Windows is using one of those later versions.
If you want to edit the FMoR channel code, sure, go ahead, perform the same hack for urllib2.
Again though, you’re only treating the symptom - it’s working on same OS and server version for others.
I’ve not seen that error in quite some time, and thought it fixed due to a Plex update (at least on Windows).
I get the feeling there’s something at odds on your machine.
@sander1 - any ideas?


This PC is a fairly clean W10pro install, only ever used for Plex. Its the only W10 machine I have. There are very few additional applications such as anti-virus or utils. The PC is in paranoia mode - most of the location service, notification stuff is turned off, but automatic updates is on.

When I look at the info for the ~15 plugins I have now, most pull vids via http. Only FMoR, and Vimeo pull vids via https. Vimeo works fine, FMoR does not, but that problem is recent. None of the other dozen PCs or smart devices on my network have any problem pulling up videos on youtube using their native apps/browsers. Possibly they all ignore certificates. Can I assume at this point that it has nothing to do with my network or ISP? If the logs are not providing the necessary visibility to close in on the issue, surely the devs have better tools for this?


@JamminR said:
It was broken in early versions of Python 2.7. Then came later that supposedly fix it, I think.

It was not broken, older versions of Python (everything before version 2.7.9) just did not validate certificates at all (see https://stackoverflow.com/a/28325763). Validation is good and makes the world a bit safer (less chance on man-in-the-middle attacks for example).

There are however a couple (other) issues we (now) run into, which, I think, are:

  • Python not finding a (valid) certificate store.
  • Python not able to use SNI (due to old ssl/old OpenSSL? I don’t know…)

  • Python not finding a (valid) certificate store.
  • Python not able to use [SNI]

I have debugging experience, just not python or web related. If I understand it, the plex(python) code starts with the https url, gets a certificate from (in this case) youtube, and validates it using the local store. Somewhere in these steps is the problem.

Does the python code look at the same certificate store that I see with the mmc console? Can I look in there to see if a proper certificate exists, or is that a given since FF validates the same url OK?

Would I learn anything useful by using visual studio or whatever debugger is used for python, and single step the suspicious part of the code, looking at the data it is using, or is this too obscure for someone not directly involved with the project?


Links on the FMoR plugin magically started working (for me). I have no idea what could have changed since there were no Windows or other updates in the last few days. Out of the dozen or so movie links I tested, there were only a couple that still didn’t work but I think that is normal.


Glad to hear, but as much as I hate to say it, something on your end was likely causing the issue.
I’m sorry I don’t have the knowledge to determine what, other than ‘certificate verification isn’t working’
Though you were experiencing what is somewhat a common issue, it’s usually common among all(or at least most) of a plugin’s users, or none.


Worked for a few weeks, but the same error is happening again for every link on FMoR:

URLError: <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)>

What has changed recently on the PC:
PMS is now,
W10 had a major update 1803,
All the various antivirus updates.


“URLError: <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)”