Getting Local Extras to work on Apple TV 4

apple-tv

#1

Hello, I've looked at other posts on the forums regarding local extras not showing up on the Apple TV 4. I'm testing it out now and I have an extra that shows up on the Web view as "behind the scenes" but the same extra does not show up on my Apple TV 4 (or even the iOS app).

Do you have to have plex permium (plex pass) even to see your local content on tvOS/iOS?


#2

https://plex.tv/features

It's under Plex Pass by the looks of it. My extras aren't spearing either but I know they got a bit funked up when I did some data moving.

Will have a play and report back.


#3

I just don't get why you'd need Plex Pass for the Apps but not the web interface...


#4

I have the Plex Pass and I had the same issue where my personal 'extras' like behind the scenes were showing up on the Plex Web App and Plex for iPhone but no on my new Apple TV. I used the correct naming structure for naming the Local Media Assets. I found it weird that two videos showed the 'extras' on my Apple TV but not the others. I figured out that in order for the 'extras' to show up on my Apple TV i need to have at least Two video 'extras' under the video. Once I did that the 'extras' now show on my Apple TV.

Hope that helps.


#5

@Scene147 said:
I found it weird that two videos showed the 'extras' on my Apple TV but not the others. I figured out that in order for the 'extras' to show up on my Apple TV i need to have at least Two video 'extras' under the video. Once I did that the 'extras' now show on my Apple TV.

Let me guess - if you have 1 "extra" you dont see it in Movie info screen BUT you can play it when you click on a trailer button?


#6

@pecinko said:

Let me guess - if you have 1 “extra” you dont see it in Movie info screen BUT you can play it when you click on a trailer button?

The ‘Videos’ or ‘Movies’ I used are my personal ‘Home Videos’ I made. I had ‘extra’ footage of my ‘Videos’ like behind the scenes and interviews which I wanted to show on the Apple TV. These don’t have trailers but in order to see the ‘extras’ on the Apple TV i had to make sure I had at least ‘two’ ‘extra’ videos on my movies and not just one.
check out the image below from my Apple TV:


#7

I noticed this too> @Scene147 said:

I have the Plex Pass and I had the same issue where my personal 'extras' like behind the scenes were showing up on the Plex Web App and Plex for iPhone but no on my new Apple TV. I used the correct naming structure for naming the Local Media Assets. I found it weird that two videos showed the 'extras' on my Apple TV but not the others. I figured out that in order for the 'extras' to show up on my Apple TV i need to have at least Two video 'extras' under the video. Once I did that the 'extras' now show on my Apple TV.

Hope that helps.

This occurs on mine as well. Only will show extras if there are 2 or more. Guess its a bug in the ATV app as it does not appear to happen in the iOS app on my iPhone.


#8

This issue needs to be fixed, as placing a second cut (or a 3D version) in an extras folder is the only way to keep them all together under a single listing. I, too, am having an issue where the AppleTV will show a trailer as an option, but not a lone extra (as opposed to multiple extras) located in the Scenes folder.


#9

Same issue here. It is a bug, you need at least two extras to make it work. Also if you have more than one trailer only the first one will be displayed if pressing the trailer button. The Plex team is aware of this. I made a bug post a few months ago and a plex team member replied but it still haven't been fixed.


#10

Not only do you need to have at least two extras, they both need to be something other than a trailer. That is, if one of your two extras is a trailer, you need to have ONE MORE other extra for them to show up in Apple TV.

My current workaround is putting a dummy video file (less than one second, named "Dummy.mkv") in the Shorts folder.


#11

@kevinbarre said:

My current workaround is putting a dummy video file (less than one second, named "Dummy.mkv") in the Shorts folder.

that's a good idea. What do you mean though you put it in the 'Shorts folder'?


#12

These are the only folder names that are blessed by Plex for storing and displaying extra content with a movie. I find that putting the dummy file in the “Shorts” folder, ends up showing the file at the end of the files listed. Putting a “Z” at the beginning of the file moves it lower, also.

See here.