# Hardware accelerated transcodes fail with nvidia driver version \>535

**URL:** <https://forums.plex.tv/t/hardware-accelerated-transcodes-fail-with-nvidia-driver-version-535/929403>\
**Category:** Plex Media Server\
**Tags:** server-linux, server-docker\
**Created:** [August 16, 2025, 12:40pm UTC](https://forums.plex.tv/t/hardware-accelerated-transcodes-fail-with-nvidia-driver-version-535/929403 "2025-08-16T12:40:01Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![zehDonut](https://avatars.discourse-cdn.com/v4/letter/z/e8c25b/32.png) [@zehDonut](https://forums.plex.tv/u/zehDonut)\
**Post date:** [August 16, 2025, 12:40pm UTC](https://forums.plex.tv/t/hardware-accelerated-transcodes-fail-with-nvidia-driver-version-535/929403/1 "2025-08-16T12:40:01Z")

</div>

Server Version#: 1.42.1.10060  
Player Version#: Plex Web 4.147.1

Plex is running in Docker version 28.3.3 on Ubuntu 22.04.5

The GPU used for transcoding is a RTX 3080.

After initially upgrading my nvidia drivers from 535.247.01 to 575.57.08 (& recreating the Plex container), I noticed that transcodes will almost always fail with the error message “Transcode runner appears to have died”.

In cases (I ran ~50 tests), the transcode would actually work, on the same media where it previously failed. Stopping & restarting the playback results in the transcoder failing again, so it does not seem to be related to the source files. The files I tested were h264/hevc, SDR.

I then went back through these driver versions

- 575.57.08
- 570.158.01
- 565.57.01
- 550.163.01

but only rolling back to 535.247.01 works.

With all drivers versions, the GPU seems to work fine inside the Plex container (nvidia-smi shows the correct driver version too)

Any idea what could cause this?

Here is an example of what shows up in the [PMS logs](https://support.plex.tv/articles/200250417-plex-media-server-log-files/) when a transcode fails:

```auto
Aug 16, 2025 14:23:38.213 [140679997897528] Debug — [Req#ce3f/Transcode/JobRunner] In directory: "/transcode/Transcode/Sessions/plex-transcode-psl6b57v1dbpihfy2xd18tfz-d61ff355-ee8e-4839-9c64-b136c7d2a076"
Aug 16, 2025 14:23:38.213 [140679997897528] Debug — [Req#ce3f/Transcode/JobRunner] Jobs: Starting child process with pid 10116
Aug 16, 2025 14:23:46.968 [140679953316664] Debug — [Req#d38a/Transcode/JobRunner] Job running: FFMPEG_EXTERNAL_LIBS='/config/Library/Application\ Support/Plex\ Media\ Server/Codecs/46f74ab-560174306fe167a5978a79dd-linux-x86_64/' X_PLEX_TOKEN=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx "/usr/lib/plexmediaserver/Plex Transcoder" -codec:0 h264 -codec:2 dca -noaccurate_seek -analyzeduration 20000000 -probesize 20000000 -i "/tv/House/Season 5/House - S05E06 - Joy Bluray-1080p.mkv" -map 0:0 -metadata:s:0 language=eng -codec:0 copy -filter_complex "[0:2] aresample=async=1:ochl='stereo':rematrix_maxval=0.000000dB:osr=48000[0]" -map "[0]" -metadata:s:1 language=eng -codec:1 aac -b:1 256k -f dash -seg_duration 5 -dash_segment_type mp4 -init_seg_name 'init-stream$RepresentationID$.m4s' -media_seg_name 'chunk-stream$RepresentationID$-$Number%05d$.m4s' -window_size 5 -delete_removed false -skip_to_segment 1 -time_delta 0.0625 -manifest_name "http://127.0.0.1:32400/video/:/transcode/session/nrtszrdi1dhne5fternpp0kh/8ac44a2a-4823-477c-bdfe-78a6b941bea3/manifest?X-Plex-Http-Pipeline=infinite" -avoid_negative_ts disabled -map_metadata -1 -map_chapters -1 dash -start_at_zero -copyts -vsync cfr -y -nostats -loglevel quiet -loglevel_plex error -progressurl http://127.0.0.1:32400/video/:/transcode/session/nrtszrdi1dhne5fternpp0kh/8ac44a2a-4823-477c-bdfe-78a6b941bea3/progress
Aug 16, 2025 14:23:46.968 [140679953316664] Debug — [Req#d38a/Transcode/JobRunner] In directory: "/transcode/Transcode/Sessions/plex-transcode-nrtszrdi1dhne5fternpp0kh-8ac44a2a-4823-477c-bdfe-78a6b941bea3"
Aug 16, 2025 14:23:46.968 [140679953316664] Debug — [Req#d38a/Transcode/JobRunner] Jobs: Starting child process with pid 10165
Aug 16, 2025 14:23:48.068 [140679942949688] Warning — [Req#d98b/Transcode/nrtszrdi1dhne5fternpp0kh] Transcode runner appears to have died.
Aug 16, 2025 14:23:48.090 [140679953316664] Warning — [Req#d964/Transcode/nrtszrdi1dhne5fternpp0kh] Transcode runner appears to have died.

```

---

<div class="post-metadata">

**Author:** ![pshanew](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/pshanew/32/160555_2.png) [@pshanew](https://forums.plex.tv/u/pshanew)\
**Post date:** [August 16, 2025, 1:08pm UTC](https://forums.plex.tv/t/hardware-accelerated-transcodes-fail-with-nvidia-driver-version-535/929403/2 "2025-08-16T13:08:41Z")

</div>

I’d be curious to know if you see any difference with the transcoder forum preview version of PMS:

> [@Transcoder Upgrade Forum Preview](https://forums.plex.tv/t/transcoder-upgrade-forum-preview/924241):
>
> Announcing the Transcoder Upgrade forum preview! Plex’s transcoder is a highly customized version of FFMPEG which has been accumulating bugfixes and features since it was forked back in 2012. With such a large number of differences, upgrading from the upstream repository became increasingly more difficult and took up more and more time. We decided it was time to clear out the bloat and start over, creating a brand new fork from ffmpeg 6.1 and only bringing over features necessary for the funct…

Part of the preview is an upgrade to the version of FFMPEG on which the Plex transcoder is based (to 6.1).

Whatever the case, you’ll likely need to provide complete [server logs](https://support.plex.tv/articles/200250417-plex-media-server-log-files/) (debug enabled, but not verbose) to receive any real help. Snippets are rarely sufficient to aid in diagnosis as they simply don’t provide enough context.

---

<div class="post-metadata">

**Author:** ![system](https://global.discourse-cdn.com/plex/original/3X/2/a/2acb9765406f63293d357b4ec509ec39aa28f2ad.png) [@system](https://forums.plex.tv/u/system)\
**Post date:** [November 14, 2025, 1:09pm UTC](https://forums.plex.tv/t/hardware-accelerated-transcodes-fail-with-nvidia-driver-version-535/929403/3 "2025-11-14T13:09:20Z")

</div>

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.
