Hardware assisted playback / transcoding on Shield



I record TV with an HD Homerun Prime using another software package which names the files in a format that Plex likes, so they import after the recording is done. I'm using the Plex server on the Shield to connect across my LAN to where these files are stored. The files are MPEG2 .ts files.

It's my understanding that the shield can play MPEG2 with hardware assistance, so I would expect them to play back buttery smooth, but they don't. It looks like it is transcoding it to "Original", which on a 1080p show still seems to cause long pauses when I fast forward. If I lower the quality down a few notches, it seems to do a better job when I skip ahead, but still not like playing it back without transcoding.

But, why is it transcoding this at all? It should be able to play it directly with the hardware, shouldn't it?

Edit to add: I've tried setting Direct Play to Forced, but then it doesn't seem to want to play at all.


The Shield does not support direct playback of mpeg2.


@MovieFan.Plex said:
The Shield does not support direct playback of mpeg2.

Yes it does. It has a inbuilt decoder.


Oops, sorry. Yes, mpeg2 is supported on the Shield. If it is transcoding, it's for some other reason. You'll need to provide the logs from the app after trying to playback this video.



I would suggest not using .TS files. ExoPlayer, the player for the Plex for Android TV app, does not like .TS files very much, at least not in it's current revision. This may change when the app is upgraded to ExoPlayer 2.x. You would no doubt get better results if the recordings were remuxed into .MKV at the moment.

Check you have local quality set to original, audio passthrough to auto in the Plex settings.


Thanks for the info. I think this won't matter too much as I'll probably only use Plex as the client on my phone when I'm not home, so it will need to transcode anyhow at that point.