Help - personal media files (mp4) not showing up under a TV Shows Library

server-linux

#1

Hi,

I have just installed plex ( Version 1.10.1.4602 ) on CentOS 7 ( Linux version 3.10.0-693.11.6.el7.x86_64 (builder@kbuilder.dev.centos.org) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-16) (GCC) ) #1 SMP Thu Jan 4 01:06:37 UTC 2018 )
I have followed the tree structure exactly even named the files the same as recommended (https://support.plex.tv/articles/200265256-naming-home-series-media/) but when i scan the library there are NO ITEMS IN THIS LIBRARY. If I add the same root folder to an "Other Videos" library they show up. I have even gone as far as chmod -R 777 on the entire media root folder.

Thanks in advance


#2

Do you have the "Local Media agent" as the first agent for TV libraries?
https://plexapp.zendesk.com/hc/en-us/articles/200220717-Local-Media-Assets-TV-Shows

Enable "Local Media Assets"

"Local Media Assets" is an Agent source that loads local media files or embedded metadata for a series. To do this, ensure the Agent source is enabled and topmost in the list:

Launch the Plex Web App
Choose Settings from the top right of the Home screen
Select your Plex Media Server from the horizontal list
Choose Agents
Choose the Library type and Agent you want to change
Ensure Local Media Assets is checked
Ensure Local Media Assets is topmost in the list

Related Page: Plex Media Server > Server Settings > Agents

I've never tried to tile my 'home videos' this way, nor knew that the support site you linked to existed.
(A URL rebranding/CSS 'plex' theme usage case I would guess)
However, I'd think ensuring the agent was first and enabled for TV show libraries might fix your issue, if they weren't enabled/at top already.