Help with Error 0x80070643, unable to upgrade.

server-windows

#1

For the past two builds plus tonight's release I have been unable to upgrade plex. So I do it manually and I get the dreaded (so it seems) error 0x80070643. I am at my wits end on this. I have spent hours trying to figure out what is causing it and looking at the logs. I've tried some registry edits that others have said it worked for them in other threads but I am getting nothing and I am stuck at build 1.8.1.4139. Attached is my log on the current error. Help?


#2

What OS? Please don't say just Windows.

Also, have you looked at this article yet.
https://support.plex.tv/hc/en-us/articles/202967086-Windows-Errors-trying-to-upgrade-install-or-uninstall-Plex-Media-Server


#3

I currently run windows 10 x64 build 1704. I didn't see that link earlier in my searches. I'll investigate. What's weird is that this box is only 3 month old.


#4

I actually don't believe that Plex service articles are among the search results from the forum. So sad..


#5

I ran the MS Fix It program and told it I was having issues uninstalling Plex. It went to work on it and after about 5-7 minutes, it said the task was completed. I went to install the latest version of it and it worked. Thanks for this link, it helped out a lot.