Help with stuttering

smart-tv

#1

I've been using Plex for a while with everything generally going well. recently I've had a few files stuttering and i cant work out why. The film stutters at the exact same spot every time, and usually recovers and carries on afterwards. I tried the film in Emby and it did the same thing at the same spot. If i watch the film through the TVs built in DLNA player it plays fine. I've monitored the server during the stuttering and the file is direct playing, with the CPU and network usage hovering around 10-15% on the server.
Ive got an Intel NUC i3 as the Plex server and my main client is a Samsung KS7000 built in app. I mainly watch remuxes both HD and UHD which has been fine as long as they direct play, I know my server is not powerful enough to transcode so i always make sure the files can direct play. This issue where the file is direct playing but still stuttering has affected 4-5 different UHD files recently, after not affecting any of the first 40 or so UHD files. Any problems in the past have either been audio or subtitle related, but i am certain that these are not the problem in this case.

can anyone suggest what the problem may be? Thanks


#2

Check Plex settings for streaming media speed. I found that not all files would play when I had settings on 'Maximum" streaming speed. I dropped it to 20mbps which is one below Maximum streaming speed and everything played without issue again. It seems "Maximum" speed setting does not auto adjust. It's very literal. I hope this helps


#3

Also just about anything with DTS is going to stutter regardless of you settings.


#4

When comparing network speed between dlna and the app don't look at the utilization percentage, check the actual transfer rate


#5

@Magnus33 said:
Also just about anything with DTS is going to stutter regardless of you settings.

With one of the films i removed every audio track over than the one that i wanted and it fixed it. Its difficult with audio tracks as in my experience its very random which ones plex will play. I have around 40 UHD films and i would say 5 of them have required me to strip out audio tracks to get them to work. Its made even harder by the fact that the most recent one worked fine for 10 minutes before stuttering, and there is no evidence to show that the audio is the problem or is going to be a problem from the start. According to plex its direct playing with no issues.

With the second film removing all audio tracks other than DD5.1 did not fix the problem...

I have definitely got UHD films with DTS which work fine - the Dark Knight trilogy + Harry Potters off the top of my head.


#6

Its not always the issue but its been a known bug nearly from the beginning.

This is for a very good reason since most tv don't do dts simply because the don't want to pay for the right to do so.
Plex itself should not be direct playing the audio for those movies since it all likelihood the tv themselves are incapable of playing the dts audio stream.

Now you do get the odd movies now and then which do appear to have dts and do play without issue but this is due to the actually audio on those movies being a nonstandard dts version.

We tested it with avatar and the new blade runner.
Non dts version played without any issue other then my can sitting on the remote.
Dts version stutter like crazy after various length of time.
Video was unchanged for either movie.

Sadly the support for smart tv is something of a joke and a after thought for plex compared to its other projects like android.