How do I set Android client to request transcode of HEVC to H264?



I have an Android based smart projector. It's kitkat and can't play HEVC (other than with Mx player software decode, but that's too jerky to watch anyway). If I try to play such a video thru plex, it doesn't transcode, so it just plays this noisey messed up picture (the same as if I played the file locally with vlc /es/localMM). How do I force it to transcode?

One way I found was to set plex to use the android player, then the server transcodes HEVC-->H264 and it plays fine, although limited to 1 minute. I'm happy with the plex player tho if I knew how to set it so that HEVC H265 gets transcoded... (There was also an option to use an external application, but when I select that I couldn't figure out how to select which application.)

Additionally, if possible, I'd like to set it to transcode h264 1080p to 720p as this projector is only 720p anyway and if I try to play a 1080p video it stutters too often so I'd rather let my PC do the conversion... maybe this has something to do with those h264 level settings?


Version Information


The "additionally" paragraph can be ignored, I found the quality setting took care of that. But still doesn't solve my HEVC issue..


Seriously. How do I set Plex to transcode HEVC to AVC when sending to my android projector? This isn't meant to be a complicated question but I can't figure it out...


I'd still love an answer. My plex server can handle hevc, my android projector can't, please help!


in short... you don't.
the Plex client is supposed to get the information from its host environment on what it's capable to play (or not). this will cause the Plex server to transcode.

what you can do for a deeper insight on Plex transcoding (or not) decision...
* start playing the hevc/h2.65 video on your projector
* go to Plex Web Settings > Server > Help > Download Logs
* unzip the file and check Plex Media Server.log for lines with a "MDE: " prefix -- this is information of Plex transcoding decision engine