How to delete files with PMS on Shield TV

server-nvidia-shield

#1

I have my videos stored on a NAS and when the server was set up on my PC, the option to delete videos after watching worked perfectly. Now that I have migrated the server directly to the Shield TV, the option is still there, but it no longer deletes the file and just says there was a problem deleting the file. I have tried via my web browser on the PC and get the same message. I still have a Plex Server on my PC and that one deletes from the NAS easily.


#2

I want to say that mounted NAS/Samba storage on the Shield TV is read-only but I'm not 100% sure and can't test.


#3

I have the exact same problem.

It seems odd that Shield TV would treat all SMB storage as read-only when I can set up permissions myself on the NAS. Anybody have any ideas why this would be the case?


#4

Same issue here but using a QNAP with full R/W access given to the user.


#5

Yep, same here. Exactly the same scenario. I keep telling my wife, we're in the dark ages of technology. Lot's of linux hobbyists in this area, not enough reality.


#6

Probably an Android issue, as the Shares are NOT read only for the System.
Android creates an "Android" folder with lot of sub folders if the user used for connecting has RW rights...
However. It is ANNOYING as hell...
So Team Plex, either disable the option in PMS for Android TV platform all the time or make this work...


#7

Any update on this?


#8

i found a "solution" to the annoying unwanted folders: Synology SMB Filter
i just added "Android" as forbidden item and that prevented the Shield from creating those annoying folders.

However, the "new feature" of crapvida to write to external storages did not change anything for smb shares.
if you want to have rw access you need to root your device and use cifsmanager and busybox for smb share mounting.
on those mountpoints you have full write access.

however... whereas rooting is already available for the new 5.0 crapxperience, it is still very much "Your own risk" to try it.
as in " i would recommend trying it atm... "


#9

Same here...no solution yet


#10

Any news as of yet? Bought the shield tv specifically for this because I saw I could run plex media server. I soon found out that I couldn't use it anything like a server......