How to Migrate From PlexMediaServer to PlexMediaServer_PlexPass?

server-freebsd

#1

Hello friends, 

 

 

Let me start with an apology if this is posted somewhere. Thanks for those that make the FreeBSD ports possible. 

 

 

I am a new plex pass holder :D . I did not get in before the price hike, but no big deal. It's good software and I don't mind supporting that. 

 

 

I have been a standard plexer for a while and have everything configured "just so". But now I am a plex passer and I want to get right on that razor's edge. But what I don't want is to lose all my settings and libraries and shares and such. 

 

 

I am running NAS4Free, so let's start with that disclaimer. However the process should be about dead-on the same to normal FreeBSD as I understand it. 

 

 

Here is what I've done: 

 

Enter jail.

 

Update ports tree of course. 

 

 

stop plex:    

/usr/local/etc/rc.d/plexmediaserver stop
 
 
Update/install plex pass version: 
 
cd /usr/ports/multimedia/plexmediaserver-plexpass && make reinstall clean
 
(also tried 

 

cd /usr/ports/multimedia/plexmediaserver-plexpass && make reinstall clean

 

and 

 

cd /usr/ports/multimedia/plexmediaserver-plexpass && make deinstall clean && make reinstall clean 

 

after restoring from ZFS snapshots when results were not satisfactory). None of these options made any difference. 

 

 

 

Start my new plexpass install!!!

 

/usr/local/etc/rc.d/plexmediaserver_plexpass onestart

But alas, my library/settings/shares are all gone. ZFS rollback engaged...:/

 

 

So, the question is -- how do I do this properly? I would like to enjoy the plexpass side of things while still maintaining my existing, meticulous configuration. Or at least the library. 

 

 

I think the answer may lie within /usr/local/share/plexmediaserver and /usr/local/share/plexmediaserver-plexpass , 

 

 

but I need some help from there. 

 

 

Thanks in advance community!

 

 

 

 

 

 

 


#2

While i have not tested it, this looks promising;

https://github.com/mstinaff/PMS_Updater

Just remember to run it from the Jail


#3

Hi,

Thanks for your response.

That script is handy for the updating process but it doesn't address my core problem -- i still lose my library when I update this way as well. The script fetches the latest tarball straight from Plex so that we don't have to wait for the ports tree update. As I understand it, for FreeNAS users with the plex plugin it is extremely helpful because they have to wait on a new point release to get a plex update. 

Anyway, my problem stands, although I do appreciate the suggestion. Unless I am missing something...


#4

Hi,

Thanks for your response.

That script is handy for the updating process but it doesn't address my core problem -- i still lose my library when I update this way as well. The script fetches the latest tarball straight from Plex so that we don't have to wait for the ports tree update. As I understand it, for FreeNAS users with the plex plugin it is extremely helpful because they have to wait on a new point release to get a plex update. 

Anyway, my problem stands, although I do appreciate the suggestion. Unless I am missing something...

First let me say I switched from the regular to the plexpass version on freebsd.  (Then I nuked my OS drive and just installed plexpass version)

But back to your first question, if you're in the same jail the easiest way is to point the plexpass version to your old plex support directory.  for me it was an extra setting in my rc.conf

plexmediaserver_plexpass_support_path="/usr/local/plexdata"

the default for plexpass version is "/usr/local/plexdata-plexpass"

Which leads me to the other option, if this is the same jail you should have both a plexdata and plexdata-plexpass version in the same location and you can also simply copy the contents from your plexdata to your plexdata-plexpass folder.  (The only really important one for me was the Plug-in Support/Databases folder which is the folder that containers your libraries, watched status, and stuff. 

What I can't tell you is where exactly your folders are/what they should be as I am using FreeBSD without a jail, but that should at least help a little bit for you.


#5

Thanks! This is just what I needed and helped me solve my problem. 

If anyone finds this in the future, the directory where user-specific data lives is /usr/local/plexdata  OR /usr/local/plexdata-plexpass 

Obviously if you are running inside a jail, this will be a subdirectory inside the jail's parent directory so for example: /mnt/jails/plexjail/usr/local        and so on. 

As suggested by J_McKee, adding this to rc.conf worked a treat after installing the plexpass version: 

plexmediaserver_plexpass_support_path="/usr/local/plexdata"

This essentially tells the plexpass version to use the config directory of the existing standard install. 

Cheers J_McKee


#6

I found this process easier through backing up the data for Plex, then restoring it to the new location. The basic overview is:

  1. Stop Plex
  2. Create a compressed backup file of the Plex data
  3. Move the backup file to different location
  4. Remove Plex
  5. Install Plex-Pass
  6. Start/Stop Plex (creates data folder and files)
  7. Restore the backup over the new data
  8. Start Plex
  9. Enjoy

Stop Plex:
service plexmediaserver stop

Backup the data (default location is /usr/local/plexdata):
cd /usr/local/plexmediaserver
tar -czvf plexbackup.tar.gz Plex\ Media\ Server

Move the file to a place you can find it:
mv plexbackupdata.tar/gz

Remove Plex:
pkg remove plexmediaserver
sysrc -x plexmediaserver_enable

Install Plex Pass:
pkg install plexmediaserver-plexpass
sysrc plexmediaserver_plexpass_enable=YES

Create the data directory by starting and stopping Plex:
service plexmediaserver_plexpass start
service plexmediaserver_plexpass stop

Restore the backup data:
mv /plexbackupdata.tar.gz /usr/local/plexdata-plexpass
cd /usr/local/plexdata-plexpass
tar -xzvf plexbackupdata.tar.gz

Start Plex:
service plexmediaserver_plexpass start


#7

@Ratoka Thank you for this guide! I just used it, and it seems to have worked perfectly. As a noob to Linux, this was very helpful.


#8

Another shoutout to @Ratoka for the guide. Worked perfectly.