Indirect access Plex on Ubuntu 16

server-linux

#1

So I moved from Windows to Ubuntu to host my Plex server. I do have Plex Pass and all. However, when I connect to plex via my phone, it says 'indirect' and if I try to use camera upload, I get an error that says my server isn't reachable. The server is reachable as I can access other files, play movies on my Fire TV, etc... So wondering if trying to add files requires me to do some additional things for permissions or something? All the user accounts I use to try this that do have that enabled give the same error. Thoughts please? Thanks much.


#2

Have you followed this help article? https://support.plex.tv/hc/en-us/articles/200484543-Enabling-Remote-Access-for-a-Server


#3

I have gone through that and all looks like it should. For trying this, I am on the same network, but wirelessly. It says it is remote enabled as shown with the screen shot. So camera upload should at least work if connected via wifi. What am I missing here?


#4

Have this as well:


#5

Do the easy part first. Camera uploads to the server.

Attempt an upload.

When it fails, Settings - Server - Help - Download Logs. Attach the ZIP file here with your next post.


#6

Alright, I did that. Not sure what I am looking for however, but have added the zip file.


#7

Thanks @ChuckPA file is attached.


#8

Thanks for the logs.

For future reference, please do not enable Verbose logging unless requested. Too much first-level diagnostic data is lost.

Did you know your server can’t find plex.tv ?

Oct 10, 2017 19:39:06.986 [0x7fe8d6bff700] ERROR - Error issuing curl_easy_perform(handle): 6
Oct 10, 2017 19:39:06.986 [0x7fe8d6bff700] WARN - HTTP error requesting GET https://plex.tv/servers/567711603f51dcae378d33bec2e94679b511067e/access_tokens.xml?auth_token=xxxxxxx&includeProfiles=1&includeProviders=1 (0, No error) (Couldn't resolve host 'plex.tv')
Oct 10, 2017 19:39:06.986 [0x7fe8d6bff700] DEBUG - MyPlex: using cached data for request for https://plex.tv

#9

@ChuckPA - thanks. Logged into the machine PMS is installed on and opened a browser to plex.tv without issue. I then logged into plex via the browser from that same machine. If this is the issue, then I am not sure what is going wrong here. What else can I do?


#10

Additionally, per the first image I shared, would that have an affect? I mean, I can access everything just fine, is just the camera upload that gives me issues.


#11

let’s make certain there is no interference from anything else

  1. SSH to the new machine ssh -l username -L 8888:127.0.0.1:32400 ip.addr.of.host
  2. In your local browser, open a tab http://127.0.0.1:8888/web
  3. Settings - Server - General
  4. Sign it out and in. Watch for errors
  5. Double check the share / library settings for your camera uploads
  6. Recreate the camera upload one more time to that server
  7. Pull its logs
  8. Post
  9. I will see what else is getting in the way but something interfered with finding plex.tv

#12

@ChuckPA - so the issue seemed to be the plex apps on the phones I was trying. Basically, uninstalling, then reinstalling and signing in via these phones (Android Samsung S7 and S8+) it now works. Going through and uploading now.

I did go through those steps you mentioned earlier, but never saw any errors. Wasn’t sure what you meant by “Double check the share / library settings for your camera uploads” on the server itself. Or was that supposed to be on phone?

Lastly, I was starting to wonder if a remote access deal was causing the issue since if you look at the second image I shared above, it shows an “X” from internet > public IP address. That is still there though, but maybe best for another post. So far, it hasn’t caused any issues trying to view movies, listen to music, etc… though.


#13

I suggested to check settings, and implied permissions as well, because that is a common oversight.

Remote access doesn’t have any bearing on local upload. My normal diagnostic procedure is to secure local (LAN) operations first and then move on to the next. That would be remote in a new thread but if you’ve done the port forwarding without success and don’t have a 5+ year old modem/router (the UPNP implementations are very bad) then please do create a new thread. We’ll also make one test with Verbose logging on a completely quiescent system so we don’t lose any data.


#14

@ChuckPA - are you talking wiht implied permissions with PMS or within my Ubuntu? As far as permissions with ports, those have all been enabled.


#15

Permissions in Linux for PMS (user plex) to write to the disk location(s) used for that library section. Remember; Linux default security is strictly enforced.


#16

Thanks a ton for all the info. I guess to close this thread out, one last question or two. So @ChuckPA - can you point me to something to ensure I have the permissions set and all? Maybe there is a doc somewhere or something? Really, everything I have that plex needs to see in terms of my library is in a folder called “Media”. I do assume that for the plex internal stuff, it sets those permissions when it installs, correct?

One more thing I thought of, if I can already see those media items, movies, music, etc…, then does that mean that the user plex already has its needed permissions? So far, I have had any issue viewing or listening to shows and music and whatnot.

Thanks again!


#17

I have assembled a group of Linux Tips here https://forums.plex.tv/categories/linux-tips

While you won’t need to perform external drive mounts for media, the tip for using NTFS and EXT4 HDs show the command to set permissions for you to administer and plex to read.

Of particular interest are the two find commands. One is for the directories (755) and the other is for files (644)


#18

Did you get sorted?

Sounds very similar to a problem I had to do with DNS rebinding.


#19

Yes, that did the trick for this part.