Is 4k play on clients something that is being worked on by plex?



Basically I have a pain in my a$$ trying to get 4k content to stream well using plex. I just recently got a lg oled55b7v and dam when its working in hdr in all its glory it is beautiful.... but plex is so painful to try get working well with this. I have tried xplay and that seems to have its own issues, specifically with audio.

I also have a shield tv with both the plex client and kodi box and im having issues with both. kodi seems to be a little more usable but again not well enough to be a daily driver. So i am now using the lg media player that recognizes the plex media server and this in 99% of cases is running perfectly. The UI clearly isnt as nice as plex or xplay but to have the content running well is clearly the most important thing.

Is there anything on the horizon for plex to get this sorted....? mostly the lack of direct play in recent releases seems to be the major issue.


Plex lately more concentrated on cord cutting so no perks for us, who simply want to watch videos in 4K


I guess 4k is still a luxury as such and doesnt really cater to the masses. I understand that until 4k becomes a more commonly used format it wont be given a high priority. On the other hand if they changed the base media player perhaps they could reap rewards across the whole spectrum of users. but then again im fairly uneducated when it comes to the inner workings of the whole thing. this may be a lot more difficult than it sounds.


The Plex app already supports 4K videos. You’ll need to provide more details on what isn’t working. The XML from the video will help as well as the app logs after trying to playback the file.


I don’t think I’ve gotten 1 file to play with direct play through the plex app. Majority of my files are mkv 10bit, with the odd hdr in there. As I said I just resorted to using the LG player. I have seen that 8bit 4k in mp4 format works?!? But it’s a very limited and spacific file format to have. Also I haven’t heard anyone say hdr files will direct play either.

I am aware that 4k direct playback is available but it is very limited at present.

I still love plex and everything about it. I’m just starting to move into 4k having recently bought a 4k TV and I’m just trying to highlight my difficulties with it on plex. And I don’t seem to be the only one. This is by no means a deal breaker for me with plex but I’d still like to see it addressed at some point or even acknowledged.


I don’t have a 4K TV but I do have two Windows laptops running Plex Media Player, and HEVC videos direct play on both of them. Just FYI.


@tazire - You’re going to need to describe an exact example. Provide the XML for the video and what device you are using.


thats just one of the files. its 4k hdr h265. it will transcode to h264 4k and lose the hdr. I have found the same result with all the 4k files i have atm.

I have tried the plex app for lg tv, plex for nvidia shield tv and plex for kodi running on the shield tv. all with the same results.


Well, you have 3 things in that file that could be causing the transcode. 1 - Dolby Atmos audio. Do you have a receiver that supports this? The Shield can pass-through Atmos but the LG TV probably can’t. In some cases the video can still be direct streamed with only the audio transcoded. 2 - You have PGS subtitles. Did you enable subtitles to be used? PGS subtitle can only be direct played if the whole file is direct played. If the stream has to be altered due to the Atmos audio, then the PGS will have to be burned in (i.e. video transcode). 3 - Your video is ~34 Mbps. What quality setting have you set in the clients? It needs to be set to maximum.

If you can reproduce from either the TV or the Shield and provide me the app logs, that will confirm what is going on.


Ok well the tv wont be the problem. its brand new oled55b7v. receiver may be the problem but i really dont think so. subs are disabled by default. finally the quality is always set to original/maximum quality.

The main reason im looking at the plex app as the issue is that, like i said, i play that specific file flawlessly using the lg media player running from the plex server. so its kinda strange to me. also bare in mind i have this issue with all my 4k hdr files. including ones with older audio codecs that would definitely be supported by the receiver…

is there anything i should be looking for in the logs that would show the reason for transcoding? ill have a look now to see.


The quick check is to turn on the “information overlay” from the settings menu. Then when the file is playing, activating the player overlay by hitting a button. In the top left corner it should have a reason why it couldn’t direct play. To get more details, you’ll need to look in the Android TV log. You should be able to search for the same reason you saw on the screen. Look above that to find more details on that decision.