Is it possible to enable a volume overlay?

plex-media-player

#15

@onekmilesbehind any more info about this please? Is the volume overlay only present when you are using a FLIRC device? Is it a Plex volume overlay or the Windows 10 one? If I buy a FLIRC device for this machine, and configure it to work with my remote, will I get a volume overlay?

Developers - should there be a volume overlay with Plex Media Player? If so, how do I enable it on this machine please?


#16

Hey @lisagood sorry for dropping off, work has picked up and I have not had not much time to look into this. To answer your questions first, no the overlay only appears when using my wireless keyboard's + and - keys; the remote pairing through FLIRC doesn't have volume keys mapped. The overlay is the PMP one, not Windows. Buying a FLIRC may fix your issue if you find a remote with enough programmable buttons, but I wouldn't purchase one until we can get a dev to chime in on this.

I did look at the logs and compared with one of mine and these were the differences I noticed in the setup (your values listed first):

Windows Version: 10.0.14393 (anniversary update) vs 10.0.15063 (creator's update)
Audio setup: optical/2.0 vs HDMI/auto (I may be wrong here, as I could have misread the log values)
Graphics Engine: OpenGL vs ANGLE

I never looked at this issue prior to me applying the creator's update, so that alone may be the source (unless one of your machines is already running the update and isn't getting an overlay). I don't have an optical setup to test with anymore, but the overlay should appear regardless. Further, I switched to OpenGL mode, manually set my audio settings to match yours, and still got an overlay so I don't think those are the culprit.

The other difference was the remote key input--we have different logged key behavior, though it's hard to tell when you hit the volume keys (I found a sequence that looks correct, but again, could be wrong):
Yours:

2017-07-10 08:39:42 [ DEBUG ] InputComponent.cpp @ 152 - Input received: source: "Keyboard" keycode: "Down" : InputBase::InputkeyState(KeyUp)
2017-07-10 08:39:43 [ DEBUG ] InputComponent.cpp @ 152 - Input received: source: "Keyboard" keycode: "Down" : InputBase::InputkeyState(KeyDown)
Mine:
2017-07-10 18:38:18 [ DEBUG ] InputComponent.cpp @ 152 - Input received: source: "Keyboard" keycode: "0x5bV" : InputBase::InputkeyState(KeyDown)
2017-07-10 18:38:18 [ DEBUG ] CachedRegexMatcher.cpp @ 68 - No match for: "0x5bV"
2017-07-10 18:38:18 [ DEBUG ] InputComponent.cpp @ 152 - Input received: source: "Keyboard" keycode: "Meta+0x5bV" : InputBase::InputkeyState(KeyUp)

I've attached the picture of the overlay I see when pressing + or -, as well as some pictures of my settings. My audio settings are set to auto-select channels and device, device type is set to HDMI, passthrough enabled for everything, and exclusive mode also enabled.

@vlang I'm sure you're swamped, but do you have any insight as to why @lisagood doesn't get a volume overlay when changing volume in PMP (log attached in previous post)? Are there any known keys that will trigger a volume change, but not trigger the overlay?


#17

Well that is bizarre, I have never seen that overlay on any of my machines. That is exactly what I need. How do I get it?

EDIT, Sorry, I should have said thanks for your help so far!


#18

Is there a developer around that can help with this please? Must be an advanced setting somewhere that can switch the volume overlay on?


#19

Maybe this is a desktop mode vs. TV mode confusion?

Desktop mode is what PMP normally shows windowed, and TV mode is normally used in fullscreen mode. But these modes can be set independent from the window mode.

As far as I'm aware, the volume bar (aka overlay) in onekmilesbehind's screenshot exists only in TV mode. As long as the key is correctly mapped, it should always be shown when volume is changed. So if volume changes, the overlay should be shown as well.

You can force TV mode by going into the TV settings, and setting the "Layout" option to "TV". It's also possible to switch the window mode without changing the UI mode with Shift+F11.


#20

Hi @vlang I just tried the machine in question in both desktop mode and tv mode and I don't see the plex volume overlay in either. The volume is changing with the remote presses (gets louder and quieter) but I don't see the overlay / volume bar.


#21

@lisagood can you describe your remote setup again? Namely looking for brand & model # and if there was any configuration tool you had to use to map the buttons initially.

@vlang thanks for chiming in--does PMP only display the volume overlay when it receives a command to change the volume directly, or will it reflect changes to the volume made by Windows (or externally in general)? I'm wondering if it's possible for PMP to not recognize the keymap, but Windows does, possibly creating this situation where the volume changes, but PMP does not show it.


#22

Hi, I use a WIndows MCE remote IR receiver like this (known as an ehome device):

https://www.quietpc.com/msrem

I also have this combined keyboard / mouse:

https://www.amazon.co.uk/gp/product/B00DUUF30Y/ref=oh_aui_search_detailpage?ie=UTF8&psc=1

Plus, I have tested with a standard USB wired keyboard with shortcuts for volume change, and two different Windows 10 PC's and they all behave the same.

They do alter the volume, and when PMP is not open, I see the windows 10 volume overlay move.

But, with PMP open and running, I see no visual volume bar / overlay, even though the volume is being changed.


#23

does PMP only display the volume overlay when it receives a command to change the volume directly, or will it reflect changes to the volume made by Windows (or externally in general)?

No, PMP has its own volume control. The global Windows volume control will be applied on top of it.

Maybe the problem is that the remote actually sends events consumed by the global Windows volume control.


#24

Okay, we have progress! The + and - keys bring up the Plex volume bar / overlay.

Unfortunately this isn't very helpful, as it only controls a trim to the windows global volume, and won't actually increase the volume beyond what the windows global volume is set at

As I use this machine for a number of different apps and purposes, I can't risk having the volume up really high and then trimming it in PMP, as I might damage my speakers when not in PMP, or (for example) if a windows notification comes in.

On the same machine, I have PMP, Open PHT, Plex Home Theatre, Media Portal 1, Media Portal 2 and Kodi. Having just discovered the + and - controls, I went into those apps to see what they do. In all of those apps, I get volume overlay with both the volume keys and the + and - keys. Some show different volumes (so windows global plus the apps ability to trim it) but some just show the one volume bar. In all of them though I can see exactly what the global windows volume is set at.

A solution, I think would be to allow the windows volume bar to be visible within PMP Which it would be if I could run it in full screen windowed mode. As I said previously, the windows volume bar does show through when running PMP in windowed mode, but it is not usable in that mode as the task bar and borders are visible, so no good for watching films or TV.

Is full screen windowed mode possible?


#25

Should I start a new thread about full screen windowed mode, as I guess that is where we are now, as getting the volume overlay to show is now solved?


#26

We could consider external mixer control as a feature request, but honestly I don't see the point. You could probably configure windows (or as last fallback use some third party software) to display a volume overlay when the volume is changed. I don't think normal applications should even mess with the global volume control.


#27

Hi @vlang . I do have windows configured to show an overlay when the global windows volume is changed, but Plex Media Player hides it. Is it possible that I could run PMP in windowed full screen mode so that the windows volume overlay shows over the top of it?


#28

Monday bump!


#29

Does no reply mean that it is not possible to run Plex Media Player in a full screen windowed mode, or does it mean that no-one has had a chance to read my post yet? Thanks!


#30

vlang's first reply back in the thread outlines that you can switch from windowed/full screen via shift + f11, but you won't be able to have the windowed mode behave like full screen and block out the dock/window borders--that's what full screen mode is designed for.

I really think this boils down to the IR remote sending a key command that Plex doesn't recognize as the volume up down command (especially since you can get the overlay to appear using the +/- on your keyboard). Creating a custom inputmap should fix this as it will force Plex to recognize the remote's volume keypresses as such. Another less tech-involved option is to buy a FLIRC and try with that. That more or less creates a custom inputmap of its own via a GUI-driven process. I got one to allow me to use my aluminum Apple remote with my HTPC and it works well.


#31

Hi @onekmilesbehind thanks for the reply.

As you say F11 doesn't help as that gives a windowed mode with borders. What I need is a full screen windowed mode, without borders. There is the option for this in Plex Home Theatre. I need it in Plex Media Player as this would allow for the global windows volume slider to be visible.

A flirc or custom input map would not help as that would just bring the plex volume overlay up, I can do that now using the + and - keys on the keyboard.

The problem is that plex will only trim ( reduce) the volume from whatever it is set at in windows. If I leave the windows volume at max and just trim it in plex, external audio such as notifications and audio from other software on the PC will be so loud it could damage the speakers.


#32

Does enabling exclusive mode in the audio settings help at all (in addition to manually setting the output device)? That should block other apps from putting out audio (theoretically).

If not, you can post the PHT-esque window mode and the external mixer support as feature requests, though your mileage may vary on response time. Plex has really locked down the UI of late. Since this isn't a bug, changing the behavior is better categorized as a feature request and so is subject to Plex weighing whether or not the request fits in with their overall vision of PMP.


#33

No, exclusive mode doesn't help. Still too risky as I use the PC for other things other than Plex.

How does everyone else manage, do you leave the global windows volume at 100% and have very loud audio outside of Plex?

Thanks - how do I post a feature request?


#34

I have my PC connected via HDMI to my receiver that decodes all the audio and I have only ever adjusted volume on the receiver itself. I had to dig into the Windows sound settings to figure out where my global volume was set (56). Sorry I haven't been able to help with this, our A/V setups and usage are different enough where I don't run into the issue you're having, but see why it's frustrating.

There is a PlexPass-only sub-forum for feature requests, but be sure to search that forum to see if your request exists already. There's a thread on the rules for that sub-forum here.