Issue where when opening app back up is stuck on last show/movie and won't go back to home screen.

apple-tv

#1

I have been having this issue on all of my apple tv devices. I have to completely restart the apple tv to get it to go back to the library. Any idea what is causing the issue and how to resolve it?


#2

I’ve been having the same issue.

Re-installing the app works for a short while; then the issue re-appears. Force-quitting the app also works temporarily as does restarting the Apple TV.

Is this a problem from the server end or from the Apple TV application? I’ve tried restarting the Plex Media Server service but it doesn’t seem to help.


#3

I’m having the same issue with Plex, on my Apple TV. Definitely seems to be the app. When it gets stuck…I’ve switch over to my roku and it’s working fine. It’s annoying. So far, this is the only discussion I’ve seen about the issue. Glad it’s not just me!


#4

Same issue here, annoys the hell out of me. Force close fixes it until next time it happens


#5

Same issue here. It’s incredibly frustrating, seems to be happening more and more often.

It’s like the navigation stack is messed up. Sometimes it’s not always the last thing I watched but something else I watched recently. I’ll hit home a few times and it’ll go back up the stack (Episode -> Season -> Show -> Library) but instead of exiting to Home Screen on what I’d expect to be the final post it shows a recent episode of something I watched and then it’ll be stuck on that.


#6

I’m also seeing this issue happen more often. I would like to see if there are any similarities in our environments and perhaps get the attention of someone from the Plex team.

Before encountering this issue, my Plex server used to run on Windows 10 - this issue was not experienced in this environment. I migrated to a new server machine where I installed Ubuntu 16.04. This was about a month ago. The version of Plex media server that I’m running is Version 1.12.0.4829. The hard drives where all the media is stored are NTFS formatted drives (coming from Windows originally).

As part of the migration I restored my Windows installation’s database file so that I could retain my watch history. I followed various guides on the internet to complete this. This appeared to have worked as I was able to continue watching from where I left off on both Movies and TV Shows. Soon after this migration I encountered the issue we’re describing.

I’ve gone as far as attempting a complete re-install of the Plex media server (on ubuntu) and rebuilding the media library from scratch. My watch history I restored by using the Trakt plugin. I again encountered this issue.

I can attach my server logs if that will help. Are there any logs of the Apple TV application that can be uploaded as well?

The issue doesn’t always happen, but when it does these seem to be my steps to reproduce:

  1. watch a show and allow the episodes to continue to the next - I’ve usually watched around 3 episodes
  2. follow steps that neilinglis detailed (using the back/menu button on remote)
  3. observe the issue

All subsequent loading of the Apple TV app displays the last show instead of the Home screen - unless you force close the app. Restarting the server without force closing the app does not help.

I have not yet tried leaving the Apple TV on its home screen and not force closing the Plex app, but instead waiting to see if it will correct itself after some time has passed and try re-opening the app.


#7

Same issue where stuck on what ever is the last show/movie see. it got stuck on the news screen first so uninstalled it thinking it was the news app, then it got stuck on a different show. no fix with reinstalling plex server. one workaround i found is if you have two plex servers you can switch to a different server and it will work till you try to switch back to home screen, then instead of going to home screen it goes to the stuck screen.


#8

Having the exact same issue on my Apple TV 4K 64GB. Just have come to accept that I need to restart the Apple TV to clear the problem.

Is there an official way to raise such issues with Plex?


#9

@neilcford said:
Having the exact same issue on my Apple TV 4K 64GB. Just have come to accept that I need to restart the Apple TV to clear the problem.

Just force close the app, no need to restart Apple TV.


#10

I have this issue as well. When my Apple TV wakes from sleep, Plex seems to be stuck showing the title screen of the episode I last watched.

Returning to the Plex home screen is impossible. Swiping left and selecting “Home” does not work. Pressing “Menu” to go to previous screen just throws me back to the Apple TV home screen.

Only workaround is to force-close the app. It has been this way for months.


#11

I also have this problem. Frequently.


#12

Same issue. Will not go back to “working” Plex menu. Have to restart the Apple4. Quite annoying. It is not a problem if I “only” use Plex and not any other program. If I exit PLEX and then re-enter Plex the menu no longer works. Can’t use home, or most other buttons. Works fine on the Roku. Hopefully it is being worked on :slight_smile:


#13

FYI, you can kill the app by swiping up while in app switching mode. No need to do a complete restart. That’s always worked for me.


#14

@nookum said:
FYI, you can kill the app by swiping up while in app switching mode. No need to do a complete restart. That’s always worked for me.

Works for me too. But it’s a pain I have to do it 2 maybe 3 times a week. Glad to hear I’m not the only one having issues on this part. If a dev needs some logs I’m happy to serve.


#15

Same f-ing problem here.


#16

I’m also having this problem. Glad I’m not going crazy, though I don’t get how it’s been going on this long with no response?


#17

Regularly having this problem for months now–almost certain it only occurs when waking from sleep. It always sticks on a specific show episode or movie. Won’t play, go to show season, or return to the main menu. Has occurred with Plex Server running on macOS 10.13.3 and over the last couple of tvOS updates on my 4th Gen. AppleTV also.


#18

I have same issue. Must restart every time.


#19

Same issue here. (Among other annoying issues since the update)

If you have access to more than one Plex server, you can just switch to another one and then back and that refreshes the connection.


#20

I’m having the exact same issue. Apple TV4 connected to Plex server on my Synology. Worked flawless until the last couple of weeks. Good to hear that I am not alone with this problem, so Plex will hopefully fix the pronblem soon.