Issues with subtitle plugins

plex-for-kodi

#1

Hi,

I'm encountering issues with downloading/listing subtitles to download, when using the Plex addon. I use autosubs to automatically open the 'download subtitles' dialog when playing a movie (so that friends who are clueless about how to acquire subtitles can have an easy method to fetch them). I have the language settings and character set working fine in Kodi.

To test, I have imported the same movie in Plex, and In Kodi (without the Plex addon).

  1. When playing using Kodi directly (without the Plex addon), the download subtitles dialog opens fine, shows me the movie filename accurately, and subtitles show up, and can be downloaded without issues.

  2. When playing through the Plex addon, the download subtitles dialog opens fine, but the movie filename is shown as 'file.mp4', and subtitles do not show up to be downloaded ('no subtitles found')

This is what the kodi log shows - let me know if more detail is needed. I have tried below with wizdom subs, but also tried with bsplayer subs addon and have the same issue.

11:02:46.577 T:123145432473600 DEBUG: ##**## [Wizdom Subs] Version:1.0.1
11:02:46.577 T:123145432473600 DEBUG: ##**## [Wizdom Subs] Action:search
11:02:46.577 T:123145432473600 DEBUG: ##**## [Wizdom Subs] isPlaying:1
11:02:46.577 T:123145432473600 DEBUG: ##**## [Wizdom Subs] item:{'file_original_path': u'file', 'season': 0, 'title': 'Correct Movie Title, 'episode': 0, 'year': '2017'}

The plex logs dont mention wizdom subs or bsplayer at all.


#2

PS: The issue seems to be with the fact that the filename when played with Plex addon for Kodi is different from the actual filename (visible when playing with Kodi directly). Is anybody else facing this issue? Tried with wizdomsubs, supersubs, and bsplayer subtitle addons…