Known limitations to transfer speeds via ethernet on LG B7 (aka 2017 models)?

smart-tv

#1

I just recently got a new LG B7 because the prices have collapsed, and the Plex app works on it very nearly perfectly.

Anything under 4K is fine, absolutely no problems. couldn't be happier.

And 4K very nearly works perfectly too. HDR loads up fine, looks gorgeous, video plays smoothly as opposed to VLC 3.0 as an example... But then it stops for a moment to buffer. Sometimes I get lucky and got 10 minutes of uninterrupted watching, most of the time more like 30 seconds, if that. The fact that it's totally smooth when it's running and how only the high end 4K HDR stuff is suffering suggests to me that it's not an issue of grunt on the TV's part, but just interruptions or limitations in the datafeed.

Keeping an eye on my network traffic when streaming shows that I'm only getting between 4 and 9-10 MBytes/second, mostly in the 6-8 region. While this theoretically should be enough for a lot of the stuff I'm watching (between 40-50 Mbps, 5-6 MB/s), it's weird that it doesn't ever reach higher speeds. My PC (the server), my TV and my Xbox One are all connected to the same router via ethernet cables, and when moving stuff between my PC and the Xbox One I get 70-80 MBytes per second, so at least I know that my PC can transfer faster, and that the router is fast enough also.

So it definitely feels like there's a limitation somewhere in the system. Is the TV's wired network connection that slow? Is the Plex server or app not able to use the full bandwidth available? Or could it be that the TV doesn't use a decently sized buffer, and would that be a limitation imposed by the TV or an app setting? Honestly, I'd be happy to wait for a few minutes while the app downloads a gigabyte into the buffer if that meant watching the rest of the film without interruptions.

FWIW out of interest I also tried the unofficial XPlay app, and the performance there was more or less identical, so it kind of seems like either a TV, app buffer size or server limitation.

If I could just get an interruption free 4K streaming experience (like I said the video looks gorgeous and is completely smooth when it's working) the app would be utterly perfect for me. HDR on Windows is such a non-functional hassle that streaming is pretty much the only way to actually get a usable experience.

Aside from that the app is working perfectly thus far, so good job on that already! Very close to the finish line. =)


#2

A quick update: It's beginning to seem like either a PMS or app limitation, because I just found out that LG has their own SmartShare app, which can handle streaming the same files perfectly, haven't had a single interruption yet.

Of course I'd much rather not use yet another data sharing software, but what can's ya do?


#3

@jubuttib said:
A quick update: It's beginning to seem like either a PMS or app limitation, because I just found out that LG has their own SmartShare app, which can handle streaming the same files perfectly, haven't had a single interruption yet.

Of course I'd much rather not use yet another data sharing software, but what can's ya do?

A couple things to look at on this issue. Your settings on Plex client app, have your set the Video Quality to "Original"?

In PMS settings , go to "Status" /now playing when streaming a HDR file and see if it is trans coding or Direct Playing.

The smartshare app works well but the UI is pretty awful compared to Plex


#4

It's definitely direct playing, I've noticed that HDR doesn't get triggered when it's transcoding, and the CPU idling is a pretty clear giveaway too. Video Quality is set to original too, yeah.

I'm testing it now with PMS in DLNA mode and it's starting to feel like an odd server limitation. The SmartShare program works via DLNA, and since that worked so well I thought I'd try Plex via that too. The results currently are that the playback is still interrupted periodically, just like with the Plex app, but the stoppages are shorter, playback continues quicker. So DLNA via Plex is an improvement, but not a solution.


#5

I have been looking at your Tv spec sheet and found this Cnet article on the subject. This maybe the issue..

https://www.cnet.com/news/hdr10-vs-dolby-vision-vs-hlg-how-do-hdr-formats-compare/


#6

Eh? As far as I can tell that is an article comparing different aspects of DV, HDR10 and HLG standards, of which the B7 supports HDR10 and DV, and has nothing to do with streaming and/or buffering issues? HDR works just fine when Direct Playing, which is also working fine. The issue is the app stopping and buffering every now and then, which happens when using both the Plex app, the Xplay app and playing content from the PMS via DLNA, but does not happen when using SmartShare via DLNA. That it's a consistent issue whenever I'm working through PMS, but not an issue when using another server system, makes me think it's something in the PMS at this point, or at least the communication between the TV and the PMS. If there's anything I can do to help pinpoint what's happening I'm happy to help.

This is definitely not to bash on Plex. I've been using and loving Plex for years, it's one of my favorite pieces of software, an astoundingly good bit of kit. This is really the first time I've had issues playing anything with Plex, and I fully trust that they can sort it out eventually.

If LG can make their SmartShare work without interruptions when playing this content, the people working at Plex definitely can too, I have full faith in them. =)


#7

Oh, and if you were referring to the "I've noticed that HDR doesn't get triggered when it's transcoding", I think that's likely just a limitation of the transcoder? From what I understand currently there aren't too many programs that manage to maintain the HDR metadata when transcoding, and I wouldn't expect Plex to support that yet either. What I meant when I said that was that "I know it's Direct Playing, because I can see HDR is triggered and my CPU isn't doing anything". =)


#8

Have you found a solution to this? I'm facing the exact same issue. There's no bottleneck I can pinpoint, and I deducted the same... if the TV had a little bigger buffer, it should have no issues.... although as the TV can do 100 Mbit/s (not the greatest nowadays, but shall be plenty, tested over eth), it should have no issues. As you said, only at certain high bitrate parts do I get the short buffering a few times, otherwise all good. I can even reproduce it by rewinding to the same scene.


#9

Same exact issue here. Seems like a bitrate issue for me too. I can get lower bitrate 4k to play without buffering but most of buffers pretty frequently. Anyone know why this is happening or know of a fix? jubuttib - did you find a solution?


#10

I noticed the same thing. 50Mbit 4k files start to buffer. i guess since it VBR, sometimes it shots up to 80-100 for a few seconds, and the buffer must be really small, so it's buffering for 1-2sec.
it's kinda annoying. They webos app is decent, but it will never be perfect, so i must look for a hdr 4k standalone linux box with decent plex software.