Lagging with the new Plex for Android release!



OK, I've been running Plex for Android for some months now streaming videos to my Chromecast. I've been using the "8Mbps 1080p" setting for video and it's been working great for all my HD movies.

Now with the latest release of Plex, on July 17:th, it is all stuttering and lagging!!! No settings changed what so ever! First I thought it was a problem with my phone since it was working well when I used my pad, but then I noticed that I hadn't updated the version on the pad. Now it's updated and it's the same crap with both units!

What has happened? Anyone else with the same problem? If I reduce the video quality to "4 Mbps 720p" it's all good, but who would want to do that? And why did it work before!!!??? Getting frustrated here!


what happens if you leave it on the "original" setting (maybe that is what you meant)? is this only when streaming to chromecast or playing on the device itself? is the media transcoding or direct play? can you post the media info xml of one the videos so we can test with something similar.


I'm a bit confused at the moment. I thought it was caused by the app update but now when I stream directly from the computer using Google Chrome I experience the same thing. This has worked perfectly before. Maybe the server has updated itself but that has always been a manual procedure before. I have gone through all the settings and I can't find anything different from before.

This is getting me nowhere. I will try to find some log files tomorrow to show you guys. It's bedtime in Sweden and I hate Chromecast too much right now. I will try again tomorrow if it still works after being thrown in the wall half an hour ago! Why only wireless, Google? WHY!!!!!?? I hate you... Good night....


Google makes a ethernet adapter/power cord for for chromecast now which i think is selling out quick ( i dont have one and I have no idea how well it might work) for some reason i cant find in when navigating to accessories on but here is link


-- Removed --


Ok, it's lagging again. And my transfer rate is ok when I check it. Something has happened that I can't explain and I'm done using Chromecast/Plex as my choice of streaming movies. It just does not work anymore. This is pretty painful since I've set up all my shit to run movies this way and now it doesn't work anymore. I'm more than frustrated. Guess I'm going back to using my old Playstation 3 as a media server. I've had it!


I have exactly the same problem since the android update, on my ipad (old version) works perfect with the higher 1080 option, with my android phone chromecast only move the 720.


is this only when casting to chromecast or when playing on the device itself?

can you show the media info for one of the file doing this and the server log covering the start of playback for the item


For me it's only when using Chromecast. I really think it's a WLAN-capacity problem but the question is why did it all of a sudden become a problem when I have made no changes what so ever to my configuration except updating Plex on my Android units?

It's like Plex now is sending a higher quality stream than it did before (although my setting has always been 8Mbit 1080p). I have done some testing around with the most problematic movie in my library, "Alvin and the Chipmunks 2" from my kids list. I have been forced to lower the bitrate to around 5 mbit/s to make it run smooth again. My kid doesn't mind but it's just irritating when it worked fine before!

I will dig up some log files when I find out where they are. I'm running a Ubuntu machine as server and I'm kinda new to that OS.


Hmmm. There's not a new file for each movie you start. It continues to build up the existing one leaving you with a massive textfile. Guess a restart of the server creates a new file.

I'm attaching a big one since I played around yesterday and found that the movie "Pain and gain" was lagging in scenes with a lot of details and movements. A quick search for "pain" in the log file gives some information. I find that the server is automatically reducing the bitrate to 8, just as it should. And the server has no capacity problems with converting as far as I can see. Maybe someone can find something else that might be troublesome. But I guess the logfile doesn't contain any information on network capacity problems. But as I said before, it's strange that it worked fine before...


When I test my wlan speed on my laptop by tranferring a big file through it, I get a speed of 6 Mb/s = 48mbit/s. This is at the same location as the Chromecast. This tells me that a movie streaming on 8 mbit/s should be NO problem whatsoever. Is the Chromecast reciever that bad? I can't find a bottleneck anywhere in my config!


Only thing I notice in the log are some of these:

Jul 22, 2015 23:51:50 [0x7fedb37ff700] ERROR - handle_stream_read error 104 Connection reset by peer

I recall that is an error pointing towards a network problem. I could be mistaken though, maybe a Plex Ninja can shine some more light on your issue.


I'm having the same problem. Happened with this new update with it's quality switching for chromecast.

Bump for visibility and a hopeful fix.


Nice to hear from more people having trouble with this. This must be a result from Plex now streaming with higher quality. This cold easily be fixed by providing some more alternatives considering quality. The lowest bitrate for 1080p is 8 Mbit. How about a 4 or 5 Mbit alternative!?


Same issue here, has been working just fine for months and now with latest android update it's laggy then not laggy then lags a few seconds again then works for quite some time.. repeat the process.


I'm having the same problem. All has worked well for months now, but after the latets update to the Plex Android app, my video's have begun stuttering both in picture and sound. If I use the iOS app on a iPad 3 og iPhone 5C and cast to the Chromecast, all my video's and movies plays as they should. But use my Nexus 5 or Google Chrome on Windows 7/8.1 and cast to the Chromecast, the stuttering returns.


I'm getting the exact same problem here. I have been using plex with chromecast for nearly 6 months now without issues but now when I try and use chromecast via the android app all my videos stutter. I have streamed high bitrate videos with chromecast before but now even if I choose something low like 720p it still stutters. Definitely not network congestion or a chromecast issue as my wifi has never had issues with an 8mbit stream or higher before. Would love a fix or solution for this as my entire media collection is inside Plex and I use Chromecast to access it.


On your android device what is the Profile limit set to? this will be in Setting.Advanced>Player>H264 Maximum Level

Can you change it to 4.1 if it is not and try again


Mine (Nexus 5) is set to 4.0 and the app warns me with this message "You have selected a maximum H264 Leves which exceeds the value reported by your device. This is likely to lead to playback issues, varying from artifacts to stuttering. Are you sure you want to do this?"

Isn't all the above the problems we are having? I mean after this H264 option was emplemented, our problems started occurring. This option is not available in the iOS app, so maybe its the culprit?


Hmmm. My Samsung Galaxy 6 was set to 4.2. I lowered it to 4.1 and tried to play a movie I've been having issues with. It played fine but I have some more movies to try before I'm satisfied. But this might, just might, be it.

I think I have read somewhere that Chromecast supports H264 4.1. I thought that this setting was only for playback on the phone but it seems like this setting is overriding the server setting (which is 4.1). Lots of "settings" there :)

Will experiment some more when I come home from work!